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Introduction 

License Agreement 
HIGHWAY CAPACITY SOFTWARE™ (HCS™)  
END-USER LICENSE AGREEMENT (EULA) 
 
Effective Date: 9/1/2025 
 
 
Copyright © 2025 University of Florida. All rights reserved. 
 
This End User License Agreement (“Agreement”) is a legal agreement between you (“End User”, “you”) 
and the University of Florida Board of Trustees for the benefit of the McTrans Center (“McTrans”, ”we”) 
regarding the use of the Highway Capacity Software (“Software”). By accessing or using the Software 
programs within the electronically transmitted package or direct download, you agree to be bound by the 
terms and conditions of this Agreement.  
 
 
1. INTEGRATION: 
This License Agreement is the complete and exclusive statement of the agreement between End User 
and McTrans and supersedes any previous End User License Agreements distributed by older versions 
of the software proposal or prior agreement, oral or written, and any other communications between End 
User and McTrans relating to the subject matter of this License Agreement. This EULA will supersede the 
End User License Agreement contained in the HCS Version 5, 6, and 7 modules disseminated as part of 
the Software. This License Agreement may only be modified by a written agreement made subsequent to 
the date hereof and signed by both parties. 
 
 
2. LICENSE GRANT: 
2.1 Subscription-Based License: 
McTrans grants you a non-exclusive, non-transferable license to access and use the Software, subject to 
the terms of your active subscription. The license is valid only for the duration of your subscription and is 
contingent upon full payment of all applicable fees. 
 
2.2 Access to Software Versions:  
Your subscription grants access to versions 5 (selected modules), 6 (selected modules), 7 and 8 series 
and beyond (2022 onward) of the Software. When a new version of the Software is released, the End 
User with an active subscription can download and access the latest version at no additional cost for the 
remainder of their subscription term. 
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3. TYPES OF SUBSCRIPTIONS: 
The type of subscription determines the permitted use of the Software. Once a subscription type is 
selected, it cannot be changed or exchanged for a different type. 
 
3.1 Office-Based Subscription: 
This subscription grants access to the Software for a predetermined number of computers within a 
physical office. An "office" refers exclusively to a fixed geographical location, typically a single physical 
address, where an organization conducts its business or operational activities. This location must consist 
of one or more contiguous rooms or spaces within a single building. Virtual offices or any non-physical 
locations are excluded from this definition. 
 
The Software may be installed on multiple devices within the office, and access is restricted to end users 
officially assigned to that licensed office. End Users may also use the Software on portable computers, 
such as laptops, while on official travel, provided that all (100%) such use is exclusively on behalf of the 
office for which this Software license was purchased. Additional offices must obtain proper licensing prior 
to accessing the Software. The Software may only be installed on devices owned or controlled by the 
licensed office. 
 
This subscription is intended exclusively for commercial use. 
 
Virtualization Restriction:  
The Software under an office-based subscription is prohibited from being used in a virtualized 
environment. All installations of the Software must be conducted on a physical computer, such as a 
desktop or laptop. Remote access technologies, such as remote desktop, are strictly prohibited under this 
subscription type. 
 
3.2 Computer-Based Subscription: 
This subscription permits the installation and use of the Software on a specified number of individual 
devices. An "individual device" refers to a single, standalone computing unit, such as a desktop or laptop, 
intended for use by a single user at a time. Concurrent or simultaneous access by multiple users on the 
same computer or through any means of remote connection is strictly prohibited. The Software may only 
be accessed directly from the device(s) on which it is installed, regardless of whether the device is 
located in a physical office or used in a virtual office. End users working remotely or in virtual offices must 
ensure that the device remains dedicated to their use and fully complies with the terms of this 
subscription. 
 
Virtualization Restriction:  
The Software under a computer-based subscription is prohibited from being used in a virtualized 
environment. All installations must be conducted on a physical computer, such as a desktop, PC, or 
laptop. Remote access to the Software via any technology, including but not limited to remote desktop, is 
strictly prohibited under this subscription type. 
 
3.3 Volume-Based Subscription: 
This subscription permits the installation and use of the Software on a specified number of individual 
devices. An "individual device" refers to a single, standalone computing unit, such as a desktop or laptop, 
intended for use by a single user at a time. Concurrent or simultaneous access by multiple users on the 
same computer or through any means of remote connection is strictly prohibited. The Software may only 
be accessed directly from the device(s) on which it is installed, regardless of whether the device is 
located in a physical office or used in a virtual office. End users working remotely or in virtual offices must 
ensure that the device remains dedicated to their use and fully complies with the terms of this 
subscription. 
 
Virtualization Restriction:  
The Software under a Volume-based subscription is prohibited from being used in a virtualized 
environment. All installations must be conducted on a physical computer, such as a desktop, PC, or 



Warrants User Guide Introduction  3 

laptop. Remote access to the Software via any technology, including but not limited to remote desktop, is 
strictly prohibited under this subscription type. 
 
3.4 Academic Subscription: 
The academic subscription is available exclusively to academic institutions and grants access to a 
specified number of seats (copies) across the entire academic institution. This subscription is intended 
solely for use in a classroom setting for teaching or a lab for research purposes under the direct 
supervision of faculty or other authorized personnel. The Software may only be installed on devices 
owned or controlled by the academic institution. 
 
The End User is required to implement appropriate protection measures to prevent students or any other 
individuals from copying the Software and removing it from the lab or classroom environment. The 
responsibility for safeguarding the Software and preventing unauthorized copying or distribution rests 
entirely with the End User. 
 
Virtualization for Virtual Classrooms:  
Under the academic license, the End User may request permission to utilize a virtual environment for the 
installation and use of the Software. Such virtualization is only permitted with prior written consent from 
McTrans. If such permission is granted, the virtual environment must adhere to all protections and 
restrictions outlined in this Agreement, ensuring that the Software is used exclusively for its intended 
educational purposes and its access is limited to the institution's faculty and actively enrolled students 
only. Additionally, the number of seats purchased must be sufficient to cover the number of students and 
faculty accessing the virtual classroom. 
 
 
4. SUBSCRIPTION TERM: 
4.1 Duration: 
The subscription term begins on the date of purchase and continues for the period specified at the time of 
purchase ("Subscription Term"). The license granted under this Agreement is valid only for the duration of 
the Subscription Term. 
 
4.2 Renewal: 
Subscriptions may be renewed upon payment of applicable fees before the end of the Subscription Term. 
If the subscription is not renewed, access to the Software and all related services, including technical 
support, will be terminated. 
 
 
5. TECHNICAL SUPPORT: 
5.1 Support Services: 
During the active Subscription Term, the End User is entitled to reasonable telephone or email support 
provided during the normal business hours of McTrans. McTrans reserves the right to determine the 
extent of the support provided. 
 
5.2 Revisions and Enhancements: 
McTrans reserves the right to make substantial revisions and enhancements to the Software and to 
market such substantially revised versions as separate products. The End User shall not be entitled to 
receive such separate products without additional charge. Upon the release of any such revised version 
of the Software, the obligation to provide the above-described technical support services to the End User 
shall cease unless the End User chooses to pay to license the enhanced version of the Software, 
regardless of whether the End User has previously requested or received support on the prior version. 
 
 
6. NETWORK USE: 
The End User is strictly prohibited from using the Software on any network. This prohibition includes but is 
not limited to the use of the Software either directly or indirectly through commands, data, or instructions 
transmitted to or from a computer that is not licensed or is not part of the licensed internal network. This 
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also includes any use for Internet or web hosting services or by any user who does not hold a valid 
license for the Software from McTrans. 
  
The Software is not designed for network use, and such use is unsupported. McTrans will not provide 
technical support for any issues resulting from network incompatibilities or unauthorized network use. 
 
 
7. RESTRICTIONS ON USE: 
The End User agrees that they shall not, nor shall they permit any third party to: 

● Software Modification: Modify, adapt, translate, or create derivative works based on the Software, 
in whole or in part, without the express prior written consent of McTrans. 

● Reverse Engineering: Reverse engineer, decompile, disassemble, or otherwise attempt to derive 
the source code of the Software, except to the extent expressly permitted by applicable law. 

● Unauthorized Use: Use the Software for any purpose other than as expressly permitted under this 
Agreement, including unauthorized copying, distribution, or dissemination of the Software. 

● Intellectual Property Infringement: Engage in any activity that infringes on the intellectual property 
rights of McTrans, including any unauthorized copying or distribution of the Software or 
associated documentation. 

● Copying and Distribution: Copy, reproduce, or distribute the Software or associated printed 
documentation for sale, distribution, or dissemination, except as expressly provided under the 
terms of this Agreement or with the express prior written consent of McTrans. 

● Documentation Use: Reproduce the associated documentation only as necessary for use within 
the permitted scope of the subscription type as outlined in this Agreement. 

● AI Training and LLMS Restriction: The End User agrees not to use the Software to train or 
develop any artificial intelligence (AI) model or large language model system (LLMS) without the 
express prior written consent of McTrans. This includes, but is not limited to, using the Software 
to generate or fine-tune AI models, create or modify LLMS, or use the Software as a data source 
for AI or LLMS training. Any attempts to do so will be considered a material breach of this 
Agreement and may result in termination of the license. 

 
Ownership of Software Modifications:  
Any modifications, adaptations, translations, derivative works, or any other products or materials resulting 
from any prohibited actions shall become the exclusive property of McTrans, regardless of whether such 
actions were performed with or without McTrans’ consent. 
 
 
8. INTELLECTUAL PROPERTY RIGHTS: 
The Software and all associated intellectual property rights are owned by McTrans. No rights are granted 
to the End User other than the limited license expressly set forth in this Agreement. 
 
 
9. USE OF RESULTS IN RESEARCH AND COMMERCIAL PUBLICATIONS: 
McTrans grants the End User legal permission to use the results generated by the Software in academic, 
research, or commercial publications, provided that such use complies with the terms of this agreement. 
The End User may publish or present findings derived from the Software as part of their research or 
commercial work as long as the Software is properly cited and all applicable license terms and restrictions 
are adhered to. Unauthorized reproduction or distribution of the Software itself remains strictly prohibited. 
 
 
10. TRANSFER OF LICENSE AND DEACTIVATION RESTRICTIONS:  
The Software is licensed only to the End User, and this License Agreement may not be assigned or 
transferred to anyone without McTrans’ prior written consent. Any authorized transferee of this License 
Agreement shall be bound by the terms of this License Agreement. The End User may not transfer, 
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assign, rent, lease, sell, or otherwise dispose of the Software except as expressly provided in this License 
Agreement. 
 
Deactivation requests are granted on a limited basis, such as hardware failure, device replacement or 
upgrade, reassignment of equipment, etc. To request deactivation, please email mctrans@ce.ufl.edu with 
a brief reason for your request and include the name of the computer or the machine you wish to 
deactivate. McTrans will then provide you with instructions on how to deactivate a license so you can use 
it on a different machine.  
 
 
11. LIMITED WARRANTY AND LIMITATIONS OF REMEDIES: 
End User acknowledges and agrees that it is the sole responsibility of End User to fully understand the 
limitations and assumptions underlying the Software and to refrain from using the Software without the 
assistance of personnel with appropriate expertise. The End User accepts full responsibility for reviewing, 
interpreting, applying, and utilizing the output of the Software and for ensuring that such output complies 
with any applicable design codes, standards, or project specifications. 
 
Except as expressly provided herein, the Software is provided “AS IS” without warranty of any kind, 
whether expressed or implied, including, but not limited to, implied warranties of merchantability and 
fitness for a particular purpose. McTrans does not warrant that the functions contained in the Software will 
meet the End User’s requirements or that the operation of the Software will be uninterrupted or error-free. 
The entire risk as to the quality and performance of the product is with the End User.  
 
In no event will McTrans be liable to the End User for any damages, including any lost profits, lost 
savings, or other incidental or consequential damages arising out of the use of or inability to use the 
Software, even if McTrans has been advised of the possibility of such damages, or for any claim by any 
other party. The above warranty gives the End User specific legal rights, and the End User may also have 
other rights in the United States, which vary from state to state.  
 
Use of the Software where the End User believes or has reason to believe that damage may occur 
constitutes a violation of any and all warranties. McTrans has no knowledge of the hardware or Software 
configurations of the End User and assumes no liability for their damage. 
 
 
12. TERMINATION: 
12.1 Termination by McTrans: 
McTrans may terminate this Agreement immediately upon notice if you fail to comply with any term or 
condition of this Agreement. Upon termination, you must cease all use of the Software and destroy all 
copies of the Software in your possession. 
 
12.2 Termination by End User: 
You may terminate this Agreement at any time by discontinuing the use of the Software and notifying 
McTrans. No refunds will be provided for any remaining portion of the Subscription Term. 
 
 
13. GOVERNING LAW: 
This License Agreement shall be governed by the laws of the State of Florida, U.S.A. Venue for all 
disputes related to this License Agreement shall be in the United States District Court of the Northern 
District of Florida, Gainesville Division, or in the Circuit Court of the Eighth Judicial Circuit for Alachua 
County, Florida. 
 
 
14. U.S. GOVERNMENT RESTRICTED RIGHTS: 
The Software and associated documentation are provided with RESTRICTED RIGHTS. Use, duplication, 
or disclosure by the U.S. Government is subject to restrictions as set forth in subdivision (c)(1)(ii) of The 
Rights in Technical Data and Computer Software clause at 52.227-7013 or subparagraphs (c)(1) and (2) 
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of the Commercial Computer Software - Restricted Rights at 48CFR52.227-19. The contractor is 
McTrans, University of Florida, PO Box 116585, Gainesville, FL 32611-6585. 
 
 
15. EXPORT REGULATION: 
The Software may be subject to U.S. export control laws and regulations, including the U.S. Export 
Control Reform Act and its associated regulations. End User will not directly or indirectly export, re-export, 
transfer, or release the Software to, or make the Software accessible from, any country, jurisdiction, or 
person to which export, re-export, transfer, or release is prohibited by applicable U.S. laws and 
regulations. End User will comply with all applicable laws and regulations and complete all required 
undertakings (including obtaining any necessary export license or other governmental approval) prior to 
exporting, re-exporting, transferring, or releasing, or otherwise making the Software available, outside the 
U.S. End User shall not export, re-export, transfer, or release the software or software source code to any 
country which is comprehensively sanctioned by the U.S. Department of the Treasury, Office of Foreign 
Assets Control (OFAC). 
 
 
16. SEVERABILITY:  
If any portion of this License Agreement shall be declared void or a nullity by a court of competent 
jurisdiction, then the remainder shall survive and remain in full force. Should you have any questions 
concerning this license, you may contact the McTrans Center, University of Florida, PO Box 116585, 
Gainesville, FL 32611-6585, U.S.A., [1] (800) 226-1013. 
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Getting Started 

System Requirements 
HCS is designed for standard Windows installations. For optimal performance, the system should be 
Windows 10 or newer. While HCS may be compatible with older versions of Windows, any installation 
and operational issues arising from using these older versions will be the sole responsibility of the end 
user. 

Getting Started 
To begin, click on File then New (or "New File" from the Start screen). Normal Windows keyboard and 
mouse functions are available. In Full View, the PgUp and PgDn keys will scroll the entry screen up and 
down respectively. Tabbing or clicking to a new field, or pressing the Enter key, will trigger a recalculation 
and update the Report pane in Full View. 
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General Controls 

Menu Items 
New – Creates a new Warrants file (*.xsw) and starts a new analysis project; shortcut is Ctrl+N 

Open – Opens an existing Warrants file (*.xhy, *.xsw); shortcut is Ctrl+O 

Example Folder – Opens folder with all HCS examples in File Explorer 

Save – Saves an open Warrants file (*.xsw) using the current file name; shortcut is Ctrl+S 

Save As… – Saves an open Warrants file (*.xsw) using a specified file name; shortcut is F12 

Close – Closes an existing Warrants file (*.xsw); shortcut is Ctrl+W 

Units 

 USC Units – Changes the units of the current file to U.S. Customary 

 Metric Units – Changes the units of the current file to Metric 

MUTCD Method 

 MUTCD 11 (2023) – Runs the procedures from the 11th Edition MUTCD 

 MUTCD 2009 – Runs the procedures from the 2009 MUTCD  

Print – Brings up printer selection and prints a Warrants report to the printer or specified file type; shortcut 
is Ctrl+P 

Print Preview – Displays preview of current report before printing; shortcut is Ctrl+F2 

View 

 Page View – Changes the view to display inputs and reports by pages; shortcut is F9 

 Full View 

 Report -> Right – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the right portion of the screen; shortcut is F10 

 Report -> Bottom – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the bottom portion of the screen; shortcut is 
F11 

Report 

 Formatted Report – Displays formatted report including the most important values; shortcut is F4 

 Text Report – Displays text report with all input, intermediary, and final results; shortcut is F6 
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Default Settings – Opens dialog box for the user to input defaults for Analyst, Agency, and Jurisdiction 
which will be applied to all new files; also allows selection of USC or SI units, which will be applied to all 
new files; shortcut is Alt+F 

Help 

Contents – Provides access to glossary, acknowledgements, copyrights, and information on the 
MUTCD Chapter 4C procedure; shortcut is Ctrl+F1 

Index – Allows user to search for keywords within the glossary 

Search – Allows user to search for any word within the glossary 

User Guide – Opens a comprehensive user guide in PDF format; shortcut is Ctrl+G 

HCM Reference Guide – Opens the McTrans website in the default web browser to request 
access to a reference guide for the HCM in PDF format 

HCM Volume 4 Website – Opens the Highway Capacity Manual Volume 4 website in the default 
web browser to access the free online resource 

HCS Updates – Sends the HCS version number anonymously without any personally identifiable 
information to McTrans to check for a newer version 

HCM/HCS Training – Opens the McTrans Training Page in the default web browser to view the 
latest training opportunities 

HCQS Website – Opens the TRB Highway Capacity and Quality of Service Committee website in 
the default web browser 

Support 

Frequently Asked Questions – Opens the McTrans support page for HCS in the default 
web browser 

HCS Overview – Opens the McTrans HCS Overview page in the default web browser 

McTrans Website – Opens the McTrans home page in the default web browser 

E-mail McTrans – Composes a new e-mail addressed to McTrans in the default e-mail 
client with registration number, serial key, module, and version number already populated 
in the Subject field 

About HCS – Opens an about window with software version information, EULA, general 
acknowledgements, contact information, and other relevant links 

Exit – Exits the HCS Warrants module; shortcut is Alt+F4 
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Signal Warrants 

MUTCD Chapter 4C 
According to the Manual on Uniform Traffic Control Devices (MUTCD), the investigation of the need for a 
traffic control signal shall include an analysis of factors related to the existing operation and safety at the 
study location and the potential to improve these conditions, and the applicable factors contained in the 
following traffic signal warrants: 
  
Warrant 1, Eight-Hour Vehicular Volume 
Warrant 2, Four-Hour Vehicular Volume 
Warrant 3, Peak Hour 
Warrant 4, Pedestrian Volume 
Warrant 5, School Crossing 
Warrant 6, Coordinated Signal System 
Warrant 7, Crash Experience 
Warrant 8, Roadway Network 
Warrant 9, Intersection Near a Grade Crossing 
 
The satisfaction of a traffic signal warrant or warrants shall not in itself require the installation of a traffic 
control signal. 
 
The entire text of the warrant descriptions can be found at: MUTCD 

Operational Data 
GENERAL 

First, the user enters the General Information into the respective fields: Analyst, Agency, Date, and Time 
Period Analyzed, as well as site information for Jurisdiction, Analysis Year, and Project Description. 

If a School Crossing exists, the user enters the number of schoolchildren crossing an established school 
crossing during the highest crossing hour, the number of adequate gaps in the traffic stream during the 
period when the schoolchildren are using the crossing, and the number of minutes in the same period. 

For a roadway network, the user can indicate if there are two major routes, if the analysis involves a 
weekend count, and if there are 5-year projected traffic volumes. 

If a Grade Crossing exists, the user selects the Grade Crossing Approach direction and the Highest 
Volume Hour with Trains. Then the user enters the Distance to the Stop Line, Rail Traffic (trains per day), 
Percent of High Occupancy Buses, and Percent of Tractor-Trailer Trucks. 
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If the MUTCD 2009 method is selected, the user can indicate if there are adequate trials of crash 
experience alternatives and the number of crashes per year. If the MUTCD 11 (2023) method is selected, 
the user can indicate if there are adequate trials of crash experience alternatives and the number of 
crashes (i.e., angle crashes and pedestrian crashes) for a one-year period and a three-year period. 

INTERSECTION 

In this section, the user enters the geometric configurations that are to be simulated. The user selects the 
Major Street Direction and Median Type (only in the MUTCD 2009 method), enters the Starting Time 
Interval, Major Street Speed (miles per hour, or kilometers per hour in metric), and Nearest Signal (ft, or 
m in metric). There are also checkboxes for the user to indicate if the population is less than 10,000 and if 
there is a coordinated signal system. The user can set the lane configuration by adding or deleting lanes 
in the Lanes graphic. 

TRAFFIC 

Traffic Volumes (vehicles per hour) are entered for up to twelve hours, beginning at the Start Time, for the 
Minor and Major Street directions. 

PEDESTRIANS 

Pedestrians (per hour) and Gaps (acceptable per hour) are entered for the Minor and Major Street 
directions. 

DELAY 

Delay (seconds per vehicle or vehicles-hours) data are entered for the Minor Street approaches. The 
selected Delay Units will determine which fields are enabled. Entering the delay for one unit will 
automatically convert for the other unit. For example, if the fields for delay in s/veh are enabled, the fields 
for delay in veh-h will be disabled. However, once the value for s/veh is entered, the corresponding value 
in the disabled veh-hr field will update with the converted value, and vice versa. 

Results 

The results are interpreted through a multiple-page formatted report. The first provides general 
information, along with information on Geometry and Traffic, School Crossing, Roadway Network, and 
Railroad Crossing. The second details Warrants 1 through 4 (hour-by-hour as met or not), Warrant 4 
pedestrian volume (only in the MUTCD 11 method), and a summary of each warrant and sub-warrant as 
either met or not with appropriate boxes checked or not, respectively. 

A detailed text report is also provided. 

Warrants Report 
The report can be displayed in either Page or Full View. If displayed in Page View, the results will 
automatically update when the user switched to the Report page. From the Report page, the user can 
then switch between the formatted report and the text report using the button found at the bottom of the 
page. The formatted report shows the most important results in a presentable format, while the text report 
shows a detailed analysis in plain text. 

If displayed in Full View, the report can be displayed along with the input screen. The user has the choice 
of displaying the report to the right of the input screen or below the input screen. The report is dynamic 
and reacts to changes in the input screen. Like the Report page in Page View, the user can switch 
between the formatted report and the text report using the button found at the bottom of the report. 

All or a portion of the reports can be copied to the Windows clipboard for insertion into other files by right-
clicking into the Report page and selecting Copy. The user can also change the display of the report 
through File Menu or with the use of shortcuts. See General Controls. 
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How To 

Create a New File 
1. From the Start screen, there are three options for creating a new file:  

Note: A new file can be created if an existing file is already open; you do not need to start from 
the Start screen. 
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a. Selecting File > New from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “New” 

 

b. Selecting “New File…” from the Start screen; this can be found below in the red box 

 

c. Using the keyboard shortcut “Ctrl+N” 

2. Once a new file is created, you will be brought to the General page if in Page View or the input 
screen split with the report either on the right or the bottom of the screen if in Full View
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a. Page View  

 

b. Full View  
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Open an Existing File 
1. From the Start screen, there are six options for opening an existing file:  

Note: A file can be opened even if another file is currently open; you do not need to start from the 
Start screen. 

a. Selecting File > Open from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Open”  
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b. Selecting “Open File…” from the Start screen; this can be found below in the red box 

 

c. Using the keyboard shortcut “Ctrl+O” 

d. Selecting a file under the Recent files list from the Start screen; this can be found below 
in the red box  

 

e. Selecting File > Example Folder from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Example Folder”. 
Opening the example folder will open the path of the HCS example files in File Explorer. 
The desired example file can be double-clicked or right-clicked and selecting ‘Open’, 
which will open the example file in the Warrants program. 
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f. Selecting “Example Folder…” from the Start screen; this can be found below in the red 
box. Opening the example folder will open the path of the HCS example files in File 
Explorer. The desired example file can be double-clicked or right-clicked and selecting 
‘Open’, which will open the example file in the Warrants program. 
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2. Once an existing file is opened, you will be brought to the General page if in Page View or the 
input screen split with the report either on the right or the bottom of the screen if in Full View 

a. Page View  

 

b. Full View  
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Save a File 
1. There are five options for saving an open file:  

a. Selecting File > Save from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Save”  

 

b. Selecting File > Save As… from the main menu; this can be found by selecting the three 
lines in the top left-hand corner of the screen and then selecting “Save As…”  

 

c. Using the keyboard shortcut “Ctrl+S” for Save 

d. Using the keyboard shortcut “F12” for Save As… 
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e. Exiting the program or closing the file without saving changes beforehand; this will 
prompt you to save changes to the file before anything is closed  

 

i. Selecting “Yes” will save the file if it is an existing file. If the file has not been 
previously saved, the Save As dialog box will popup allowing you to change the 
file name and save it. 

ii. Selecting “No” will exit the program or close the file without saving the file 

iii. Selecting “Cancel” will prevent the file from closing 

Note: Using Save with an existing file will save a file without prompting you to specify a file name. Using 
Save with a new file will bring up the Save As dialog box for you to specify a file name for saving. Using 
Save As will always bring up the Save As dialog box for you to specify a file name for saving. 

Close a File 
1. There are three options for closing an open file: 

a. Selecting File > Close from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Close”  

 

b. Using the keyboard shortcut “Ctrl+W” 

c. Exiting the program itself; please see How To: Exit the Program 



Warrants User Guide How To  21 

Exit the Program 
1. From the Start screen, there are three options for exiting the program:  

Note: The program can be exited even if a file is still open; you do not need to start from the Start 
screen. 

a. Selecting File > Exit from the main menu; this can be found by selecting the three lines in 
the top left-hand corner of the screen and then selecting “Exit”  

 

b. Using the keyboard shortcut “Alt+F4” 
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c. Selecting “X” in the top right-hand corner of the screen; this can be found below in the red 
box 

 

Edit the Default Settings 
1. From the Start screen, there are two options for editing the Default Settings:  

Note: The Default Settings can be changed even if an existing file is already open; you do not 
need to start from the Start screen. 
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a. Selecting File > Default Settings from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Default Settings” 

 

b. Using the keyboard shortcut “Alt+F” 

2. Opening the Default Settings will cause a Default Settings window to pop up:  

 

3. You can specify the Analyst, Agency, and Jurisdiction by clicking in the corresponding text boxes 
and typing the desired text. 

4. Under ‘Units’, you are given the option of running the analysis in either U.S. Customary (USC) or 
SI (Metric) units. 

5. Under ‘MUTCD Method’, you are given the option of running the analysis using the MUTCD 11 
(2023) method or the MUTCD 2009 method. 

6. Clicking “OK” will save the changes made and close the Default Settings window; clicking 
“Cancel” will close the Default Settings window without saving any changes. 

7. When a new file is created, the Analyst, Agency, and Jurisdiction fields will automatically be 
populated with the text is specified in the Default Settings. 

8. When starting a new file, the input and results will display according to the units specified in the 
Default Settings. 

9. When starting a new file, the inputs available and the procedures used will determined according 
to the method specified in the Default Settings. 
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Change the View 
1. When a file is open, there are three main options for the view of the program: 

a. Page View: the inputs and results reports are separated into pages as seen below. You 
can navigate between pages using the “Back” and “Next” buttons or by clicking the page 
names found at the top of the screen. 

 

b. Full View with the report on the right of the screen: the screen is split with all inputs on 
the left side and the results reports on the right side. You can access all inputs and view 
all of the current report by using the corresponding scroll bars. There is also a screen 
splitter that can be moved to adjust the views of the input screen and results report. 

 

c. Full View with the report on the bottom of the screen: the screen is split with all inputs on 
the top of the screen and the results reports on the bottom of the screen. You can access 
all inputs and view all of the current report by using the corresponding scroll bars. There 
is also a screen splitter that can be moved to adjust the views of the input screen and 
results report. 
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2. Views can be changed by using the main menu items or the keyboard shorcuts. 

a. Main Menu Items 

i. To switch to Page View, select File > View > Page View from the main menu; this 
can be found by selecting the three lines in the top left-hand corner of the screen, 
hovering over “View”, and then selecting “Page View”.  

 

ii. To switch to Full View with the report on the right of the screen, select File > View 
> Full View > Report -> Right from the main menu; this can be found by selecting 
the three lines in the top left-hand corner of the screen, hovering over “View”, 
hovering over “Full View”, and then selecting “Report -> Right”. 
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iii. To switch to Full View with the report on the bottom of the screen, select File > 
View > Full View > Report -> Bottom from the main menu; this can be found by 
selecting the three lines in the top left-hand corner of the screen, hovering over 
“View”, hovering over “Full View”, and then selecting “Report -> Bottom”. 

 

b. Keyboard Shortcuts 

i. Page View: keyboard shortcut is “F9” 

ii. Full View with report on the right of the screen: keyboard shortcut is “F10” 

iii. Full View with report on the bottom of the screen: keyboard shortcut is “F11” 

Change the Lane Configuration 
1. When a new file is created or an existing file is opened, the lane configuration can be changed 

under the Lanes section. This can be found on the Intersection page if using Page View or the 
input portion of the split screen if using Full View. 
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a. Page View  

 

b. Full View  

 

2. To add lanes, click on the lane buttons (black arrows) on the edges of the lanes graphic. If the 
background of a lane button is white, the lane is available to add to the corresponding approach. 
If the background of a lane button is gray, it is disabled and cannot be added to the 
corresponding approach based on the current lane configuration.  
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a. Each approach allows up to seven lanes to be added  

 

b. Adding a shared left-right (LR) lane will disable all other lanes except left (L) and right (R) 

 

c. Adding a shared left-thru-right (LTR) lane will disable all other lanes except left (L) and 
right (R)  
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d. Adding a shared left-thru (LT) lane will disable the shared left-thru-right (LTR) and shared 
left-right (LR) lanes  

 

e. Adding a shared thru-right (TR) lane will disable the shared left-thru-right (LTR) and 
shared left-right (LR) lanes  

 

3. To remove lanes, click on the lanes within the center of the lanes graphic (white arrows). Clicking 
on an arrow will immediately remove the lane and change which lane buttons are 
enabled/disabled for the corresponding approach. 

4. Changes to the lane configuration on the lanes graphic in the input screen will be reflected on the 
lanes graphic in the formatted report and the lane information in both the formatted and text 
reports. 

View Results of the Analysis 
1. After editing all the necessary inputs, results of the analysis can be found in the form of reports. 

Reports can be found on the Report page if using Page View or on the results portion of the split 
screen if using Full View. 
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a. Page View with Report page displayed  

 

b. Full View with the report on the right of the screen  
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c. Full View with the report on the bottom of the screen  

 

2. There are two options for reports: Formatted and Text 

a. Formatted reports show the most important results in a presentable format  
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b. Text reports show a more detailed analysis in plain text  

 

3. The type of report displayed can be changed by using the main menu items, keyboard shortcuts, 
or toggle buttons under the report. 

a. Main Menu Items 

i. To switch to the Formatted Report, select File > Report > Formatted Report from 
the main menu; this can be found by selecting the three lines in the top left-hand 
corner of the screen, hovering over “Report”, and then selecting “Formatted 
Report”. 

 

ii. To switch to the Text Report, select File > Report > Text Report from the main 
menu; this can be found by selecting the three lines in the top left-hand corner of 
the screen, hovering over “Report”, and then selecting “Text Report”. 
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b. Keyboard Shortcuts 

i. Formatted Report: keyboard shortcut is “F4” 

ii. Text Report: keyboard shortcut is “F6” 

c. Report Toggle Buttons 

i. Whether viewing the report in Page View or Full View, a toggle button will be 
available at the bottom of the screen underneath the report.  

ii. If the formatted report is currently being displayed, the toggle button will say 
“Switch to Text Report” which will allow you to display the text report if clicked.  

 



34  How To Warrants User Guide 

iii. If the text report is currently being displayed, the toggle button will say “Switch to 
Formatted Report” which will allow you to display the formatted report if clicked. 

 

4. The magnification of the report currently being displayed can be changed using the zoom slider 
found at the bottom right-hand corner of the screen.   

 

a. To zoom in, drag the slider to the right; to zoom out, drag the slider to the left 

b. Clicking the plus (+) button will zoom in; clicking the minus (-) button will zoom out  

c. Holding down “ctrl” on the keyboard and scrolling up on the mouse wheel will zoom in; 
holding down “ctrl” on the keyboard and scrolling down on the mouse wheel will zoom out 
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Print a Report 
1. There are four options for printing a report:  

a. Selecting File > Print from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Print”  

 

b. Selecting File > Print Preview from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Print Preview” 

 

c. Using the keyboard shortcut “Ctrl+P” for Print 

d. Using the keyboard shortcut “Ctrl+F2” for Print Preview  
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2. Print 

a. Using Print will bring up a Print dialog box where you can select which printer to print to 

 

3. Print Preview 

a. Using Print Preview will bring up a window where you can view how the report will look 
on paper before sending it to the printer  

 

b. The print icon in the toolbar found in the top left-hand corner can then be selected 
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c. A Print dialog box will pop up where you can select which printer to print to  
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Glossary of Terms 

15th Percentile Pedestrian Speed < 3.5 ft/s 
A checkbox is provided to indicate whether or not the 15th percentile pedestrian crossing speed is less 
than 3.5 feet per second (or 1.07 meters per second in metric). 

Adequate Trials of Alternatives 
A checkbox is provided to indicate whether or not adequate trials of crash experience alternatives with 
satisfactory observance and enforcement has failed to reduce the crash frequency. 

Agency 
This field is provided to document the name of the Agency or the Company conducting the analysis. 

Analysis Time Period 
Enter the time period over which the analysis was conducted. 

Analysis Year 
This field is provided to document the year the analysis is modeling. For example, a current or past 
operational year or a future design or planning year might be coded here. 

Analyst 
This field is provided to document the individual performing the analysis. 

Angle Crashes 
Angle crashes include all crashes that occur at an angle and involve one or more vehicles on the major 
street and one or more vehicles on the minor street. 

Coordinated Signal System 
This is from engineering judgment from the description of Warrant 6, Coordinated Signal System. 
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Crash Experience 
Crash experience can be entered for one-year and three-year periods. Inputs are provided for the 
following type crashes: Angle Crashes (All Severities), Angle Crashes (Fatal and Injury), Pedestrian 
Crashes (All Severities), and Pedestrian Crashes (Fatal and Injury). 

Crashes/Year 
This number is compared to the five required in the Crash Experience warrant, but only those crashed 
susceptible to correction by signal installation should be included, as described in Warrant 7. 

Date 
The date will default to the computer’s date, but may be edited. The format of the date is determined by 
the user's 'Short date style' preferences (regional settings icon on the Control Panel). 

Delay 
The average stopped delay for each approach is coded in seconds per vehicle. The appropriate volumes 
will be used to calculate the total stopped delay in vehicle hours. Alternatively, the total stopped delay in 
vehicle hours may be coded directly, and the appropriate volumes will be used to calculate the delay in 
seconds per vehicle.  

The option of which units to input is provided by selecting one of the radio buttons for Delay Units. The 
textbox inputs of the selected units will be enabled. The textbox inputs for the other units will be disabled, 
but the corresponding values will automatically be converted and used for determining Warrant 3. 

Distance to Stop Line 
The distance from the center of the track nearest the intersection and the stop line on the approach. This 
is measured in feet (or meters in metric). 

Gaps 
Gaps per hour in the traffic stream of adequate length to allow pedestrians to cross during the same 
period when the pedestrian volume criterion is satisfied. Where there is a divided street having a median 
of sufficient width for pedestrians to wait, the requirement applies separately to each direction of vehicular 
traffic. 

Grade Crossing Approach 
The user selects the approach direction where the grade railway crossing exists. If no grade crossing 
exists, the user selects ‘None’. 

High Occupancy Buses 
The percentage of vehicles crossing the track that are high-occupancy buses. A high-occupancy bus is 
defined as a bus occupied by a least 20 people. 

Highest Volume Hour with Trains 
The user selects the highest traffic volume hour during which rail traffic uses the crossing. 
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Intersection 
Description or name of the intersection can be coded here. 

Jurisdiction 
Generally the agency for which the analysis is being performed or has jurisdiction over the freeway being 
analyzed. 

Major Street Direction 
This must be defined in order to use the appropriate data for the stop-controlled approaches. 

Major Street Speed 
This speed is used to determine which MUTCD tables and figures are to be used. Lower thresholds are 
required when the major street speed is above 40 mi/h (or 64.4 km/h in metric) in Warrant 1, Warrant 2, 
Warrant 3, and Warrant 7.  

Median 
A median is the area between opposing lanes of traffic, excluding turn lanes. Medians in urban and 
suburban areas can be defined by pavement markings, raised medians, or islands to separate motorized 
and non-motorized road users. 

For the MUTCD 2009 method, whether a median of sufficient width for pedestrians to wait exists is coded 
here. The median types available include the following: Undivided and Divided. 

MUTCD Method 
Two methodologies are available for running a Warrants analysis: MUTCD 11 (2023) and MUTCD 2009. 
Both methods are based on the procedures established in the Manual on Uniform Traffic Control Devices 
(MUTCD). MUTCD 11 (2023) is based on the procedures from the 11th Edition MUTCD. MUTCD 2009 is 
based on the procedures from the 2009 MUTCD. 

Nearest Signal 
This information is used to determine the applicability of the Pedestrian Volume, School Crossing, and 
Coordinated Signal System in Warrant 4, Warrant 5, and Warrant 6. 

Pedestrian Median Refuge 
A pedestrian refuge island (or crossing area) is a median with a refuge area that is intended to help 
protect pedestrians who are crossing a road. 

A checkbox is provided for each approach to indicate if a pedestrian median refuge is available. 

Pedestrians 
The number of pedestrians per hour crossing the approach. 
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Population 
If the population is less than 10,000 people, the user checks this field. 

Project Description 
This field is provided for the user to document the analysis with any information for identification 
purposes. 

Rail Traffic 
The number of trains per day that use the rail crossing. 

Roadway Network 
The need for a traffic control signal shall be considered if an engineering study finds that the common 
intersection of two or more major routes meets one or both of the following criteria: 

A. The intersection has a total existing, or immediately projected, entering volume of at least 1,000 
vehicles per hour during the peak hour of a typical weekday and has 5-year projected traffic 
volumes, based on an engineering study, that meet one or more of Warrants 1, 2, and 3 during 
an average weekday; or 

B. The intersection has a total existing or immediately projected entering volume of at least 1,000 
vehicles per hour for each of any 5 hours of a weekend, nonnormal business day (Saturday or 
Sunday). 

A major route as used in this signal warrant shall have one or more of the following characteristics:  

A. It is part of the street or highway system that serves as the principal roadway network for through 
traffic flow; or  

B. It includes rural or suburban highways outside, entering, or traversing a City; or  

A. It appears as a major route on an official plan, such as a major street plan in an urban area traffic 
and transportation study. 

School Crossing 
The need for a traffic control signal shall be considered when an engineering study of the frequency and 
adequacy of gaps in the vehicular traffic stream as related to the number and size of groups of school 
children at an established school crossing across the major street shows that the number of adequate 
gaps in the traffic stream during the period when the children are using the crossing is less than the 
number of minutes in the same period (see Section 7A.03) and there are a minimum of 20 students 
during the highest crossing hour.  

Start Time 
The Start Time is coded to allow for subsequent periods to be automatically labeled. 

Tractor-Trailer Trucks 
The percentage of vehicle crossing the track that are tractor-trailer trucks. 
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Traffic Volumes 
The hourly volumes (V) for each movement are coded in vehicles per hour (veh/h). 
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