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Introduction 

License Agreement 
HIGHWAY CAPACITY SOFTWARE™ (HCS™)  
END-USER LICENSE AGREEMENT (EULA) 
 
Effective Date: 9/1/2025 
 
 
Copyright © 2025 University of Florida. All rights reserved. 
 
This End User License Agreement (“Agreement”) is a legal agreement between you (“End User”, “you”) 
and the University of Florida Board of Trustees for the benefit of the McTrans Center (“McTrans”, ”we”) 
regarding the use of the Highway Capacity Software (“Software”). By accessing or using the Software 
programs within the electronically transmitted package or direct download, you agree to be bound by the 
terms and conditions of this Agreement.  
 
 
1. INTEGRATION: 
This License Agreement is the complete and exclusive statement of the agreement between End User 
and McTrans and supersedes any previous End User License Agreements distributed by older versions 
of the software proposal or prior agreement, oral or written, and any other communications between End 
User and McTrans relating to the subject matter of this License Agreement. This EULA will supersede the 
End User License Agreement contained in the HCS Version 5, 6, and 7 modules disseminated as part of 
the Software. This License Agreement may only be modified by a written agreement made subsequent to 
the date hereof and signed by both parties. 
 
 
2. LICENSE GRANT: 
2.1 Subscription-Based License: 
McTrans grants you a non-exclusive, non-transferable license to access and use the Software, subject to 
the terms of your active subscription. The license is valid only for the duration of your subscription and is 
contingent upon full payment of all applicable fees. 
 
2.2 Access to Software Versions:  
Your subscription grants access to versions 5 (selected modules), 6 (selected modules), 7 and 8 series 
and beyond (2022 onward) of the Software. When a new version of the Software is released, the End 
User with an active subscription can download and access the latest version at no additional cost for the 
remainder of their subscription term. 
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3. TYPES OF SUBSCRIPTIONS: 
The type of subscription determines the permitted use of the Software. Once a subscription type is 
selected, it cannot be changed or exchanged for a different type. 
 
3.1 Office-Based Subscription: 
This subscription grants access to the Software for a predetermined number of computers within a 
physical office. An "office" refers exclusively to a fixed geographical location, typically a single physical 
address, where an organization conducts its business or operational activities. This location must consist 
of one or more contiguous rooms or spaces within a single building. Virtual offices or any non-physical 
locations are excluded from this definition. 
 
The Software may be installed on multiple devices within the office, and access is restricted to end users 
officially assigned to that licensed office. End Users may also use the Software on portable computers, 
such as laptops, while on official travel, provided that all (100%) such use is exclusively on behalf of the 
office for which this Software license was purchased. Additional offices must obtain proper licensing prior 
to accessing the Software. The Software may only be installed on devices owned or controlled by the 
licensed office. 
 
This subscription is intended exclusively for commercial use. 
 
Virtualization Restriction:  
The Software under an office-based subscription is prohibited from being used in a virtualized 
environment. All installations of the Software must be conducted on a physical computer, such as a 
desktop or laptop. Remote access technologies, such as remote desktop, are strictly prohibited under this 
subscription type. 
 
3.2 Computer-Based Subscription: 
This subscription permits the installation and use of the Software on a specified number of individual 
devices. An "individual device" refers to a single, standalone computing unit, such as a desktop or laptop, 
intended for use by a single user at a time. Concurrent or simultaneous access by multiple users on the 
same computer or through any means of remote connection is strictly prohibited. The Software may only 
be accessed directly from the device(s) on which it is installed, regardless of whether the device is 
located in a physical office or used in a virtual office. End users working remotely or in virtual offices must 
ensure that the device remains dedicated to their use and fully complies with the terms of this 
subscription. 
 
Virtualization Restriction:  
The Software under a computer-based subscription is prohibited from being used in a virtualized 
environment. All installations must be conducted on a physical computer, such as a desktop, PC, or 
laptop. Remote access to the Software via any technology, including but not limited to remote desktop, is 
strictly prohibited under this subscription type. 
 
3.3 Volume-Based Subscription: 
This subscription permits the installation and use of the Software on a specified number of individual 
devices. An "individual device" refers to a single, standalone computing unit, such as a desktop or laptop, 
intended for use by a single user at a time. Concurrent or simultaneous access by multiple users on the 
same computer or through any means of remote connection is strictly prohibited. The Software may only 
be accessed directly from the device(s) on which it is installed, regardless of whether the device is 
located in a physical office or used in a virtual office. End users working remotely or in virtual offices must 
ensure that the device remains dedicated to their use and fully complies with the terms of this 
subscription. 
 
Virtualization Restriction:  
The Software under a Volume-based subscription is prohibited from being used in a virtualized 
environment. All installations must be conducted on a physical computer, such as a desktop, PC, or 



AWSC User Guide Introduction  3 

laptop. Remote access to the Software via any technology, including but not limited to remote desktop, is 
strictly prohibited under this subscription type. 
 
3.4 Academic Subscription: 
The academic subscription is available exclusively to academic institutions and grants access to a 
specified number of seats (copies) across the entire academic institution. This subscription is intended 
solely for use in a classroom setting for teaching or a lab for research purposes under the direct 
supervision of faculty or other authorized personnel. The Software may only be installed on devices 
owned or controlled by the academic institution. 
 
The End User is required to implement appropriate protection measures to prevent students or any other 
individuals from copying the Software and removing it from the lab or classroom environment. The 
responsibility for safeguarding the Software and preventing unauthorized copying or distribution rests 
entirely with the End User. 
 
Virtualization for Virtual Classrooms:  
Under the academic license, the End User may request permission to utilize a virtual environment for the 
installation and use of the Software. Such virtualization is only permitted with prior written consent from 
McTrans. If such permission is granted, the virtual environment must adhere to all protections and 
restrictions outlined in this Agreement, ensuring that the Software is used exclusively for its intended 
educational purposes and its access is limited to the institution's faculty and actively enrolled students 
only. Additionally, the number of seats purchased must be sufficient to cover the number of students and 
faculty accessing the virtual classroom. 
 
 
4. SUBSCRIPTION TERM: 
4.1 Duration: 
The subscription term begins on the date of purchase and continues for the period specified at the time of 
purchase ("Subscription Term"). The license granted under this Agreement is valid only for the duration of 
the Subscription Term. 
 
4.2 Renewal: 
Subscriptions may be renewed upon payment of applicable fees before the end of the Subscription Term. 
If the subscription is not renewed, access to the Software and all related services, including technical 
support, will be terminated. 
 
 
5. TECHNICAL SUPPORT: 
5.1 Support Services: 
During the active Subscription Term, the End User is entitled to reasonable telephone or email support 
provided during the normal business hours of McTrans. McTrans reserves the right to determine the 
extent of the support provided. 
 
5.2 Revisions and Enhancements: 
McTrans reserves the right to make substantial revisions and enhancements to the Software and to 
market such substantially revised versions as separate products. The End User shall not be entitled to 
receive such separate products without additional charge. Upon the release of any such revised version 
of the Software, the obligation to provide the above-described technical support services to the End User 
shall cease unless the End User chooses to pay to license the enhanced version of the Software, 
regardless of whether the End User has previously requested or received support on the prior version. 
 
 
6. NETWORK USE: 
The End User is strictly prohibited from using the Software on any network. This prohibition includes but is 
not limited to the use of the Software either directly or indirectly through commands, data, or instructions 
transmitted to or from a computer that is not licensed or is not part of the licensed internal network. This 
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also includes any use for Internet or web hosting services or by any user who does not hold a valid 
license for the Software from McTrans. 
  
The Software is not designed for network use, and such use is unsupported. McTrans will not provide 
technical support for any issues resulting from network incompatibilities or unauthorized network use. 
 
 
7. RESTRICTIONS ON USE: 
The End User agrees that they shall not, nor shall they permit any third party to: 

● Software Modification: Modify, adapt, translate, or create derivative works based on the Software, 
in whole or in part, without the express prior written consent of McTrans. 

● Reverse Engineering: Reverse engineer, decompile, disassemble, or otherwise attempt to derive 
the source code of the Software, except to the extent expressly permitted by applicable law. 

● Unauthorized Use: Use the Software for any purpose other than as expressly permitted under this 
Agreement, including unauthorized copying, distribution, or dissemination of the Software. 

● Intellectual Property Infringement: Engage in any activity that infringes on the intellectual property 
rights of McTrans, including any unauthorized copying or distribution of the Software or 
associated documentation. 

● Copying and Distribution: Copy, reproduce, or distribute the Software or associated printed 
documentation for sale, distribution, or dissemination, except as expressly provided under the 
terms of this Agreement or with the express prior written consent of McTrans. 

● Documentation Use: Reproduce the associated documentation only as necessary for use within 
the permitted scope of the subscription type as outlined in this Agreement. 

● AI Training and LLMS Restriction: The End User agrees not to use the Software to train or 
develop any artificial intelligence (AI) model or large language model system (LLMS) without the 
express prior written consent of McTrans. This includes, but is not limited to, using the Software 
to generate or fine-tune AI models, create or modify LLMS, or use the Software as a data source 
for AI or LLMS training. Any attempts to do so will be considered a material breach of this 
Agreement and may result in termination of the license. 

 
Ownership of Software Modifications:  
Any modifications, adaptations, translations, derivative works, or any other products or materials resulting 
from any prohibited actions shall become the exclusive property of McTrans, regardless of whether such 
actions were performed with or without McTrans’ consent. 
 
 
8. INTELLECTUAL PROPERTY RIGHTS: 
The Software and all associated intellectual property rights are owned by McTrans. No rights are granted 
to the End User other than the limited license expressly set forth in this Agreement. 
 
 
9. USE OF RESULTS IN RESEARCH AND COMMERCIAL PUBLICATIONS: 
McTrans grants the End User legal permission to use the results generated by the Software in academic, 
research, or commercial publications, provided that such use complies with the terms of this agreement. 
The End User may publish or present findings derived from the Software as part of their research or 
commercial work as long as the Software is properly cited and all applicable license terms and restrictions 
are adhered to. Unauthorized reproduction or distribution of the Software itself remains strictly prohibited. 
 
 
10. TRANSFER OF LICENSE AND DEACTIVATION RESTRICTIONS:  
The Software is licensed only to the End User, and this License Agreement may not be assigned or 
transferred to anyone without McTrans’ prior written consent. Any authorized transferee of this License 
Agreement shall be bound by the terms of this License Agreement. The End User may not transfer, 
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assign, rent, lease, sell, or otherwise dispose of the Software except as expressly provided in this License 
Agreement. 
 
Deactivation requests are granted on a limited basis, such as hardware failure, device replacement or 
upgrade, reassignment of equipment, etc. To request deactivation, please email mctrans@ce.ufl.edu with 
a brief reason for your request and include the name of the computer or the machine you wish to 
deactivate. McTrans will then provide you with instructions on how to deactivate a license so you can use 
it on a different machine.  
 
 
11. LIMITED WARRANTY AND LIMITATIONS OF REMEDIES: 
End User acknowledges and agrees that it is the sole responsibility of End User to fully understand the 
limitations and assumptions underlying the Software and to refrain from using the Software without the 
assistance of personnel with appropriate expertise. The End User accepts full responsibility for reviewing, 
interpreting, applying, and utilizing the output of the Software and for ensuring that such output complies 
with any applicable design codes, standards, or project specifications. 
 
Except as expressly provided herein, the Software is provided “AS IS” without warranty of any kind, 
whether expressed or implied, including, but not limited to, implied warranties of merchantability and 
fitness for a particular purpose. McTrans does not warrant that the functions contained in the Software will 
meet the End User’s requirements or that the operation of the Software will be uninterrupted or error-free. 
The entire risk as to the quality and performance of the product is with the End User.  
 
In no event will McTrans be liable to the End User for any damages, including any lost profits, lost 
savings, or other incidental or consequential damages arising out of the use of or inability to use the 
Software, even if McTrans has been advised of the possibility of such damages, or for any claim by any 
other party. The above warranty gives the End User specific legal rights, and the End User may also have 
other rights in the United States, which vary from state to state.  
 
Use of the Software where the End User believes or has reason to believe that damage may occur 
constitutes a violation of any and all warranties. McTrans has no knowledge of the hardware or Software 
configurations of the End User and assumes no liability for their damage. 
 
 
12. TERMINATION: 
12.1 Termination by McTrans: 
McTrans may terminate this Agreement immediately upon notice if you fail to comply with any term or 
condition of this Agreement. Upon termination, you must cease all use of the Software and destroy all 
copies of the Software in your possession. 
 
12.2 Termination by End User: 
You may terminate this Agreement at any time by discontinuing the use of the Software and notifying 
McTrans. No refunds will be provided for any remaining portion of the Subscription Term. 
 
 
13. GOVERNING LAW: 
This License Agreement shall be governed by the laws of the State of Florida, U.S.A. Venue for all 
disputes related to this License Agreement shall be in the United States District Court of the Northern 
District of Florida, Gainesville Division, or in the Circuit Court of the Eighth Judicial Circuit for Alachua 
County, Florida. 
 
 
14. U.S. GOVERNMENT RESTRICTED RIGHTS: 
The Software and associated documentation are provided with RESTRICTED RIGHTS. Use, duplication, 
or disclosure by the U.S. Government is subject to restrictions as set forth in subdivision (c)(1)(ii) of The 
Rights in Technical Data and Computer Software clause at 52.227-7013 or subparagraphs (c)(1) and (2) 
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of the Commercial Computer Software - Restricted Rights at 48CFR52.227-19. The contractor is 
McTrans, University of Florida, PO Box 116585, Gainesville, FL 32611-6585. 
 
 
15. EXPORT REGULATION: 
The Software may be subject to U.S. export control laws and regulations, including the U.S. Export 
Control Reform Act and its associated regulations. End User will not directly or indirectly export, re-export, 
transfer, or release the Software to, or make the Software accessible from, any country, jurisdiction, or 
person to which export, re-export, transfer, or release is prohibited by applicable U.S. laws and 
regulations. End User will comply with all applicable laws and regulations and complete all required 
undertakings (including obtaining any necessary export license or other governmental approval) prior to 
exporting, re-exporting, transferring, or releasing, or otherwise making the Software available, outside the 
U.S. End User shall not export, re-export, transfer, or release the software or software source code to any 
country which is comprehensively sanctioned by the U.S. Department of the Treasury, Office of Foreign 
Assets Control (OFAC). 
 
 
16. SEVERABILITY:  
If any portion of this License Agreement shall be declared void or a nullity by a court of competent 
jurisdiction, then the remainder shall survive and remain in full force. Should you have any questions 
concerning this license, you may contact the McTrans Center, University of Florida, PO Box 116585, 
Gainesville, FL 32611-6585, U.S.A., [1] (800) 226-1013. 
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Getting Started 

System Requirements 
HCS is designed for standard Windows installations. For optimal performance, the system should be 
Windows 10 or newer. While HCS may be compatible with older versions of Windows, any installation 
and operational issues arising from using these older versions will be the sole responsibility of the end 
user. 

Getting Started 
To begin, click on New File found on the left side of the screen under the Start header. There are two 
types of views available in AWSC – Page View (F9) or Full View (F10 and F11). These commands are 
also accessible through menu items. Normal Windows keyboard and mouse functions are available. In 
Full View, The PgUp and PgDn keys will scroll the entry screen up and down, respectively. In both views, 
tabbing, clicking to a new field, or pressing the Enter key will trigger a recalculation and update the Report 
pane. 

All-Way Stop-Controlled (AWSC) Analysis 

All-Way Stop-Controlled (AWSC) intersection analyses will estimate Capacity and Level of Service (LOS) 
for a given set of traffic and geometric conditions. This type of analysis is oriented toward the evaluation 
of an existing or planned facility. The methodology and procedures of application use the HCM Chapter 
21 procedures. 
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General Controls 

Menu Items 
New – Creates a new AWSC file (*.xaw) and starts a new analysis project; shortcut is Ctrl+N 

Open – Opens an existing AWSC file (*.xhu, *.xaw); shortcut is Ctrl+O 

Example Folder – Opens folder with all HCS examples in File Explorer 

Save – Saves an open AWSC file (*.xaw) using the current file name; shortcut is Ctrl+S 

Save As… – Saves an open AWSC file (*.xaw) using a specified file name; shortcut is F12 

Close – Closes an existing AWSC file (*.xaw); shortcut is Ctrl+W 

Units 

 USC Units – Changes the units of the current file to U.S. Customary 

 Metric Units – Changes the units of the current file to Metric 

Print – Brings up printer selection and prints an AWSC report to the printer or specified file type; shortcut 
is Ctrl+P 

Print Preview – Displays preview of current report before printing; shortcut is Ctrl+F2 

View 

Page View – Changes the view to display inputs and reports by pages; shortcut is F9 

Full View 

Report -> Right – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the right portion of the screen; shortcut is F10 

Report -> Bottom – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the bottom portion of the screen; shortcut is 
F11 

Report 

Formatted Report – Displays formatted report including the most important values; shortcut is F4 

Text Report – Displays text report with all input, intermediary, and final results; shortcut is F6  

Default Settings – Opens a dialog box for the user to input defaults for Analyst, Agency, and Jurisdiction, 
which will be applied to all new files; also allows selection of USC or SI units, which will be applied to all 
new files; shortcut is Alt+F 
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Help 

Contents – Provides access to glossary, acknowledgements, copyrights, and information on the 
HCM procedure; shortcut is Ctrl+F1 

Index – Allows user to search for keywords within the glossary 

Search – Allows user to search for any word within the Contents 

User Guide – Opens a comprehensive user guide in PDF format; shortcut is Ctrl+G 

HCM Reference Guide – Opens the McTrans website in the default web browser to request 
access to a reference guide for the HCM in PDF format 

HCM Volume 4 Website – Opens the Highway Capacity Manual Volume 4 website in the default 
web browser to access the free online resource 

HCS Updates – Sends the HCS version number anonymously without any personally identifiable 
information to McTrans to check for a newer version 

HCM/HCS Training – Opens the McTrans Training Page in the default web browser to view the 
latest training opportunities 

HCQS Website – Opens the TRB Highway Capacity and Quality of Service Committee website in 
the default web browser 

Support 

Frequently Asked Questions – Opens the McTrans support page for HCS in the default 
web browser 

HCS Overview – Opens the McTrans HCS Overview page in the default web browser 

McTrans Website – Opens the McTrans home page in the default web browser 

Email McTrans – Composes a new e-mail addressed to McTrans in the default e-mail 
client with registration number, serial key, module, and version number already populated 
in the Subject field 

About HCS – Opens an about window with software version information, EULA, general 
acknowledgements, contact information, and other relevant links 

CORSIM 

View Animation – Sends data to the TSIS-CORSIM program for simulation and/or animation 
purposes, TRAFVU can be opened within TSIS-CORSIM to allow user to view animation; 
shortcut is Ctrl+Shift+A 

Generate TRF File – Saves an open AWSC file (*.xaw) as a CORSIM file (*.trf), which is a file 
that contains the input data used to define a CORSIM network and to drive the CORSIM 
simulation for a single simulation case; shortcut is Ctrl+Shift+T 

Exit – Exits the HCS AWSC module; shortcut is Alt+F4 
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All-Way Stop-Controlled 
Intersections 

HCM Chapter 21 
The procedure in this chapter can be used to analyze the capacity and level of service, lane 
requirements, and effects of traffic and design features of all-way stop-controlled (AWSC) intersections. 
 
The procedure for AWSC intersections with one or two lane approaches is addressed in Part 3 of this 
chapter. The procedure for three lane approaches is addressed in Part 4 of this chapter, but also 
references supplemental material in Part 4 of Chapter 32. Example problems that demonstrate the 
calculations and results achieved by applying the procedures are found in Part 5 of Chapter 32. 
 
LIMITATIONS OF THE METHODOLOGY 
All of the methods are for steady-state conditions (i.e., the demand and capacity conditions are constant 
during the analysis period); the methods are not designed to evaluate how fast or how often the facility 
transitions from one demand/capacity state to another. Analysts interested in that kind of information 
should consider applying simulation models. 

Operational Data 
First, the user enters the Project Properties into the respective fields: Analyst, Agency or Company, Date 
Performed, Time Analyzed, Jurisdiction, Analysis Year, and Project Description. Then, the user enters the 
Intersection Data into the respective fields: Intersection, East/West Street Name, North/South Street 
Name, Analysis Time Period (normally 15 minutes, to represent the length of time the peak flow is 
constant), and Peak Hour Factor. 

Note: Hovering over numeric input fields will display the allowable range for that input. 

Next, the user codes the lane configurations and traffic characteristics. The total number of lanes per 
approach is limited to three by the HCM methodology. 

The Volume for each movement of the intersection is coded in vehicles per hour. An hourly volume is 
required for any movement to be included in the analysis. 

When there is a thru lane(s) coded along-side a shared left-thru or shared thru-right lane, the Percent 
Thrus Using Shared Lane field is activated. The user must enter this value to provide for the traffic split 
for the lanes. 

Note: The Percent Heavy Vehicles input is coded by lane and should not be entered by movement.  
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For queue length calculations, the Stored Passenger Car Length and Stored Heavy Vehicle Length are 
provided. 

Results 

Level of Service (LOS) criteria for AWSC intersections in control delay (s/veh): 

 

Note: For individual lane evaluation, if any v/c ratio exceeds 1.0, the LOS assigned is F. However, for 
evaluation at the approach and intersection level, v/c ratio is not considered and LOS is defined only by 
control delay values. 

AWSC Report 
The formatted version of the AWSC report is the default report view. The user may easily view the text 
report instead by clicking the Switch to Formatted Report button found at the bottom of the formatted 
report. The report updates dynamically based on changes to input values. 

Note: In the formatted report, only the first two fields in Vehicle Volumes and Adjustments (Volume and % 
Thrus in Shared Lane) pertain to movements, as denoted by L, T or R. All subsequent fields pertain to the 
lane being analyzed, as denoted by L1, L2 or L3. LOS is also reported per lane. Similarly in the text 
report, only the fields in Vehicle Volumes and Adjustments pertain to movements, as denoted by L, T, or 
R. All other fields refer to the lane being analyzed, as denoted by L1, L2 or L3. 

All or a portion of the report can be copied to the Windows clipboard for insertion into other files by right-
clicking into the Report pane and selecting Copy or by using keyboard shortcuts Ctrl+C or Ctrl+A to select 
all. The Report pane can also be printed or saved to a PDF or XPS by using menu items to access Print 
or by using keyboard shortcut Ctrl+P. 

Note: Due to the iterative nature of the AWSC procedure, it is recommended to stay in Page View if the 
user is making multiple edits to the input fields. 
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How To 

Create a New File 
1. From the Start screen, there are three options for creating a new file:  

 
Note: A new file can be created if an existing file is already open; you do not need to start from 
the Start screen. 
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a. Selecting File > New from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “New” 

 

b. Selecting “New File…” from the Start screen; this can be found below in the red box 

 

c. Using the keyboard shortcut “Ctrl+N” 

2. Once a new file is created, you will be brought to the General page if in Page View or the input 
screen split with the report either on the right or the bottom of the screen if in Full View
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a. Page View  

 

b. Full View  
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Open an Existing File 
1. From the Start screen, there are six options for opening an existing file:  

 
Note: A file can be opened even if another file is currently open; you do not need to start from the 
Start screen. 

a. Selecting File > Open from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Open”  
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b. Selecting “Open File…” from the Start screen; this can be found below in the red box 

 

c. Using the keyboard shortcut “Ctrl+O” 

d. Selecting a file under the Recent files list from the Start screen; this can be found below 
in the red box  

 

e. Selecting File > Example Folder from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Example Folder”. 
Opening the example folder will open the path of the HCS example files in File Explorer. 
The desired example file can be double-clicked or right-clicked and selecting ‘Open’, 
which will open the example file in the AWSC program. 
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f. Selecting “Example Folder…” from the Start screen; this can be found below in the red 
box. Opening the example folder will open the path of the HCS example files in File 
Explorer. The desired example file can be double-clicked or right-clicked and selecting 
‘Open’, which will open the example file in the AWSC program. 

 

2. Once an existing file is opened, you will be brought to the General page if in Page View or the 
input screen split with the report either on the right or the bottom of the screen if in Full View
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a. Page View  

 

b. Full View  
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Save a File 
1. There are five options for saving an open file: 

a. Selecting File > Save from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Save”  

 

b. Selecting File > Save As… from the main menu; this can be found by selecting the three 
lines in the top left-hand corner of the screen and then selecting “Save As…”  

 

c. Using the keyboard shortcut “Ctrl+S” for Save 

d. Using the keyboard shortcut “F12” for Save As 
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e. Exiting the program or closing the file without saving changes beforehand; this will 
prompt you to save changes to the file before anything is closed  

 

i. Selecting “Yes” will save the file if it is an existing file. If the file has not been 
previously saved, the Save As dialog box will pop up allowing you to change the 
file name and save it. 

ii. Selecting “No” will exit the program or close the file without saving the file 

iii. Selecting “Cancel” will prevent the file from closing 

Note: Using Save with an existing file will save a file without prompting you to specify a file name. Using 
Save with a new file will bring up the Save As dialog box for you to specify a file name for saving. Using 
Save As will always bring up the Save As dialog box for you to specify a file name for saving. 

Close a File 
1. There are three options for closing an open file: 

a. Selecting File > Close from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Close”  

 

b. Using the keyboard shortcut “Ctrl+W” 

c. Exiting the program itself; please see How To: Exit the Program 
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Exit the Program 
1. From the Start screen, there are three options for exiting the program:  

Note: The program can be exited even if a file is still open; you do not need to start from the Start 
screen. 

a. Selecting File > Exit from the main menu; this can be found by selecting the three lines in 
the top left-hand corner of the screen and then selecting “Exit”  

 

b. Using the keyboard shortcut “Alt+F4” 
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c. Selecting “X” in the top right-hand corner of the screen; this can be found below in the red 
box 

 

Edit the Default Settings 
1. From the Start screen, there are two options for editing the Default Settings:  
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Note: The Default Settings can be changed even if an existing file is already open; you do not 
need to start from the Start screen. 

a. Selecting File > Default Settings from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Default Settings” 

 

b. Using the keyboard shortcut “Alt+F” 

2. Opening the Default Settings will cause a Default Settings window to pop up:  

 

3. You can specify Analyst, Agency, and Jurisdiction by clicking in the corresponding text boxes and 
typing the desired text. 

4. Under ‘Units’, you are given the option of running the analysis in either U.S. Customary (USC) or 
SI (Metric) units. 

5. Clicking “OK” will save the changes made and close the Default Settings window; clicking 
“Cancel” will close the Default Settings window without saving any changes. 

6. When a new file is created, the Analyst, Agency, and Jurisdiction fields will automatically be 
populated with the text specified in the Default Settings. 

7. When starting a new file, the input and results will display according to the units specified in the 
Default Settings. 
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Change the View 
1. When a file is open, there are three main options for the view of the program: 

a. Page View: the inputs and results reports are separated into pages as seen below. You 
can navigate between pages using the “Back” and “Next” buttons or by clicking the page 
names found at the top of the screen.  

 

b. Full View with the report on the right of the screen: the screen is split with all inputs on 
the left side and the results reports on the right side. You can access all inputs and view 
all of the current report by using the corresponding scroll bars. There is also a screen 
splitter that can be moved to adjust the views of the input screen and results report. 



AWSC User Guide How To  25 

c. Full View with the report on the bottom of the screen: the screen is split with all inputs on 
the top of the screen and the results reports on the bottom of the screen. You can access 
all inputs and view all of the current report by using the corresponding scroll bars. There 
is also a screen splitter that can be moved to adjust the views of the input screen and 
results report.  

 

2. Views can be changed by using the main menu items or the keyboard shortcuts. 

a. Main Menu Items 

i. To switch to Page View, select File > View > Page View from the main menu; this 
can be found by selecting the three lines in the top left-hand corner of the screen, 
hovering over “View”, and then selecting “Page View”.  

 

ii. To switch to Full View with the report on the right of the screen, select File > View 
> Full View > Report -> Right from the main menu; this can be found by selecting 
the three lines in the top left-hand corner of the screen, hovering over “View”, 
hovering over “Full View”, and then selecting “Report -> Right”. 
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iii. To switch to Full View with the report on the bottom of the screen, select File > 
View > Full View > Report -> Bottom from the main menu; this can be found by 
selecting the three lines in the top left-hand corner of the screen, hovering over 
“View”, hovering over “Full View”, and then selecting “Report -> Bottom”.  

 

b. Keyboard Shortcuts 

i. Page View: keyboard shortcut is “F9” 

ii. Full View with report on the right of the screen: keyboard shortcut is “F10” 

iii. Full View with report on the bottom of the screen: keyboard shortcut is “F11” 

Change the Lane Configuration 
1. When a new file is created or an existing file is opened, the lane configuration can be changed 

under the Lanes sections. This can be found on the Lanes page if using Page View or the input 
portion of the split screen if using Full View 
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a. Page View  

 

b. Full View  

 

2. To add lanes, click on the lane buttons (black arrows) on the edges of the lanes graphic. If the 
background of a lane button is white, the lane is available to add to the corresponding approach. 
If the background of a lane button is gray, it is disabled and cannot be added to the 
corresponding approach based on the current lane configuration. 
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a. Each approach allows up to three lanes to be added  

 

b. Each approach allows up to three thru (exclusive or shared) lanes to be added  
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c. Adding one or two exclusive thru (T) lanes will disable the shared left-thru-right (LTR) and 
shared left-right (LR) lanes  

  

d. Adding a shared left-right (LR) lane will disable all other lanes  
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e. Adding a shared left-thru-right (LTR) lane will disable all other lanes  

 

f. Adding an exclusive left (L) lane will disable the exclusive left (L), shared left-thru (LT), 
shared left-thru-right (LTR), and shared left-right (LR) lanes  
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g. Adding a shared left-thru (LT) lane will disable the exclusive left (L), shared left-thru (LT), 
shared left-thru-right (LTR), and shared left-right (LR) lanes  

 

h. Adding a shared thru-right (TR) lane will disable the shared left-thru-right (LTR), shared 
left-right (LR), shared thru-right (TR), and exclusive right (R) lanes  
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i. Adding an exclusive right (R) lane will disable the shared left-thru-right (LTR), shared left-
right (LR), shared thru-right, and exclusive right (R) lanes  

 

3. To remove lanes, click on the lanes within the center of the lanes graphic (white arrows). Clicking 
on an arrow will immediately remove the lane and change which lane buttons are 
enabled/disabled for the corresponding approach. 

4. Changes to the lane configuration on the lanes graphic in the input screen will be reflected on the 
lanes graphic in the formatted report and the lane information in both the formatted and text 
reports.
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Enable and Edit the Percent Thrus Using Shared Lane 
Fields 

1. To enable the ‘Percent Thrus Using Shared Lane (%)’ field(s) for a specific approach, the lane 
configuration for the approach should have at least two thru lanes and one of the thru lanes must 
be a shared thru lane.  

 

a. To enable the Left field for ‘Percent Thrus Using Shared Lane (%)’ field, the lane 
configuration for the approach should include one of the following: 

i. LT, T 

ii. LT, T, T 

iii. LT, T, TR 

iv. LT, T, R 

v. LT, TR 

b. To enable the Right field for ‘Percent Thrus Using Shared Lane (%)’ field, the lane 
configuration for the approach should include one of the following: 

i. T, TR 

ii. L, T, TR 

iii. LT, T, TR 

iv. T, T, TR 
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v. LT, TR 

2. The percentage defaults populated in the ‘Percent Thrus Using Shared Lane (%)’ fields is 
dependent on the number of thru lanes coded. 

a. If there are two thru lanes coded for an approach, the corresponding percentage would 
be 50. 

i. LT, T: Left = enabled, 50; Right = disabled 

ii. LT, T, TR: Left = enabled, 50; Right = disabled 

iii. T, TR: Left = disabled; Right = enabled, 50 

iv. L, T, TR: Left = disabled; Right = enabled, 50 

v. LT, TR: Left = enabled, 50; Right = enabled, 50 

b. If there are three thru lanes coded for an approach, the corresponding percentage would 
be 33. 

i. LT, T, T: Left = enabled, 33; Right = dsabled 

ii. LT, T, TR: Left = enabled, 33; Right = enabled, 33 

iii. T, T, TR: Left = disabled; Right = enabled, 33 

3. The range for the ‘Percent Thrus Using Shared Lane (%)’ is from 0 to 100. 

4. The percentages can be edited and will maintain a maximum total of 100% for the approach. 

a. Lane Configuration: LT, TR (both Left and Right fields are enabled) 

i. If one field is edited that will cause the total of the two fields to exceed 100, the 
other field will automatically adjust according to the initial field edited. For 
example: if both fields are set at 50, one is edited to 70, the other will 
automatically be set to 30. 

ii. When there are only two thru lanes, the total of the two fields must equal 100. 
For example: if both fields are set at 50, one is edited to 25, the other will 
automatically be set to 75. 

b. Lane Configuration: LT, T, TR 

i. The total of the two fields can be less than 100. For example, if both fields are set 
at 33, one is edited to 20, the other will remain at 33. 

ii. When there are three thru lanes, the total of the two fields cannot exceed 100. 
For example, if both fields are set at 33, one is edited to 80, the other will 
automatically be set to 20. 



AWSC User Guide How To  35 

View Results of the Analysis 
1. After editing all the necessary inputs, results of the analysis can be found in the form of reports. 

Reports can be found on the Report page if using Page View or on the results portion of the split 
screen if using Full View. 

a. Page View with Report page displayed  

 

b. Full View with the report on the right of the screen  
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c. Full View with the report on the bottom of the screen  

 

2. There are two options for reports: Formatted and Text 

a. Formatted reports show the most important results in a presentable format  
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b. Text reports show a more detailed analysis in plain text  

 

3. The type of report displayed can be changed by using the main menu items, keyboard shortcuts, 
or toggle buttons found under the report 

a. Main Menu Items 

i. To switch to the Formatted Report, select File > Report > Formatted Report from 
the main menu; this can be found by selecting the three lines in the top left-hand 
corner of the screen, hovering over “Report”, and then selecting “Formatted 
Report”. 

 

ii. To switch to the Text Report, select File > Report > Text Report from the main 
menu; this can be found by selecting the three lines in the top left-hand corner of 
the screen, hovering over “Report”, and then selecting “Text Report”.
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b. Keyboard Shortcuts 

i. Formatted Report: keyboard shortcut is “F4” 

ii. Text Report: keyboard shortcut is “F6” 

c. Report Toggle Buttons 

i. Whether viewing the report in Page View or Full View, a toggle button will be 
available at the bottom of the screen underneath the report. 

ii. If the formatted report is currently being displayed, the toggle button will say 
“Switch to Text Report” which will allow you to display the text report if clicked. 
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iii. If the text report is currently being displayed, the toggle button will say “Switch to 
Formatted Report” which will allow you to display the formatted report if clicked. 

 

4. The magnification of the report currently being displayed can be changed using the zoom slider 
found at the bottom right-hand corner of the screen.  

 

a. To zoom in, drag the slider to the right; to zoom out, drag the slider to the left 

b. Clicking the plus (+) button will zoom in; clicking the minus (-) button will zoom out
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c. Holding down “ctrl” on the keyboard and scrolling up on the mouse wheel will zoom in; 
holding down “ctrl” on the keyboard and scrolling down on the mouse wheel will zoom out 

Print a Report 
1. There are four options for printing a report: 

a. Selecting File > Print from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Print”  

 

b. Selecting File > Print Preview from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Print Preview” 

 

c. Using keyboard shortcut “Ctrl+P” for Print 

d. Using keyboard shortcut “Ctrl+F2” for Print Preview 
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2. Print 

a. Using Print will bring up a Print dialog box where you can select which printer to print to 

 

3. Print Preview 

a. Using Print Preview will bring up a window where you can view how the report will look 
on paper before sending it to the printer  

 

b. The print icon in the toolbar found in the top left-hand corner can then be selected 
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c. A Print dialog box will pop up where you can select which printer to print to  
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Glossary of Terms 

Agency 
This field is provided to document the agency or company associated with this analysis or project. 

Analysis Time Period 
The length of time (T) the peak flow remains constant (usually 0.25 hours) and is used in the delay 
equations. If v/c exceeds 0.90, control delay may be significantly affected by the value of T. The range is 
0.25 hrs to 3.00 hours. The default is 0.25 hours. 

Analysis Year 
This field is provided to document the year for which the analysis is being performed. 

Analyst 
The field is provided to document the individual performing the analysis. 

Capacity 
Capacity is the maximum hourly rate at which persons or vehicles can be reasonably expected to 
traverse a point or uniform segment of a lane or roadway during a given time period under prevailing 
roadway, traffic, and roadway conditions. 

Control Delay 
Control Delay is the portion of total delay attributed to traffic control measures, either traffic signals or stop 
signs. 

Date Performed 
The date will default to the computer's date, but may be edited. The format of the date is determined by 
the user's 'Short date style' preferences (regional setting icon on the Control Panel). 
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Delay 
The difference between the travel time actually experienced and the reference travel time that would 
result during conditions with ideal geometric characteristics and in the absence of incidents, control, and 
traffic. 

East/West Street Name 
The name of the east/west intersecting street is coded to document the intersection being analyzed. 

Intersection 
The name of the intersection, usually defined by the two intersecting streets, is coded to document the 
intersection being analyzed and will be printed on the report. 

Jurisdiction 
The field is provided to document any jurisdiction convention or project related information. 

Lanes 
Lanes is a graphic data entry screen for coding lane configuration data. Lane combinations can be 
selected by clicking on the appropriate arrows to place them on the central diagram for each approach. 
Clicking on an arrow on the central diagram will remove it. As arrows are selected, others may become 
disabled as appropriate.  

Note: As stipulated in the HCM methodology, each approach can have up to three lanes. 

Level of Service (LOS) 
A level of service is a letter designation that describes a range of operating conditions on a particular type 
of facility. Six levels of service are defined, using the letters A through F. Level of service A represents the 
best level of service, and generally describes operation of free flow and very low delay. Level of service F 
represents the worst operating conditions. 

LOS criteria for AWSC intersections are given in the exhibit below. As the exhibit notes, LOS F is 
assigned if the volume-to-capacity (v/c) ratio of a lane exceeds 1.0, regardless of the control delay. For 
assessment of LOS at the approach and intersection levels, LOS is based solely on control delay. 

 

Movement Volume 
The value of movement volume is a number between 0 and 9999 veh/h. The default value is 0 veh/h. 
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North/South Street Name 
The name of the north/south intersecting street is coded to document the intersection being analyzed. 

Peak-Hour Factor 
The hourly volume during the analysis hour divided by the peak 15-min flow rate within the analysis hour; 
a measure o traffic demand fluctuation within the analysis hour. The peak-hour factor (PHF) is entered for 
the intersection to compute peak flow rates. 

Percent Heavy Vehicles 
The percentage of heavy vehicles is entered for each movement. This value is used in the calculation of 
headway adjustment. 

Percent Thrus Using Shared Lane 
When there is a shared left-thru or shared thru-right lane coded beside a thru lane(s), this field is 
activated to provide for the percentage traffic split. 

Project Description 
This field is provided for the user to document the analysis with any information for identification 
purposes. 

Queue Length 
Queue Length is the number of vehicles in queue. 

Stored Heavy Vehicle Length 
The lane length in feet, or meters in metric, occupied by a queued heavy vehicle; this affects the 
computation of queue length 

Stored Passenger Car Length 
The lane length in feet, or meters in metric, occupied by a queued passenger car; this affects the 
computation of queue length 

Time Analyzed 
Documenting the time frame of the analysis as morning peak, afternoon peak, existing conditions, future 
projections, etc. 

Traffic Volume 
The hourly volumes (V) for each movement are coded in vehicles per hour (veh/h). 

v/c Ratio 
The v/c Ratio is the volume capacity ratio, which is the volume of one movement (or shared-lane 
movements) divided by the movement capacity of the movement (or shared-lane movements).
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