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Introduction 

License Agreement 
HIGHWAY CAPACITY SOFTWARE™ (HCS™)  
END-USER LICENSE AGREEMENT (EULA) 
 
Effective Date: 10/15/2024 
 
 
Copyright © 2024 University of Florida. All rights reserved. 
 
This End User License Agreement (“Agreement”) is a legal agreement between you (“End User”, “you”) 
and the University of Florida Board of Trustees for the benefit of the McTrans Center (“McTrans”, ”we”) 
regarding the use of the Highway Capacity Software (“Software”). By accessing or using the Software 
programs within the electronically transmitted package or direct download, you agree to be bound by the 
terms and conditions of this Agreement.  
 
 
1. INTEGRATION: 
This License Agreement is the complete and exclusive statement of the agreement between End User 
and McTrans and supersedes any previous End User License Agreements distributed by older versions 
of the software proposal or prior agreement, oral or written, and any other communications between End 
User and McTrans relating to the subject matter of this License Agreement. This EULA will supersede the 
End User License Agreement contained in the HCS Version 5, 6, and 7 modules disseminated as part of 
the Software. This License Agreement may only be modified by a written agreement made subsequent to 
the date hereof and signed by both parties. 
 
 
2. LICENSE GRANT: 
2.1 Subscription-Based License: 
McTrans grants you a non-exclusive, non-transferable license to access and use the Software, subject to 
the terms of your active subscription. The license is valid only for the duration of your subscription and is 
contingent upon full payment of all applicable fees. 
 
2.2 Access to Software Versions:  
Your subscription grants access to versions 5 (selected modules), 6 (selected modules), 7 and 8 series 
and beyond (2022 onward) of the Software. When a new version of the Software is released, the End 
User with an active subscription can download and access the latest version at no additional cost for the 
remainder of their subscription term. 
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3. TYPES OF SUBSCRIPTIONS: 
The type of subscription determines the permitted use of the Software. Once a subscription type is 
selected, it cannot be changed or exchanged for a different type. 
 
3.1 Office-Based Subscription: 
This subscription grants access to the Software for a predetermined number of computers within a 
physical office. An "office" refers exclusively to a fixed geographical location, typically a single physical 
address, where an organization conducts its business or operational activities. This location must consist 
of one or more contiguous rooms or spaces within a single building. Virtual offices or any non-physical 
locations are excluded from this definition. 
 
The Software may be installed on multiple devices within the office, and access is restricted to end users 
officially assigned to that licensed office. End Users may also use the Software on portable computers, 
such as laptops, while on official travel, provided that all (100%) such use is exclusively on behalf of the 
office for which this Software license was purchased. Additional offices must obtain proper licensing prior 
to accessing the Software. The Software may only be installed on devices owned or controlled by the 
licensed office. 
 
This subscription is intended exclusively for commercial use. 
 
Virtualization Restriction:  
The Software under an office-based subscription is prohibited from being used in a virtualized 
environment. All installations of the Software must be conducted on a physical computer, such as a 
desktop or laptop. Remote access technologies, such as remote desktop, are strictly prohibited under this 
subscription type. 
 
3.2 Computer-Based Subscription: 
This subscription permits the installation and use of the Software on a specified number of individual 
devices. An "individual device" refers to a single, standalone computing unit, such as a desktop or laptop, 
intended for use by a single user at a time. It is not shared concurrently with other users and is intended 
for use by a single user only The Software may only be accessed directly from the device(s) on which it is 
installed, regardless of whether the device is located in a physical office or used in a virtual office. End 
users working remotely or in virtual offices must ensure that the device remains dedicated to their use 
and fully complies with the terms of this subscription. 
 
Virtualization Restriction:  
The Software under a computer-based subscription is prohibited from being used in a virtualized 
environment. All installations must be conducted on a physical computer, such as a desktop, PC, or 
laptop. Remote access to the Software via any technology, including but not limited to remote desktop, is 
strictly prohibited under this subscription type. 
 
3.3 Academic Subscription: 
The academic subscription is available exclusively to academic institutions and grants access to a 
specified number of seats (copies) across the entire academic institution. This subscription is intended 
solely for use in a classroom setting for teaching or a lab for research purposes under the direct 
supervision of faculty or other authorized personnel. The Software may only be installed on devices 
owned or controlled by the academic institution. 
 
The End User is required to implement appropriate protection measures to prevent students or any other 
individuals from copying the Software and removing it from the lab or classroom environment. The 
responsibility for safeguarding the Software and preventing unauthorized copying or distribution rests 
entirely with the End User. 
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Virtualization for Virtual Classrooms:  
Under the academic license, the End User may request permission to utilize a virtual environment for the 
installation and use of the Software. Such virtualization is only permitted with prior written consent from 
McTrans. If such permission is granted, the virtual environment must adhere to all protections and 
restrictions outlined in this Agreement, ensuring that the Software is used exclusively for its intended 
educational purposes and its access is limited to the institution's faculty and actively enrolled students 
only. Additionally, the number of seats purchased must be sufficient to cover the number of students and 
faculty accessing the virtual classroom. 
 
 
4. SUBSCRIPTION TERM: 
4.1 Duration: 
The subscription term begins on the date of purchase and continues for the period specified at the time of 
purchase ("Subscription Term"). The license granted under this Agreement is valid only for the duration of 
the Subscription Term. 
 
4.2 Renewal: 
Subscriptions may be renewed upon payment of applicable fees before the end of the Subscription Term. 
If the subscription is not renewed, access to the Software and all related services, including technical 
support, will be terminated. 
 
 
5. TECHNICAL SUPPORT: 
5.1 Support Services: 
During the active Subscription Term, the End User is entitled to reasonable telephone or email support 
provided during the normal business hours of McTrans. McTrans reserves the right to determine the 
extent of the support provided. 
 
5.2 Revisions and Enhancements: 
McTrans reserves the right to make substantial revisions and enhancements to the Software and to 
market such substantially revised versions as separate products. The End User shall not be entitled to 
receive such separate products without additional charge. Upon the release of any such revised version 
of the Software, the obligation to provide the above-described technical support services to the End User 
shall cease unless the End User chooses to pay to license the enhanced version of the Software, 
regardless of whether the End User has previously requested or received support on the prior version. 
 
 
6. NETWORK USE: 
The End User is strictly prohibited from using the Software on any network. This prohibition includes but is 
not limited to the use of the Software either directly or indirectly through commands, data, or instructions 
transmitted to or from a computer that is not licensed or is not part of the licensed internal network. This 
also includes any use for Internet or web hosting services or by any user who does not hold a valid 
license for the Software from McTrans. 
  
The Software is not designed for network use, and such use is unsupported. McTrans will not provide 
technical support for any issues resulting from network incompatibilities or unauthorized network use. 
 
 
7. RESTRICTIONS ON USE 
The End User agrees that they shall not, nor shall they permit any third party to: 

● Software Modification: Modify, adapt, translate, or create derivative works based on the Software, 
in whole or in part, without the express prior written consent of McTrans. 

● Reverse Engineering: Reverse engineer, decompile, disassemble, or otherwise attempt to derive 
the source code of the Software, except to the extent expressly permitted by applicable law. 
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● Unauthorized Use: Use the Software for any purpose other than as expressly permitted under this 
Agreement, including unauthorized copying, distribution, or dissemination of the Software. 

● Intellectual Property Infringement: Engage in any activity that infringes on the intellectual property 
rights of McTrans, including any unauthorized copying or distribution of the Software or 
associated documentation. 

● Copying and Distribution: Copy, reproduce, or distribute the Software or associated printed 
documentation for sale, distribution, or dissemination, except as expressly provided under the 
terms of this Agreement or with the express prior written consent of McTrans. 

● Documentation Use: Reproduce the associated documentation only as necessary for use within 
the permitted scope of the subscription type as outlined in this Agreement. 

 
Ownership of Software Modifications:  
Any modifications, adaptations, translations, derivative works, or any other products or materials resulting 
from any prohibited actions shall become the exclusive property of McTrans, regardless of whether such 
actions were performed with or without McTrans’ consent. 
 
 
8. INTELLECTUAL PROPERTY RIGHTS: 
The Software and all associated intellectual property rights are owned by McTrans. No rights are granted 
to the End User other than the limited license expressly set forth in this Agreement. 
 
 
9. USE OF RESULTS IN RESEARCH AND COMMERCIAL PUBLICATIONS: 
McTrans grants the End User legal permission to use the results generated by the Software in academic, 
research, or commercial publications, provided that such use complies with the terms of this agreement. 
The End User may publish or present findings derived from the Software as part of their research or 
commercial work as long as the Software is properly cited and all applicable license terms and restrictions 
are adhered to. Unauthorized reproduction or distribution of the Software itself remains strictly prohibited. 
 
 
10. TRANSFER RESTRICTIONS:  
The Software is licensed only to the End User, and this License Agreement may not be assigned or 
transferred to anyone without McTrans’ prior written consent. Any authorized transferee of this License 
Agreement shall be bound by the terms of this License Agreement. The End User may not transfer, 
assign, rent, lease, sell, or otherwise dispose of the Software except as expressly provided in this License 
Agreement.  
 
 
11. LIMITED WARRANTY AND LIMITATIONS OF REMEDIES: 
End User acknowledges and agrees that it is the sole responsibility of End User to fully understand the 
limitations and assumptions underlying the Software and to refrain from using the Software without the 
assistance of personnel with appropriate expertise. The End User accepts full responsibility for reviewing, 
interpreting, applying, and utilizing the output of the Software and for ensuring that such output complies 
with any applicable design codes, standards, or project specifications. 
 
Except as expressly provided herein, the Software is provided “AS IS” without warranty of any kind, 
whether expressed or implied, including, but not limited to, implied warranties of merchantability and 
fitness for a particular purpose. McTrans does not warrant that the functions contained in the Software will 
meet the End User’s requirements or that the operation of the Software will be uninterrupted or error-free. 
The entire risk as to the quality and performance of the product is with the End User.  
 
In no event will McTrans be liable to the End User for any damages, including any lost profits, lost 
savings, or other incidental or consequential damages arising out of the use of or inability to use the 
Software, even if McTrans has been advised of the possibility of such damages, or for any claim by any 
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other party. The above warranty gives the End User specific legal rights, and the End User may also have 
other rights in the United States, which vary from state to state.  
 
Use of the Software where the End User believes or has reason to believe that damage may occur 
constitutes a violation of any and all warranties. McTrans has no knowledge of the hardware or Software 
configurations of the End User and assumes no liability for their damage. 
 
 
12. TERMINATION: 
12.1 Termination by McTrans: 
McTrans may terminate this Agreement immediately upon notice if you fail to comply with any term or 
condition of this Agreement. Upon termination, you must cease all use of the Software and destroy all 
copies of the Software in your possession. 
 
12.2 Termination by End User: 
You may terminate this Agreement at any time by discontinuing the use of the Software and notifying 
McTrans. No refunds will be provided for any remaining portion of the Subscription Term. 
 
 
13. GOVERNING LAW: 
This License Agreement shall be governed by the laws of the State of Florida, U.S.A. Venue for all 
disputes related to this License Agreement shall be in the United States District Court of the Northern 
District of Florida, Gainesville Division, or in the Circuit Court of the Eighth Judicial Circuit for Alachua 
County, Florida. 
 
 
14. U.S. GOVERNMENT RESTRICTED RIGHTS: 
The Software and associated documentation are provided with RESTRICTED RIGHTS. Use, duplication, 
or disclosure by the U.S. Government is subject to restrictions as set forth in subdivision (c)(1)(ii) of The 
Rights in Technical Data and Computer Software clause at 52.227-7013 or subparagraphs (c)(1) and (2) 
of the Commercial Computer Software - Restricted Rights at 48CFR52.227-19. The contractor is 
McTrans, University of Florida, PO Box 116585, Gainesville, FL 32611-6585. 
 
 
15. EXPORT REGULATION: 
The Software may be subject to U.S. export control laws and regulations, including the U.S. Export 
Control Reform Act and its associated regulations. End User will not directly or indirectly export, re-export, 
transfer, or release the Software to, or make the Software accessible from, any country, jurisdiction, or 
person to which export, re-export, transfer, or release is prohibited by applicable U.S. laws and 
regulations. End User will comply with all applicable laws and regulations and complete all required 
undertakings (including obtaining any necessary export license or other governmental approval) prior to 
exporting, re-exporting, transferring, or releasing, or otherwise making the Software available, outside the 
U.S. End User shall not export, re-export, transfer, or release the software or software source code to any 
country which is comprehensively sanctioned by the U.S. Department of the Treasury, Office of Foreign 
Assets Control (OFAC), as updated from time to time, which currently includes: Cuba, Iran, North Korea, 
Syria, and the Donetsk, Luhansk, and Crimea regions of Ukraine. 
 
 
16. SEVERABILITY:  
If any portion of this License Agreement shall be declared void or a nullity by a court of competent 
jurisdiction, then the remainder shall survive and remain in full force. Should you have any questions 
concerning this license, you may contact the McTrans Center, University of Florida, PO Box 116585, 
Gainesville, FL 32611-6585, U.S.A., [1] (800) 226-1013. 
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Getting Started 

System Requirements 
HCS is designed for standard Windows installations. For optimal performance, the system should be 
Windows 10 or newer. While HCS may be compatible with older versions of Windows, any installation 
and operational issues arising from using these older versions will be the sole responsibility of the end 
user. 

Getting Started 
To begin, click on File then New (or the "New File" icon).  

Normal Windows keyboard and mouse functions are available. The PgUp and PgDn keys will scroll the 
entry screen up and down respectively. Tabbing, clicking to a new field, or pressing the Enter key will 
trigger a recalculation and update the Report pane. 

Roundabout Analysis 

Roundabout intersection analyses will estimate Capacity and Level of Service (LOS) for a given set of 
traffic and geometric conditions. This type of analysis is oriented toward the evaluation of an existing or 
planned facility. The methodology and procedures of application use the HCM Chapter 22 procedures. 
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General Controls 

Menu Items 
New – Creates a new Roundabouts file (*.xro) and starts a new analysis project; shortcut is Ctrl+N 

Open – Opens an existing Roundabouts file (*.xro, *.xra); shortcut is Ctrl+O 

Example Folder – Opens folder with all HCS examples in File Explorer 

Save – Saves an open Roundabouts file (*.xro) using the current file name; shortcut is Ctrl+S 

Save As… – Saves an open Roundabouts file (*.xro) using a specified file name; shortcut is F12 

Close – Closes an existing Roundabouts file (*.xro); shortcut is Ctrl+W 

Units 

 USC Units – Changes the units of the current file to U.S. Customary 

 Metric Units – Changes the units of the current file to Metric 

Print – Brings up printer selection and prints a Roundabouts report to the printer or specified file type; 
shortcut is Ctrl+P 

Print Preview – Displays preview of current report before printing; shortcut is Ctrl+F2 

View  

 Page View – Changes the view to display inputs and reports by pages; shortcut is F9 

 Full View 

Report -> Right – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the right portion of the screen; shortcut is F10 

Report -> Bottom – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the bottom portion of the screen; shortcut is 
F11 

Report 

Roundabout Formatted Report – Displays formatted report of the currently selected intersection 
including the most important values; shortcut is F4 

Roundabout Text Report – Displays text report with all input, intermediary, and final results of 
the currently selected intersection; shortcut is F6 

Segment Formatted Report – Displays formatted report of the currently selected segment 
including the most important values; shortcut is F7 
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Segment Text Report – Displays text report with all input, intermediary, and final results of the 
currently selected segment; shortcut is F8 

Full Segments Report – Displays formatted report for all segments including the most important 
values; shortcut is F3 

Default Settings – Opens a dialog box for the user to input defaults for Analyst, Agency, and Jurisdiction, 
which will be applied to all new files; also allows selection of USC or SI units, which will be applied to all 
new files; shortcut is Alt+F 

Help 

Contents – Provides access to glossary, acknowledgements, copyrights, and information on the 
HCM procedures; shortcut is Ctrl+F1 

Index – Allows user to search for keywords within the glossary 

Search – Allows user to search for any word within the Contents 

User Guide – Opens a comprehensive user guide in PDF format; shortcut is Ctrl+G 

HCM Reference Guide – Opens a reference guide for the HCM in PDF format 

HCS Updates – Sends the HCS version number anonymously without any personally identifiable 
information to McTrans to check for a newer version 

HCM/HCS Training – Opens the McTrans Training Page in the default web browser to view the 
latest training opportunities 

HCQS Web Page – Opens the TRB Highway Capacity and Quality of Service Committee page in 
the default web browser 

Support 

Frequently Asked Questions – Opens the McTrans support page for HCS in the default 
web browser 

HCS Overview – Opens the McTrans HCS Overview page in the default web browser 

McTrans Website – Opens the McTrans home page in the default web browser 

E-mail McTrans – Composes a new e-mail addressed to McTrans in the default e-mail 
client with registration number, serial key, module, and version number already populated 
in the Subject field 

About HCS – Opens an about window with software version information, EULA, general 
acknowledgements, contact information, and other relevant links 

CORSIM 

View Animation – Sends data to the TSIS-CORSIM program for simulation and/or animation 
purposes, TRAFVU can be opened within TSIS-CORSIM to allow user to view animation; 
shortcut is Ctrl+Shift+A 

Generate TRF File – Saves an open Roundabouts file (*.xro) as a CORSIM file (*.trf), which is a 
file that contains the input data used to define a CORSIM network and to drive the CORSIM 
simulation for a single simulation case; shortcut is Ctrl+Shift+T 

Exit – Exits the HCS Roundabouts module; shortcut is Alt+F4 
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Roundabouts 

HCM Chapter 22 
Roundabouts are intersections with a generally circular shape, characterized by yield on entry and 
circulation around a central island (counterclockwise in the United States). Roundabouts have been used 
successfully throughout the world and are being used increasingly in the United States, especially since 
1990. Chapter 22, Roundabouts, presents concepts and procedures for analyzing these types of 
intersections. 

LIMITATIONS OF THE METHODOLOGY 

The procedures presented in this chapter cover many of the typical situations that a user may encounter 
in practice. However, there are sometimes applications for which alternative tools can produce a more 
accurate analysis. The following limitations, stated earlier in this chapter, may be addressed by using 
available simulation tools. The conditions beyond the scope of this chapter that are treated explicitly by 
alternative tools include 

 Pedestrian signals or hybrid beacons at roundabout crosswalks, 

 Metering signals on one or more approaches, 

 Adjacent signals or roundabouts, 

 Priority reversal under extremely high flows, 

 High pedestrian or bicycle activity levels, 

 More than two entry lanes on an approach, or 

Flared entry lanes. 

HCM Chapter 33 
Chapter 33 is the supplemental chapter for Chapter 22, Roundabouts, which is found in Volume 3 of the 
Highway Capacity Manual (HCM). This chapter presents detailed information about the following aspects 
of the Chapter 22 motorized vehicle methodology: 

 Information about the large variability in U.S. driver behavior at roundabouts, 

 Guidance on making an appropriate selection of a lane utilization factor, and 

 Guidance on calibrating the capacity model to reflect local conditions. 

This chapter also provides example problems that demonstrate the application of the Chapter 22 
methodology to single-lane and multilane roundabouts. 
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Operational Data 
This Highway Capacity Software (HCS) faithfully implements the methodology prescribed in the Highway 
Capacity Manual (HCM) for analyzing Roundabouts. 

First, the user enters the Project Properties into the respective fields: Analyst, Agency, Date, Time 
Analyzed, Jurisdiction, Analysis Year, Project Description, and Facility Name. Then, the user enters the 
Intersection Data into the respective fields: Intersection Name, East/West Street Name, North/South 
Street Name, Analysis Time Period, Peak Hour Factor, and Proportion of CAVs. The Analysis Time 
Period is normally 15 minutes (T=0.25 hr) to represent the length of time the peak flow is constant.  

Lane Designations 

The geometry of each approach is described by coding the number of lanes and the movements allowed 
in each lane, including whether movements are exclusive or shared. These are coded with the use of the 
Roundabouts lane graphic. Each approach allows for two lanes to be coded and one bypass lane, if 
necessary. Lanes for an approach will be disabled depending on what is already coded. Defining the 
number of lanes and usage is necessary to allow further analysis.  

The Conflicting Lanes on Entry is specified for each approach as the number of lanes that pass directly in 
front of the subject entry. It can be coded by either clicking on the arrows within the roundabout or by 
changing the number in the textboxes below the graphic. The number of conflicting lanes on entry for an 
approach can be either 1 or 2. 

If a right-turn bypass lane is necessary for an approach, the user can choose to code either a Yielding or 
a Non-Yield Right-Turn Bypass Lane. The yellow arrow represents a yielding right-turn bypass lane and 
the green arrow represents a non-yielding right-turn bypass lane. If a yielding right-turn bypass lane is 
coded for an approach, the corresponding textbox for Conflicting Lanes on Bypass Exit will enable, 
allowing the user to specify the number of lanes as 1 or 2. 

Traffic Volumes 

The Volume for each movement of the intersection is coded in vehicles per hour. An hourly volume is 
required for any movement to be included in the analysis. The Percent Heavy Vehicles (%HV) and 
Passenger Car Equivalent is entered for each movement. The Percent of Entry Vehicles Using Left Lane 
is also entered for each approach if there are two lanes coded for the approach and both lanes have the 
same movement. This field provides for the traffic split for the two lanes. For example, if there is a LT and 
TR coded for one approach, the Percent of Entry Vehicles Using Left Lane field will enable for the 
approach to allow the user to specify how the thru volume is distributed among the two lanes. 

For queue length calculations, the Stored Passenger Car Length and Stored Heavy Vehicle Length are 
provided. 

Pedestrian Volumes 

The Number of Pedestrians Crossing Entry for each entry of the intersection is coded in pedestrians per 
hour. 

Critical Headway and Follow-up Headway 

The default values for Critical Headway and Follow-Up Headway depends on the roundabout geometry. 
To calibrate the capacity equations, these values can be adjusted from the default values. 
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Results 

Level of Service (LOS) criteria for Roundabouts in control delay (s/veh): 

 
Control Delay is computed for each critical lane, approach and the intersection as a whole. Critical lanes 
where the volume-to-capacity ratio is more than 1.0, LOS F is assigned regardless of control delay. 

Roundabout Report 
The report can be displayed in either Page or Full View. If displayed in Page View, the results will 
automatically update when the user switches to the Report page. From the Report page, the user can 
then switch between the formatted report and the text report using the button found at the bottom of the 
page. The formatted report shows the most important results in a presentable format, while the text report 
shows a detailed step-by-step analysis in plain text.  

If displayed in Full View, the report can be displayed along with the input screen. The user has the choice 
of displaying the report to the right of the input screen or below the input screen. The report is dynamic 
and reacts to changes in the input screen. Like the Report page in Page View, the user can switch 
between the formatted report and the text report using the button found at the bottom of the report.  

All or a portion of the reports can be copied to the Windows clipboard for insertion into other files by right-
clicking into the Report pane and selecting Copy. The user can also change the display of the report 
through File Menu or with the use of shortcuts. See General Controls. 
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Roundabout Segments 

HCM Chapter 30 
Roundabout Segment methodology is a subsection in Chapter 30, Urban Streets Segments. It provides 
an overview of the methodology for evaluating the performance of the motorized vehicle mode on an 
urban street segment bounded by one or more roundabouts. The procedure is based on national 
research that measured the travel time performance of nine corridors containing three or more 
roundabouts in series. The procedure is designed to be integrated into the general computation process 
for urban street segments described in Chapter 18. Only the relevant deviations from the general 
procedure are provided in this subsection. 

LIMITATIONS OF THE METHODOLOGY 

The methodologies in this subsection are based on regression analyses of field-measured data. The 
limits of these field data are provided in Exhibit 30-40. The analyst is cautioned regarding the validity of 
the results when an input or intermediate calculated value is outside the range of the research data. In 
addition, the methodology does not account for capacity constraint caused by oversaturated conditions or 
the possible effects of an upstream signal on a downstream roundabout. 

Operational Data 
This Highway Capacity Software (HCS) faithfully implements the methodology prescribed in the Highway 
Capacity Manual (HCM) for analyzing Roundabout Segments. 

The user enters all the information necessary in a normal Roundabouts dataset. When a second 
Roundabout is added, the program will recognize the dataset as a Roundabout Segments dataset and all 
the necessary fields for the Roundabout Segments procedure will appear. 

Intersection/Segment Selection 

In a Roundabout Segments dataset, at least two intersections need to be coded. In the upper right-hand 
corner of the screen, the user has the option to add and delete intersections in the dataset with the use of 
‘+’ and ‘-‘ buttons, respectively. Segments will be added based on the number of intersections added. The 
user also has the ability to change the display of the input screen and reports by switching between 
intersections and segments with the use of drop-down menus. 

Roundabout Properties 

In addition to the general Roundabout properties, Roundabout Segments also requires input of Average 
Width of Circulating Lanes and Inscribed Circle Diameter, both of which are in units of feet (or meters in 
metric units), and Speed Limit, which is in units of mi/h (or km/h in metric units). The information displayed 
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on the input screen and current report is dependent on which Roundabout Intersection is selected. 
Roundabout Intersection selection can be found in the upper right-hand corner of the screen. 

Segment Properties 

When more than one Roundabout is coded in a dataset, the program will recognize the analysis as a 
Roundabout Segments analysis. A Segment Properties intersection will appear on the input screen after 
the Roundabout Properties section. The Name of the segment can be input but is not necessary. 
Segment Length is a required input. For both the Forward and Reverse directions, required inputs include 
BFFS Calibration Factor, Restrictive Median, Right-Hand Curb, Right-Hand Access Points, and On-Street 
Parking, and Mid-Segment Demand Flow Rate.  

Roundabout Segments Report 
The report can be displayed in either Page or Full View. If displayed in Page View, the results will 
automatically by updated when the user switches to the Report page. In Full View, the report can be 
displayed along with the input screen. The user has the choice of displaying the report to the right of the 
input screen or below the input screen. The report is dynamic and reacts to changes in the input screen. 
The user can switch between the formatted report and the text report using the buttons found at the 
bottom of the report or using the buttons found in the menu items.  

For the formatted report, there are two types of reports that can be displayed: the Segment or the 
Roundabout report. If the user chooses to display the Roundabout report, the intersection displayed for 
the report will depend on which intersection is currently displayed for the input screen. A dropdown menu 
in the upper right-hand corner of the screen allows the user to switch between intersections. If there are 
multiple segments and the user chooses to display the Segment report, the segment displayed for the 
report will depend on which segment is currently displayed for the input screen. Similarly, a dropdown 
menu in the upper right-hand corner of the screen allows the user to switch between segments. 

For the text report, there are two types of reports that can be displayed: the Segment or the Roundabout 
report. If the user chooses to display the Roundabout report, the intersection displayed for the report will 
depend on which intersection is currently displayed for the input screen. A dropdown menu in the upper 
right-hand corner of the screen allows the user to switch between intersections. If there are multiple 
segments and the user chooses to display the Segment report, the segment displayed for the report will 
depend on which segment is currently displayed for the input screen. Similarly, a dropdown menu in the 
upper right-hand corner of the screen allows the user to switch between segments. 

All or a portion of the reports can be copied to the Windows clipboard for insertion into other files by right-
clicking into the Report pane and selecting Copy. The user can also change the display of the report 
through File Menu or with the use of shortcuts. See General Controls. 
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How To 

Create a New File 
1. From the Start screen, there are three options for creating a new file:  

 
Note: A new file can be created if an existing file is already open; you do not need to start from 
the Start screen. 
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a. Selecting File > New from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “New” 

 

b. Selecting “New File…” from the Start screen; this can be found below in the red box 

 

c. Using keyboard shortcut “Ctrl+N” 

2. Once a new file is created, you will be brought to the General page if in Page View or the input 
screen split with the report either on the right or the bottom of the screen if in Full View 
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a. Page View  

 

b. Full View  
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Open an Existing File 
1. From the Start screen, there are six options for opening an existing file:  

 
Note: A file can be opened even if another file is currently open; you do not need to start from the 
Start screen. 

a. Selecting File > Open from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Open”  
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b. Selecting “Open File…” from the Start screen; this can be found below in the red box 

 

c. Using the keyboard shortcut “Ctrl+O” 

d. Selecting a file under the Recent files list from the Start screen; this can be found below 
in the red box  

 

e. Selecting File > Example Folder from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Example Folder”. 
Opening the example folder will open the path of the HCS example files in File Explorer. 
The desired example file can be double-clicked or right-clicked and selecting ‘Open’, 
which will open the example file in the Roundabouts program. 
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f. Selecting “Example Folder…” from the Start screen; this can be found below in the red 
box. Opening the example folder will open the path of the HCS example files in File 
Explorer. The desired example file can be double-clicked or right-clicked and selecting 
‘Open’, which will open the example file in the Roundabouts program. 

 

2. Once an existing file is opened, you will be brought to the General page if in Page View or the 
input screen split with the report either on the right or the bottom of the screen if in Full View 
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a. Page View  

 

b. Full View  
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Save a File 
1. There are five options for saving an open file: 

a. Selecting File > Save from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Save”  

 

b. Selecting File > Save As… from the main menu; this can be found by selecting the three 
lines in the top left-hand corner of the screen and then selecting “Save As…” 

 

c. Using the keyboard shortcut “Ctrl+S” for Save 

d. Using the keyboard shortcut “F12” for Save As 
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e. Exiting the program or closing the file without saving changes beforehand; this will 
prompt you to save changes to the file before anything is closed  

 

i. Selecting “Yes” will save the file if it is an existing file. If the file has not been 
previously saved, the Save As dialog box will pop up allowing you to change the 
file name and save it. 

ii. Selecting “No” will exit the program or close the file without saving the file 

iii. Selecting “Cancel” will prevent the file from closing 

Note: Using Save with an existing file will save a file without prompting you to specify a file name. Using 
Save with a new file will bring up the Save As dialog box for you to specify a file name for saving. Using 
Save As will always bring up the Save As dialog box for you to specify a file name for saving. 

Close a File 
1. There are three options for closing an open file: 

a. Selecting File > Close from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Close”  

 

b. Using the keyboard shortcut “Ctrl+W” 

c. Exiting the program itself; please see How To: Exit the Program 
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Exit the Program 
1. From the Start screen, there are three options for exiting the program:  

 
Note: The program can be exited even if a file is still open; you do not need to start from the Start 
screen. 

a. Selecting File > Exit from the main menu; this can be found by selecting the three lines in 
the top left-hand corner of the screen and then selecting “Exit”  

 

b. Using the keyboard shortcut “Alt+F4” 
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c. Selecting “X” in the top right-hand corner of the screen; this can be found below in the red 
box 

 

Edit the Default Settings 
1. From the Start screen, there are two options for editing the Default Settings:  

 
Note: The Default Settings can be changed even if an existing file is already open; you do not 
need to start from the Start screen. 



26  How To Roundabouts User Guide 

a. Selecting File > Default Settings from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Default Settings” 

 

b. Using the keyboard shortcut “Alt+F” 

2. Opening the Default Settings will cause a Default Settings window to pop up:  

 

3. You can specify Analyst, Agency, and Jurisdiction by clicking on the corresponding text boxes 
and typing the desired text. 

4. Under ‘Units’, you are given the option of running the analysis in either U.S. Customary (USC) or 
SI (Metric) units. 

5. Clicking “OK” will save the changes made and close the Default Settings window; clicking 
“Cancel” will close the Default Setting window without saving and changes. 

6. When a new file is created, the Analyst, Agency, and Jurisdiction fields will automatically be 
populated with the text specified in the Default Settings. 

7. When starting a new file, the input and results will display according to the units specified in the 
Default Settings. 
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Change the View 
1. When a file is open, there are three main options for the view of the program: 

a. Page View: the inputs and results reports are separated into pages as seen below. You 
can navigate between pages using the “Back” and “Next” buttons or by clicking the page 
names found at the top of the screen.  

 

b. Full View with the report on the right of the screen: the screen is split with all inputs on 
the left side and the results reports on the right side. You can access all inputs and view 
all of the current report by using the corresponding scroll bars. There is also a screen 
splitter that can be moved to adjust the views of the input screen and results report. 
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c. Full View with the report on the bottom of the screen: the screen is split with all inputs on 
the top of the screen and the results report on the bottom of the screen. You can access 
all inputs and view all of the current report by using the corresponding scroll bars. There 
is also a screen splitter that can be moved to adjust the view of the input screen and 
results report.  

 

2. Views can be changed by using the main menu items or the keyboard shortcuts. 

a. Main Menu Items 

i. To switch to Page View, select File > View > Page View from the main menu; this 
can be found by selecting the three lines in the top left-hand corner of the screen, 
hovering over “View”, and then selecting “Page View”.  

 

ii. To switch to Full View with the report on the right of the screen, select File > View 
> Full View > Report -> Right from the main menu; this can be found by selecting 
the three lines in the top left-hand corner of the screen, hovering over “View”, 
hovering over “Full View”, and then selecting “Report -> Right”. 
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iii. To switch to Full View with the report on the bottom of the screen, select File > 
View >  Full View > Report -> Bottom from the main menu; this can be found by 
selecting the three lines in the top left-hand corner of the screen, hovering over 
“View”, hovering over “Full View”, and then selecting “Report -> Bottom”.  

 

b. Keyboard Shortcuts 

i. Page View: keyboard shortcut if “F9” 

ii. Full View with report on the right of the screen: keyboard shortcut is “F10” 

iii. Full View with report on the bottom of the screen: keyboard shortcut is “F11” 

Change the Lane Configuration 
1. When a new file is created or an existing file I opened, the lane configuration can be changed 

under the Lanes section. This can be found on the Geometry page if using Page View or the input 
portion of the split screen if using Full View. 
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a. Page View  

 

b. Full View  

 

2. To add lanes, click on the lane buttons (black, yellow, or green arrows within boxes) on the edges 
of the lanes graphic. If the background of a lane button is white, the lane is available to add to the 
corresponding approach. If the background of a lane button is gray, it is disabled and cannot be 
added to the corresponding approach based on the current lane configuration.  

 

a. The black arrows include all the standard lanes: exclusive left-turn (L), shared left-thru 
(LT), shared left-thru-right (LTR), shared left-right (LR), exclusive thru (T), shared thru-
right (TR), and exclusive right (R) lanes. 

b. The yellow and green arrows include the right-turn bypass lanes. The yellow arrow 
indicates a yielding right-turn bypass lane; the green arrow indicates a non-yielding right-
turn bypass lane. 
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c. Each approach allows up to two standard lanes to be added  

 

d. Each approach allows up to one right-turn bypass lane to be added  

 

e. Adding an exclusive left-turn (L) lane will disable the exclusive left-turn (L) lane  
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f. Adding a shared left-thru (LT) lane will disable the shared left-thru (LT), shared left-thru-
right (LTR), and shared left-right (LR) lanes  

 

g. Adding a shared left-thru-right (LTR) lane will disable the shared left-thru (LT), shared 
left-thru-right (LTR), shared left-right (LR), exclusive thru (T), and shared thru-right (TR) 
lanes 

 

h. Adding a shared left-right (LR)  lane will disable the shared left-thru (LT), shared left-thru-
right (LTR), shared left-right (LR), exclusive thru (T), and shared thru-right (TR) lanes 
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i. Adding an exclusive thru (T) lane will disable the shared left-thru-right (LTR) and shared 
left-right (LR) lanes  

 

j. Adding a shared thru-right (TR) lane will disable the shared left-thru-right (LTR), shared 
left-right (LR), and shared thru-right (TR) lanes  

 

k. Adding an exclusive right (R) will disable the exclusive right (R) lane  
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l. Adding a yielding right-turn bypass lane will disable both the yielding and non-yielding 
right-turn bypass lanes  

 

m. Adding a non-yielding right-turn bypass lane will disable both the yielding and non-
yielding right-turn bypass lanes  

 

3. To remove lanes, click on the lanes within the approach (white arrows and/or yellow or green 
arrows outside of the roundabout circle). Clicking on an arrow will immediately remove the lane 
and change which lane buttons are enabled/disabled for the corresponding approach. 

4. Within the roundabout circle are white arrows for each approach. These represent the number of 
circulating lanes. The circulating flow arrow(s) simply toggles between one and two lanes for each 
approach. 
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5. Changes to the lane configuration on the lanes graphic in the input screen will be reflected on the 
lanes graphic in the formatted report and the lane information in both the formatted and text 
reports. 

Add or Delete Roundabout Intersections 
1. In a roundabout analysis, there can be a single roundabout or multiple roundabouts. Whether in 

Page View or Full View, drop down menus for Intersection and Segment, along with plus (+) and 
minus (-) buttons are provided at the top right-hand corner of the window next to the information 
icon. 

 

2. When the current analysis only has one roundabout, the Segment drop down menu is disabled 
and the Intersection drop down menu will only have one choice.  
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3. To add a roundabout to an analysis, select the plus (+) button next to the Intersection drop down 
menu. This will add a roundabout intersection after whichever roundabout is currently selected in 
the Intersection drop down menu. When a new intersection is added, it will also be listed in the 
drop down menu. If the Segment drop down menu was previously disabled, it will now be enabled 
and a new segment will be listed in the Segment drop down menu. For every intersection 
included in an analysis, there will be one less segment included. For example, an analysis with 
two intersections will have one segment and an analysis with three intersections will have two 
segments.  

 

4. The intersection selected in the Intersection drop down menu will be the current intersection 
displayed on the input screen and results report. Similarly, the segment selected in the Segment 
drop down menu will be the current segment displayed on the input screen and results report.  
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5. To delete a roundabout from an analysis, select the minus (-) button next to the Intersection drop 
down menu. This will remove whichever roundabout intersection is currently selected in the 
Intersection drop down menu.  

 

View Results of the Analysis 
1. After editing all the necessary inputs, results of the analysis can be found in the form of reports. 

Reports can be found on the Report page if using Page View or on the results potion of the split 
screen if using Full View. 

a. Page View with Report page displayed  
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b. Full View with the report on the right of the screen  

 

c. Full View with the report on the bottom of the screen  

 

2. There are two types of reports: Formatted and Text 

a. Formatted reports show the most important results in a presentable format. Options 
available for formatted reports include: Roundabout Formatted Report, Segment 
Formatted Report, and Full Segments Report. 
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b. Text reports show a more detailed analysis in plain text. Options available for text reports 
include: Roundabout Text Report and Segment Text Report.  

 

3. The type of report displayed can be changed by using the main menu items, keyboard shortcuts, 
or toggle buttons found under the report 

a. Main Menu Items 

i. To switch to the Roundabout Formatted Report, select File > Report > 
Roundabout Formatted Report from the main menu; this can be found by 
selecting the three lines in the top left-hand corner of the screen, hovering over 
“Report”, and then selecting “Roundabout Formatted Report”. 
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ii. To switch to the Roundabout Text Report, select File > Report > Roundabout 
Text Report from the main menu; this can be found by selecting the three lines in 
the top left-hand corner of the screen, hovering over “Report”, and then selecting 
“Roundabout Text Report”.  

 

iii. To switch to the Segment Formatted Report, select File > Report > Segment 
Formatted Report from the main menu; this can be found by selecting the three 
lines in the top left-hand corner of the screen, hovering over “Report”, and then 
selecting “Segment Formatted Report”. Note: This will only be enabled if there 
are multiple Roundabouts in the current analysis.  
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iv. To switch to the Segment Text Report, select File > Report > Segment Text 
Report from the main menu; this can be found by selecting the three lines in the 
top left-hand corner of the screen, hovering over “Report”, and then selecting 
“Segment Text Report”. Note: This will only be enabled if there are multiple 
Roundabouts in the current analysis.  

 

v. To switch to the Full Segments Report, select File > Report > Full Segments 
Report from the main menu; this can be found by selecting the three lines in the 
top left-hand corner of the screen, hovering over “Report” and then selecting “Full 
Segments Report”. Note: This will only be enabled if there are multiple 
Roundabouts in the current analysis. 
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b. Keyboard Shortcuts 

i. Formatted Report: keyboard shortcut is “F4” 

ii. Text Report: keyboard shortcut if “F6” 

c. Report Toggle Buttons 

i. Whether viewing the report in Page View or Full View, a toggle button(s) will be 
available at the bottom of the screen underneath the report. 

ii. If there is a single roundabout in the current analysis and the roundabout 
formatted report is currently being displayed, one toggle button will be displayed 
and will say “Switch to Text Report” which will allow you to display the 
roundabout text report if clicked.  

 

iii. If there is a single roundabout in the current analysis and the roundabout text 
report is currently being displayed, one toggle button will be displayed and will 
say “Switch to Formatted Report” which will allow you to display the roundabout 
formatted report if clicked. 



Roundabouts User Guide How To  43 

 

iv. If there are multiple roundabouts in the current analysis and the roundabout 
formatted report is currently being displayed, two toggle buttons will be displayed. 
One will say “Switch to Text Report” which will allow you to display the 
roundabout text report if clicked. The other will say “Switch to Segment Report” 
which will allow you to display the segment formatted report if clicked. 

 

v. If there are multiple roundabouts in the current analysis and the roundabout text 
report is currently being displayed, two toggle buttons will be displayed. One will 
say “Switch to Formatted Report” which will allow you to display the roundabout 
formatted report if clicked. The other will say “Switch to Segment Report” which 
will allow you to display the segment text report if clicked. 
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vi. If there are multiple roundabouts in the current analysis and the segment 
formatted report is currently being displayed, two toggle buttons will be displayed. 
One will say “Switch to Text Report” which will allow you to display the segment 
text report if clicked. The other will say “Switch to Roundabout Report” which will 
allow you to display the roundabout formatted report if clicked. 

 

vii. If there are multiple roundabouts in the current analysis and the segment text 
report is currently being displayed, two toggle buttons will be displayed. One will 
say “Switch to Formatted Report” which will allow you to display the segment 
formatted report if clicked. The other will say “Switch to Roundabout Report” 
which will allow you to display the roundabout text report if clicked. 
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4. The magnification of the report currently being displayed can be changed using the zoom slider 
found at the bottom right-hand corner of the screen.  

 

a. To zoom in, drag the slider to the right; to zoom out, drag the slider to the left 

b. Clicking the plus (+) button will zoom in; clicking the minus (-) button will zoom out 

c. Holding down “ctrl” on the keyboard and scrolling up on the mouse wheel will zoom in; 
holding down “ctrl” on the keyboard and scrolling down on the mouse wheel will zoom out 

Print a Report 
1. There are four options for printing a report: 

a. Selecting File > Print from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Print” 
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b. Selecting File > Print Preview from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Print Preview” 

 

c. Using keyboard shortcut “Ctrl+P” for Print 

d. Using keyboard shortcut “Ctrl+F2” for Print Preview 

2. Print 

a. Using Print will bring up a Print dialog box where you can select which printer to print to 
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3. Print Preview 

a. Using Print Preview will bring up a window where you can view how the report will look 
on paper before sending it to the printer  

 

b. The print icon in the toolbar found in the top left-hand corner can then be selected 
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c. A print dialog box will pop up where you can select which printer to print to  
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Glossary of Terms 

Agency 
This field is provided to document the agency or company associated with this analysis or project. 

Analysis Time Period 
The length of time (T) the peak flow remains constant (usually 0.25 hr) and is used in the delay equations 

Analysis Year 
This field is provided to document the year for which the analysis is being performed. 

Analyst 
This field is provided to document the individual performing the analysis. 
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Average Width of Circulating Lanes 
The average width of circulating lanes is measured in the section of circulatory roadway immediately 
downstream of the entry, that is, the same location where the number of circulating lanes is counted. It is 
measured in feet (or meters in metric). This is illustrated in the following: 

  

Base Free-Flow Speed Calibration Factor 
The Base Free-Flow Speed Calibration Factor, Scalib, is used to adjust Base Free-Flow Speed and is in 
units of miles per hour (or kilometers per hour in metric). The Base-Free Flow Speed equation has been 
calibrated using data for many urban street segments collectively located throughout the U.S., so the 
default value of 0.0 mi/h (or km/h in metric) for Scalib is believed to yield results that are reasonably 
representative of driver behavior in most urban areas. However, if desired, a locally representative value 
can be determined from field-measured estimates of the base free-flow speed for several street 
segments. The local default value can be established for typical street segments, or for specific street 
types. 
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Capacity 
The maximum sustainable hourly flow rate at which persons or vehicles can be reasonably expected to 
traverse a point or a uniform section of a lane or roadway during a given time period under prevailing 
roadway, environmental, traffic, and control conditions. 

CAVs 
Connected and automated vehicles, or CAVs, integrate two separate types of technology, 
communications and automation. The combination of these technologies is required to achieve roadway 
capacity increases, as described below:  

 Connected vehicles transmit data about their status to their surroundings (e.g., roadside 
infrastructure, other road users). They also receive information about their surroundings (e.g., 
traffic conditions, weather conditions, presence of potential conflicting vehicles, traffic signal 
timing) that motorists can use to adjust their driving behavior in response to conditions present at 
a given time and location. The exchange of information offers potential safety, fuel economy, and 
environmental benefits. However, it is not clear how connectivity affects car following and driver 
behavior and subsequently intersection movement capacity. 

 Automated vehicles take over all or a portion of the driving task. Depending on the level of 
automation, a human may still need to take over under certain conditions. In the absence of 
connectivity, the information available to automated vehicles is limited to that which can be 
gathered by on-board sensors, which is typically constrained by a sensor’s line of sight and the 
rate at which the sensor takes measurements (e.g., 10 times per second). As a result, for both 
safety and passenger comfort reasons, current adaptive cruise control systems offer minimum 
time gaps that are similar to, or longer than, the gaps used by human drivers, and thus may 
decrease roadway capacity when in widespread use. 

 Connected and automated vehicles communicate with each other and with roadside 
infrastructure. The connectivity element provides automated driving systems with more complete 
information about a vehicle’s surroundings and enables cooperative vehicle maneuvers that 
improve roadway operations. The vehicle’s enhanced detection capabilities, as well as 
redundancy in detection, enable an automated driving system to operate more efficiently and 
more safely than with only an on-board system. 

Conflicting Lanes on Bypass Exit 
Conflicting Lanes on Bypass Entry are the lanes that pass directly in front of the subject yielding bypass 
lane. For this field, select the number of conflicting lanes. 

Conflicting Lanes on Entry 
The Conflicting Lanes of Entry are the lanes that pass directly in front of the subject entry. For this field, 
select the number of conflicting lanes. 

Control Delay 
The portion of total delay attributed to traffic control measures 

Critical Headway 
The minimum headway in the traffic stream that will allow entry of one vehicle into the roundabout. Critical 
headway is used in determining capacity equations: 
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where  

cpce = lane capacity, adjusted for heavy vehicles (pc/h), 

vc = conflicting flow (pc/h) 

tc = critical headway (s), and 

tf = follow-up headway (s). 

Current Intersection 
A drop-down menu is provided for the current intersection to allow the user to change which intersection 
information to display on the input screen and for the reports. 

Current Segment 
A drop-down menu is provided for current segment to allow the user to change which segment 
information to display on the input screen and for the reports. 

Date 
The date will default to the computer's date, but may be edited. The format of the date is determined by 
the user's 'Short date style' preferences (regional setting icon on the Control Panel). 

Delay 
The difference between the travel time actually experienced and the reference travel time that would 
result during conditions with ideal geometric characteristics and in the absence of incidents, control, and 
traffic 

Delay Due to Turns 
The delay due to turns is the delay to through vehicles that follow vehicles turning from the major street 
into an unsignalized access point intersection. This delay can be incurred at any access point intersection 
along the street. For right-turn vehicles, the delay results when the following vehicles’ speed is reduced to 
accommodate the turning vehicles. For left-turn vehicles, the delay results when the following vehicles 
must wait in queue while a vehicle ahead executes a left-turn maneuver at the access point. This delay 
occurs primarily on undivided streets; however, it can also occur on divided streets when the left-turn 
queue exceeds the available storage and spills back into the inside through lane. 

The delay estimation process consists of the following two procedures: 

 Delay due to left turns, and 

 Delay due to right turns 
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East/West Street Name 
This field is provided to document the name of the east/west intersecting street of the intersection being 
analyzed. 

Entry Flow 
The traffic flow entering a roundabout on the subject approach 

Facility Name 
This field is provided to document a name for the facility. 

Follow-Up Headway 
The time between the departure of one vehicle from an approach and the departure of the next vehicle 
using the same critical headway, under a condition of continuous queueing. 

Follow-up headway is used in determining capacity equations: 

 

where  

cpce = lane capacity, adjusted for heavy vehicles (pc/h), 

vc = conflicting flow (pc/h) 

tc = critical headway (s), and 

tf = follow-up headway (s). 

Forward Direction 
This specifies the direction the segments run and the direction for segment calculations such as running 
time, through delay, travel speed, etc. There are four choices for Forward Direction: EB, WB, NB, and SB. 
If EB is the Forward Direction, then WB is the Reverse Direction, and vice versa. Similarly, if NB is the 
Forward Direction, then SB is the Reverse Direction, and vice versa. 

Geometry 
Geometry is a graphic data entry screen for coding lane configuration data. Lane combinations can be 
selected by clicking on the appropriate arrows to place them on the central diagram for each approach. 
Clicking on an arrow on the central diagram will remove it. As arrows are selected, others may become 
disabled as appropriate. For right-turn bypass lanes, the yellow right-turn arrow is used for yielding and 
the green right-turn arrow is used for non-yielding. While these will show just outside of the approach, 
clicking on them will also remove them. The circulating flow arrow simply toggles between one and two 
lanes for each approach. 
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Inscribed Circle Diameter 
The inscribed circle diameter, ICD, is the diameter of the largest circle that can be inscribed within the 
outer edges of the circulatory roadway. The ICD serves as the width of the roundabout and is measured 
in feet (or meters in metric). This is illustrated in the following: 

 

Intersection 
The name of the intersection, usually defined by the two intersecting streets, is coded to document the 
intersection being analyzed and will be printed on the report. 

Intersection Delay 
The Intersection Delay is the total additional travel time experienced by drivers, passengers, or 
pedestrians as a result of control measures and interaction with other users of the facility, divided by the 
volume departing from the corresponding cross section of the facility. 

Jurisdiction 
This field is provided to document any jurisdiction convention or project related information. 

Level of Service (LOS) 
A level of service is a letter designation that describes a range of operating conditions on a particular type 
of facility. Six levels of service are defined; using the letters A through F. Level of service A represents the 
best level of service, and generally describes operation of free flow and very low delay. Level of service F 
represents the worst operating conditions. 
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LOS criteria for Roundabouts are given in the exhibit below. 

 

Midsegment Demand Flow Rate 
The number of vehicles or other roadway users passing the middle of the segment. 

North/South Street Name 
This field is provided to document the name of the north/south intersecting street of the intersection being 
analyzed. 

Number of Circulating Lanes 
The number of circulating lanes represents the count of circulating lanes immediately downstream of the 
entry that forms the end of the segment under study. 

On-Street Parking 
The percentage of the segment with on-street parking represents that percent of the link length that has 
parking stalls (either marked or unmarked) available along the right side of the segment. The user enters 
this value as a percentage, which is converted into a proportion. This proportion is computed as the 
length of street with parking stalls divided by the link length. Parking stalls considered include those 
described as having either a parallel or angle design. This proportion is separately computed for each 
direction of travel along the segment. 

Passenger Car Equivalent 
The number of passenger cars that will result in the same operational conditions as a single heavy 
vehicle of a particular type under identical roadway, traffic, and control conditions. 

Peak Hour Factor 
The hourly volume during the analysis hour divided by the peak 15-min flow rate within the analysis hour; 
a measure of traffic demand fluctuation within the analysis hour. The peak-hour factor is entered for the 
intersection to compute peak flow rates. 

Pedestrians Crossing Entry 
The number of pedestrians per hour crossing the approach entry 
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Percent Heavy Vehicles 
The percentage of heavy vehicles is entered for each movement. This value is used to adjust flow rate for 
heavy vehicles. 

Percent of Entry Vehicles Using Left Lane 
When the corresponding approach has two lanes coded with the same movement, the field is activated to 
specify the percentage of vehicles using the left lane. 

However, please note that enabling/disabling of the field will also depend on de facto lanes. The assumed 
(de facto) lane assignments can be found below in HCM Exhibit 22-14: 

 

On the basis of the assumed lane assignment for the entry and the lane utilization effect described above, 
flow rates can be assigned to each lane by using the formulas given below in HCM Exhibit 22-15: 

 

Project Description 
This field is provided for the user to document the analysis with any information for identification 
purposes. 

Proportion of CAVs 
This is the proportion of CAVs in the traffic stream. CAV is a connected and automated vehicle, defined 
here as a vehicle with an operating cooperative adaptive cruise control system. The range of proportion of 
CAVs in the traffic stream is from 0 to 100. 

CAVs may improve the capacity of roundabout approaches through their potential to safely accept 
smaller gaps in traffic than human drivers. The proportion of the traffic stream that is composed of CAVs 
will influence the achievable capacity increase. The greater the proportion of CAVs in the traffic stream, 
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the more frequently the benefits of connectivity can be realized, because more vehicles will be able to 
accept smaller gaps safely. 

The proportion of CAVs is used in determining the adjustment factor for the intercept parameter (fA) and 
the adjustment factor for the slope parameter (fB), which are then used in determining the entry lane 
capacity. The HCM exhibit below is used to determine fA and fB.  

 

Restrictive Median Length 
The restrictive median length represents the length, in feet (or meters in metric), of street with a restrictive 
median (e.g., raised curb). This length is measured from median nose to median nose along the 
centerline of the street. It does not include the length of any median openings on the street. This is 
specified for both the Forward and the Reverse Directions. 

Right-Hand Access Points 
The number of access point approaches along a segment represents the count of all unsignalized 
driveway and public-street approaches to the segment, regardless of whether the access point is 
considered to be “active.” This number is counted separately for each side of the segment. It must equal 
or exceed the number of “active” access point approaches for which delay to segment through vehicles is 
computed.  

Right-Hand Curb 
The percentage of the segment with curb represents that percent of the link length that has curb along the 
right side of the segment and this curb is within 4 feet of the traveled way (i.e., within 4 feet of the nearest 
edge of traffic lane). The user enters this value as a percentage, which is converted into a proportion. 
This proportion is computed as the length of street with a curb present (and within 4 feet) divided by the 
link length. The length of street with a curb present is measured from the start of the curbed cross section 
to the end of the curbed cross section on the link. The width of driveway openings is not deducted from 
this length. This proportion is computed separately for each direction of travel along the segment. 

Right-Turn Bypass 
Right-turn bypass lanes can either be yielding or non-yielding. A yielding right-turn bypass lane 
terminates at a high angle, with right-turning traffic yielding to exiting traffic. A non-yielding right-turn 
bypass lane merges at a low angle with exiting traffic or forms a new lane adjacent to exiting traffic.
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Roundabout 
A roundabout is an intersection with a generally circular shape, characterized by yield on entry and 
circulation around a central island. 

Segment Length 
Segment length represents the distance between the boundary intersections that define the segment. The 
point of measurement at each intersection is the stop line, yield line, or the functional equivalent in the 
subject direction of travel. This length is measured along the centerline of the street. If it differs in the two 
travel directions, then an average length is used. This value is measured in units of feet (or meters in 
metric). 

Segment Name 
This field is provided to document the name of the segment being analyzed. 

Speed Limit 
The posted speed limit along the direction of travel in miles per hour (or kilometers per hour in metric). 
Speed limit influences Base Free-Flow Speed and is used to determine the Speed Constant in the Base 
Free-Flow Speed calculation. The range of speed limits is restricted to 25 through 50 mi/h (or 40.2 
through 80/5 km/h in metric). The following table shows how to determine the Speed Constant based on 
the Speed Limit. 
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Stored Heavy Vehicle Length 
The lane length in feet, or meters in metric, occupied by a queued heavy vehicle; this affects the 
computation of queue length 

Stored Passenger Car Length 
The lane length in feet, or meters in metric, occupied by a queued passenger car; this affects the 
computation of queue length 

Time Analyzed 
This field is provided to document the time period over which the analysis was conducted. 

v/c Ratio 
The v/c ratio is the volume-to-capacity ratio, which is the volume of one movement (or shared-lane 
movements) divided by the movement capacity of the movement (or shared-lane movements). 

Volume 
The total number of vehicles or other roadway users that pass over a given point or section of a lane or 
roadway during a given time interval. The volumes (V) for each movement are coded in vehicles per hour 
(veh/h). 
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