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Introduction 

License Agreement 
HIGHWAY CAPACITY SOFTWARE™, TRANSYT-7F™, AND HIGHWAY SAFETY SOFTWARE™ 
 
HCS2022™ END USER LICENSE AGREEMENT 
 
Copyright © 2021 University of Florida. All rights reserved. 
 
This is an agreement between you and the University of Florida Board of Trustees for the benefit of the 
McTrans Center. 
 
BY USING THE PROGRAMS WITHIN THE ELECTRONIC TRANSMITTED PACKAGE OR DIRECT 
DOWNLOAD (“SOFTWARE”), YOU AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE 
AGREEMENT. DO NOT USE THE SOFTWARE WITHOUT FIRST READING AND UNDERSTANDING 
THE TERMS OF THIS LICENSE AGREEMENT. 
 
If you do not agree with the terms of this license, discontinue use, delete and/or return the unused 
Software immediately to the distributor from which it was obtained. 
 
1. LICENSE: In consideration of the required license fee, the University of Florida McTrans Center 
(hereinafter called “McTrans”) hereby grants you (hereinafter called “End User”) a nonexclusive license to 
use the enclosed HIGHWAY CAPACITY SOFTWARE, TRANSYT-7F, and HIGHWAY SAFETY 
SOFTWARE in HCS2022 (hereinafter called “Software”) as described in the applicable portion of section 
3 for a period in which the End User pays the subscription fee established by McTrans. 
 
2. OWNERSHIP: This license is not a sale of the Software; it is a license to use the Software under the 
terms of this License Agreement.  
 
3. USE: The Software is licensed to End Users for a particular use, depending on the particular license 
that is designated on order and described in this Section 3. 
 
a. Single Office License. The End User may use the Software on any number of computers within End 
User’s immediate office, which is defined as a single organizational unit, having a unique function, 
comprising one or more contiguous rooms in a single location. All persons using the Software are also 
End Users. End Users may also use the Software on portable computers while on official travel and on 
home computers, as long as ALL such use is on behalf of the office for which this Software License was 
purchased. This Software License does not authorize the use of the Software at any offices that are 
related to that single organizational unit but are not located at the same geographic location, even if the 
Software is stored on a portable computer. If you have any questions as to the validity of your End User 
License, contact McTrans. 



2  Introduction Two-Way Stop Controlled Intersections Users Guide 

 
b. Academic License. The End User may use the Software only within a laboratory within End User’s 
immediate school, which is defined as a single school unit, having a unique function, comprising one or 
more contiguous rooms in a single location, up to the permitted (purchased) number of copies, provided 
the use is supervised in a classroom setting for teaching or research purposes, and appropriate 
protection is in place against students copying the Software and taking it out of the lab. The responsibility 
for ensuring this protection of the Software rests with the End User. Multiple laboratories require multiple 
licenses. The Software may not be installed or used on any computer outside of the licensed laboratory 
under the Academic License, including (but not limited to) any office, home, networked or portable 
computer. If you have any questions as to the type or validity of your End User License, contact McTrans. 
 
WARNING! If this license is a Single Office License for use in traffic and transportation applications, the 
Software may not be used for classroom or workshop instruction, demonstrations, conferences or other 
similar purposes without the express, written consent of McTrans. (Contact McTrans for an Academic 
License.) If this license is an Academic License for use in training or educational applications, the 
Software may not be used for traffic and transportation applications or other similar purposes without the 
express, written consent of McTrans. (Contact McTrans for an Applications License.) 
 
4. NETWORK INCOMPATIBILITIES: McTrans is not able to provide technical support for issues resulting 
from network incompatibilities. 
 
5. GENERAL: The Software is not designed for network use, and such use is not supported. No network 
use is permitted, including but not limited to, using the Software either directly or through commands, data 
or instructions from or to a computer not already licensed and part of the internal network, for Internet or 
web hosting services or by any user not licensed to use this copy of the Software through a valid license 
from McTrans. 
 
6. COPY RESTRICTIONS: Unauthorized copying, distribution, or dissemination of the Software is 
expressly prohibited. End User may be held legally responsible for any copyright infringement that is 
caused, encouraged, or enabled by failure to abide by the terms of this license. Subject to these 
restrictions, End User may make copies of the Software for backup purposes and for use of the Software 
on any computers located within its office complex, as described in paragraph 3. Under no circumstances 
may the Software or associated printed documentation be copied for sale, distribution, or dissemination, 
except as provided in paragraph 3, without the express, written consent of McTrans. End User may 
reproduce the associated documentation as necessary to use within the geographic location for which the 
license is granted. End User may not modify, adapt, translate, reverse engineer, decompile, disassemble, 
or create derivative work from the Software or any associated written materials without the prior written 
consent of McTrans. ANY SUCH ACTIVITY OR PRODUCT BECOMES THE PROPERTY OF McTRANS. 
 
7. TRANSFER RESTRICTIONS: The Software is licensed only to the End User, and this License 
Agreement may not be assigned or transferred to anyone without the prior written consent of McTrans. 
Any authorized transferee of this License Agreement shall be bound by the terms of this License 
Agreement. End User may not transfer, assign, rent, lease, sell, or otherwise dispose of the Software 
except as expressly provided in this License Agreement.  
 
8. REGISTRATION AND SUPPORT: This license is automatically registered to the person or entity that 
purchased it. If the End User wishes to change the registration, he or she must fill out and return the 
registration card contained in this package. McTrans may, from time to time, revise or update the 
Software to correct bugs or add minor improvements. McTrans will supply, at its discretion, minor updates 
to the End User without additional charge and will provide reasonable telephone or email support to the 
End User during the normal business hours of McTrans for the period for which End User pays the 
subscription fee established by McTrans. McTrans reserves the right to determine the extent of the 
support. McTrans reserves the right to make substantial revisions and enhancements to the Software and 
to market such substantially revised versions as separate products. End User shall not be entitled to 
receive such separate products without additional charge. Upon release of any such revised version of 
the Software, the obligation to provide the above described technical support services to End User shall 
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cease, unless End User chooses to pay to license the enhanced version of the Software, whether or not 
the End User has previously requested or received support on the prior version. 
 
9. LIMITED WARRANTY AND LIMITATIONS OF REMEDIES: McTrans warrants the magnetic or optical 
medium on which the Software is furnished to be free from defects in material and workmanship under 
normal use for a period of thirty (30) days from the date of delivery to the End User as evidenced by a 
copy of invoice. The entire liability and End User’s exclusive remedy shall be the replacement of any 
diskette found to be defective. Defective diskettes should be returned with a copy of the End User’s 
invoice to the distributor from which the Software was obtained. End User agrees that it is the 
responsibility of End User to understand fully the limitations of and assumptions underlying the Software 
and not to make use of the Software without the assistance of personnel with appropriate expertise. End 
User accepts all responsibility for review, application, and use of the program output and accepts all 
responsibility for assurance that the output meets provisions of any applicable design code, standard, or 
any project specification. 
 
EXCEPT AS PROVIDED ABOVE, THE PRODUCT IS PROVIDED “AS IS” WITHOUT WARRANTY OF 
ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. McTRANS 
DOES NOT WARRANT THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET END 
USER’S REQUIREMENTS OR THAT THE OPERATION OF THE SOFTWARE WILL BE 
UNINTERRUPTED OR ERROR-FREE. THE ENTIRE RISK AS TO THE QUALITY AND 
PERFORMANCE OF THE PRODUCT IS WITH THE END USER. IN NO EVENT WILL McTRANS BE 
LIABLE TO END USER FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR 
OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR 
INABILITY TO USE THE SOFTWARE EVEN IF McTRANS HAS BEEN ADVISED OF THE POSSIBILITY 
OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. THE ABOVE WARRANTY 
GIVES END USER SPECIFIC LEGAL RIGHTS AND END USER MAY ALSO HAVE OTHER RIGHTS IN 
THE UNITED STATES WHICH VARY FROM STATE TO STATE. USE OF THE SOFTWARE WHERE 
THE END USER BELIEVES OR HAS REASON TO BELIEVE THAT DAMAGE MAY OCCUR IS A 
VIOLATION OF ANY AND ALL WARRANTIES. McTRANS HAS NO KNOWLEDGE OF THE 
HARDWARE OR SOFTWARE CONFIGURATIONS OF THE END USER AND ASSUMES NO LIABILITY 
FOR THEIR DAMAGE. 
 
10. TERMINATION: This license is effective from the date End User receives the Software until this 
License Agreement is terminated. End User may terminate it by returning or destroying all copies of the 
Software and associated documentation in End User’s possession or control. If any terms of this license 
are breached by End User, the license shall terminate immediately. 
 
11. GOVERNING LAW: This License Agreement shall be governed by the laws of the State of Florida, 
U.S.A. Venue for all disputes related to this License Agreement shall be in the United States District Court 
of the Northern District of Florida, Gainesville Division, or in the Circuit Court of the Eighth Judicial Circuit 
for Alachua County Florida. 
 
12. U.S. GOVERNMENT RESTRICTED RIGHTS: The Software and associated documentation are 
provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the U.S. Government is subject 
to restrictions as set forth in subdivision (c)(1)(ii) of The Rights in Technical Data and Computer Software 
clause at 52.227-7013 or subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted 
Rights at 48CFR52.227-19. The contractor is McTrans, University of Florida, PO Box 116585, Gainesville, 
FL 32611-6585. 
 
13. EXPORT REGULATION: The Software may be subject to U.S. export control laws, including the U.S. 
Export Control Reform Act and its associated regulations. End User will not directly or indirectly, export, 
re-export, or release the Software to, or make the Software accessible from, any country, jurisdiction or 
person to which export, re-export, or release is prohibited by applicable law. End User will comply with all 
applicable laws and complete all required undertakings (including obtaining any necessary export license 
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or other governmental approval) prior to exporting, re-exporting, releasing, or otherwise making the 
Software available outside the U.S.  
 
14. INTEGRATION: This License Agreement is the complete and exclusive statement of the agreement 
between End User and McTrans and supersedes any proposal or prior agreement, oral or written, and 
any other communications between End User and McTrans relating to the subject matter of this License 
Agreement. This License Agreement may only be modified by a written agreement made subsequent to 
the date hereof and signed by both parties. 
 
15. SEVERABILITY: If any portion of this License Agreement shall be declared void or a nullity by a court 
of competent jurisdiction then the remainder shall survive and remain in full force. Should you have any 
questions concerning this license, you may contact the McTrans Center, University of Florida, PO Box 
116585, Gainesville, FL 32611-6585, U.S.A., [1] (352) 392-0378. 
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Getting Started 

Getting Started 
To begin, click on File then New (or the "New File…" from the Start screen). Normal Windows keyboard 
and mouse functions are available. In Full View, the PgUp and PgDn keys will scroll the entry screen up 
and down respectively. Tabbing, clicking to a new field, or pressing the Enter key will trigger a 
recalculation and update the Report pane in Full View. 

Two-Way Stop-Controlled (TWSC) Analysis 

Two-Way Stop-Controlled (TWSC) intersection analyses will estimate Capacity and Level of Service 
(LOS) for a given set of traffic and geometric conditions. This type of analysis is oriented toward the 
evaluation of an existing or planned facility. The methodology and procedures of application use the HCM 
Chapter 20 procedures. 
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General Controls 

Menu Items 
New – Creates a new TWSC file (*.xtw) and starts a new analysis project; shortcut is Ctrl+N 

Open – Opens an existing TWSC file (*.xhu, *.xtw); shortcut is Ctrl+O 

Example Folder – Opens folder with all HCS examples in File Explorer 

Save – Saves an open TWSC file (*.xtw) using the current file name; shortcut is Ctrl+S 

Save As… – Saves an open TWSC file (*.xtw) using a specified file name; shortcut is F12 

Close – Closes an existing TWSC file (*.xtw); shortcut is Ctrl+W 

Units 

 USC Units – Changes the units of the current file to U.S. Customary 

 Metric Units – Changes the units of the current file to Metric 

Print – Brings up printer selection and prints a TWSC report to the printer or specified file type; shortcut is 
Ctrl+P 

Print Preview – Displays preview of current report before printing; shortcut is Ctrl+F2 

View 

 Page View – Changes the view to display inputs and reports by pages; shortcut is F9 

 Full View 

Report -> Right – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the right portion of the screen; shortcut is F10 

Report -> Bottom – Changes the view to display both the input screen and report 
simultaneously; the report is displayed on the bottom portion of the screen; shortcut is 
F11 

Report 

 Formatted Report – Displays formatted report including the most important values; shortcut is F4 

 Text Report – Displays text report with all input, intermediary, and final results; shortcut is F6 

 RCUT Report – Displays formatted report for an RCUT analysis; shortcut is F7 

Default Settings – Opens a dialog box for the user to input defaults for Analyst, Agency, and Jurisdiction, 
which will be applied to all new files; also allows selection of USC or SI units, which will be applied to all 
new files; shortcut is Alt+F 
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Help 

Contents – Provides access to glossary, acknowledgements, copyrights, and information on the 
HCM procedure; shortcut is Ctrl+F1 

Index – Allows user to search for keywords within the glossary 

Search – Allows user to search for any word within the glossary 

User Guide – Opens a comprehensive user guide in PDF format; shortcut is Ctrl+G 

HCM6 Reference Guide – Opens the McTrans website in the default web browser to access the 
Highway Capacity Manual Reference Guide PDF 

HCS Updates – Sends the HCS version number anonymously without any personally identifiable 
information to McTrans to check for a newer version 

HCM/HCS Training – Opens the McTrans Training Page in the default web browser to view the 
latest training opportunities 

HCQS Web Page – Opens the TRB Highway Capacity and Quality of Service Committee page in 
the default web browser 

Support 

Frequently Asked Questions – Opens the McTrans support page for HCS in the default 
web browser 

HCS on the Web – Opens the McTrans HCS Overview page in the default web browser 

McTrans on the Web – Opens the McTrans home page in the default web browser 

E-mail McTrans – Composes a new e-mail addressed to McTrans in the default e-mail 
client with registration number, serial key, module, and version number already populated 
in the Subject field 

About HCS – Opens an about window with software version information, EULA, general 
acknowledgements, contact information, and other relevant links 

CORSIM 

View Animation – Sends data to the TSIS-CORSIM program for simulation and/or animation 
purposes, TRAFVU can be opened within TSIS-CORSIM to allow user to view animation; 
shortcut is Ctrl+Shift+A 

Generate TRF File – Saves an open TWSC file (*.xtw) as a CORSIM file (*.trf), which is a file that 
contains the input data used to define a CORSIM network and to drive the CORSIM simulation for 
a single simulation; shortcut it Ctrl+Shift+T 

TransModeler 

View Animation – Sends data to the TransModeler application by Caliper Corporation for 
simulation and/or animation purposes 

Exit – Exits the HCS TWSC module; shortcut is Alt+F4 
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Two-Way STOP Control (TWSC) 
Intersections 

HCM Chapter 20 
Two‐way STOP‐controlled (TWSC) intersections are common in the United States. One typical 
configuration is a four‐leg intersection, where one street—the major street—is uncontrolled, while the 
other street—the minor street—is controlled by STOP signs. The other typical configuration is a three‐leg 
intersection, where the single minor‐street approach (i.e., the stem of the T configuration) is controlled by 
a STOP sign. Minor street approaches can be public streets or private driveways. Chapter 20, Two‐Way 
STOP‐Controlled Intersections, presents concepts and procedures for analyzing these types of 
intersections. 
 
LIMITATIONS OF THE METHODOLOGY 
 
The methodologies in this chapter apply to TWSC intersections with up to three through lanes (either 
shared or exclusive) on the major‐street approaches and up to three lanes on the minor‐street 
approaches (with no more than one exclusive lane for each movement on the minor‐street approach). 
Effects from other intersections are accounted for only in situations in which a TWSC intersection is 
located on an urban street segment between coordinated signalized intersections. In this situation, the 
intersection can be analyzed by using the procedures in Chapter 18, Urban Street Segments. The 
methodologies do not apply to TWSC intersections with more than four approaches. 
 
The methodologies do not include a detailed method for estimating delay at YIELD‐controlled 
intersections; however, with appropriate changes in the values of key parameters (e.g., critical headway 
and follow‐up headway), the analyst could apply the TWSC method to YIELD‐controlled intersections. 
 
All the methods are for steady‐state conditions (i.e., the demand and capacity conditions are constant 
during the analysis period); the methods are not designed to evaluate how fast or how often the facility 
transitions from one demand or capacity state to another. Analysts interested in that kind of information 
should consider applying alternative tools. 

Operational Data 
GENERAL 

First, the user enters the General Information into the respective fields: Analyst, Agency, Date, and Time 
Analyzed, as well as site information for Jurisdiction, Analysis Year, Project Description, Intersection and 
Street Names. 
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The Major Street Direction is selected as either East-West or North-South form the drop-down menu 
options. 

Analysis Time Period is the length of time (T) the peak flow remains constant (usually 0.25 hr) and is used 
in the delay equations. If v/c exceeds 0.90, control delay may be significantly affected by the value of T. 

The Peak Hour Factor (PHF) for the intersection is coded under the Intersection Data. The HCM no 
longer permits PHF by movement. 

The Median Type is coded for the major street, either Undivided, Thru & Left, or Left Only. A raised, 
striped or two-way left-turn lane (TWLTL), often causes a special gap acceptance phenomenon known as 
two-stage gap acceptance where a significant proportion of the minor-street drivers cross part of the 
major-street then pause in the median to wait for a gap on the other approach.  

Undivided is selected when there is no median storage, disabling that field. Thru & Left is selected if the 
geometry permits both thrus and lefts from the minor street to store in the median for two-stage 
movements. Left Only is selected if only left turns (not thrus) can be stored, in a TWLTL for example. 

If a median type other than Undivided is selected, the Median Storage field will enable coding the number 
of vehicles able to be stored. 

In Page View, the Back and Next arrows on the left and right margins allow navigation between screens. 
This can also be done by selecting screens from the menu bar at the top among Start, General, Lanes, 
Traffic Headway, Adjustment, and Report. 

LANES 

Lanes is a graphic data entry screen for coding lane configuration data. Lane combinations can be 
selected by clicking on the appropriate arrows to place them on the central diagram for each approach. 
Clicking on an arrow on the central diagram will remove it. As arrows are selected, others may become 
disabled. 

Note: As stipulated in the HCM methodology, each major-street approach can have up to three thru lanes 
and one exclusive right- and/or left-turn lane (five lanes maximum). Each minor-street approach can have 
up to three lanes, a maximum of one exclusive lane for each movement. 

Enter the Percent Grade for each approach with positive values for upgrades and negative values for 
downgrades. These values are used to compute adjustment factors used in the computation of critical 
headway and follow-up headway. 

The Right Turn Channelized box is checked when the right-turning traffic from the major road is 
separated by a triangular island and has to comply with a stop or yield sign. This is a special case of an 
exclusive right-turn lane, which is coded in Lanes. 

The Flared Minor-Street Approaches box is checked when two vehicles may occupy or depart from the 
stop line simultaneously as a result of a large curb radius, a tapered curb, or a parking prohibition. This 
geometry may result in a greater capacity than if turning and through movement share only one lane. The 
magnitude of this effect depends in part on the turning-movement flow rates and the resultant probability 
of there being two vehicles simultaneously at the stop line, and in part on the storage length available to 
feed the second position at the stop line. The Flared Minor-Street Storage is the number of spaces for 
right turning passenger cars that can queue at the stop line without obstructing the access to the stop line 
for other movements. 

TRAFFIC 

The Volume for each movement of the intersection is coded in vehicles per hour. An hourly volume is 
required for any movement to be included in the analysis. Note that U-turns off the major street are now 
analyzed. 

Enter the Percent Heavy Vehicles for each movement. These values are used to compute adjustment 
factors used in the computation of critical headway and follow-up headway. 
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The Short Left-Turn Pocket box is checked if present and the Left-Turn Storage is coded for computing 
the delay to Rank 1 vehicles if the estimated queue exceeds the storage. 

If no exclusive left-turn lane is provided on the major street, it is possible for major-street thru (and 
possibly right-turning) traffic to be delayed by left-turning vehicles waiting for an acceptable gap. In this 
situation, the Saturation Flow Rate and Percent Thrus Using Shared Lane for the appropriate major street 
thru and right turn movements are required to compute the probability that there will be no queue in the 
respective major-street shared lanes. 

HEADWAY 

The Critical Headway is defined as the minimum time interval in the major-street traffic stream that allows 
intersection entry to one minor-street vehicle. The Base Critical Headway is obtained from HCM defaults 
for each movement for two-lane, four-lane, or six-lane major roads. Adjustments are made to account for 
the presence of heavy vehicles, approach grade, T-intersections and two-stage gap acceptance. 

Follow-Up Headway is the time span between the departure of one vehicle from the minor street and the 
departure of the next vehicle using the same major-street headway under a condition of continuous 
queuing on the minor street. The Base Follow-Up Headway is obtained from HCM defaults for each 
movement for either two-lane, four-lane, or six-lane major roads. 

Calibration of these values for local condition is strongly advised. If smaller values are observed, capacity 
will be increased. If larger values are used, capacity will be decreased. 

ADJUSTMENT 

Pedestrian Flows are the pedestrians crossing each approach (i.e., "Eastbound" pedestrians are those 
crossing the Eastbound vehicular approach) and are counted somewhat differently than vehicle flows. If a 
pedestrian crosses the intersection individually, then each pedestrian should be counted individually in 
the pedestrian flows. If pedestrians tend to cross in the groups, the number of groups should be counted 
in the pedestrian flow. The pedestrian volume is the sum of pedestrians crossing individually and groups 
of pedestrians crossing together during the time period of study. Minor-street traffic streams must yield to 
pedestrian streams.  

The Lane Width is entered as the average width for all lanes in the approach. 

The Pedestrian Walking Speed is entered to calculate the pedestrian blockage factor, or proportion of 
time that one lane on an approach is blocked during the analysis period. 

The Pedestrian Blockage Factor is automatically computed on the basis of the pedestrian flow rate, 
pedestrian walking speed, and the lane width. 

The Upstream Signal box is checked for the existence of a nearby upstream signalized intersection. An 
upstream signalized intersection usually causes vehicles to arrive at the subject intersection in platoons, 
which may cause an increase in the minor-street capacity compared with the case of random arrivals. The 
greater the number of vehicles traveling in platoons, the higher the minor-street capacity for a given 
opposing flow because there is a greater proportion of large gap sizes that can be used by more than one 
minor-street vehicle.  

To evaluate the impact of coordinated upstream signals, the urban street segments methodology is used 
to estimate the proportion of time that each Rank 2 or lower movement will be effectively blocked by a 
platoon. With these values, the proportion of the analysis period that is blocked for each minor movement 
can be computed. 
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Results 

Level of Service (LOS) criteria for TWSC intersections in control delay (s/veh): 

 

Control Delay and LOS are computed for each movement and approach. 

TWSC Report 
The report can be displayed in either Page or Full View. If displayed in Page View, the results will 
automatically update when the user switches to the Report page. From the Report page, the user can 
then switch between the formatted report and the text report using the button found at the bottom of the 
page. The formatted report shows the most important results in a presentable format, while the text report 
shows a detailed step-by-step analysis in plain text. 

If displayed in Full View, the report can be displayed along with the input screen. The user has the choice 
of displaying the report to the right of the input screen or below the input screen. The report is dynamic 
and reacts to changes in the input screen. Like the Report page in Page View, the user can switch 
between the formatted report and the text report using the button found at the bottom of the report. 

All or a portion of the reports can be copied to the Windows clipboard for insertion into other files by right-
clicking into the Report pane and selecting Copy. The user can also change the display of the report 
through File Menu or with the use of shortcuts. See General Controls. 
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Pedestrian Mode 

HCM Chapter 20 
This methodology applies to TWSC intersections and midblock crossings at which pedestrians cross up to 
four through lanes on the major street. It is applied through a series of steps requiring input data related 
to vehicle and pedestrian volumes, geometric conditions, and motorist yield rates to pedestrians. 

LIMITATIONS OF THE METHODOLOGY 

The pedestrian methodology’s limitations differ from the limitations of the motorized vehicle mode 
because the methods were developed in separate research efforts. The pedestrian methodology does not 
apply to undivided streets with more than four lanes, although it can accommodate up to four lanes in 
each direction separated by a median. It does not account for interaction effects of upstream signalized 
intersections, and it assumes random arrivals on the major street and equal directional and lane 
distribution on the major street. 

The methodology does not take into account pedestrian cross flows (i.e., pedestrian flows approximately 
perpendicular to and crossing another pedestrian stream), and it assumes the pedestrian will reach the 
crossing without delay from pedestrians traveling parallel to the major street. Under high pedestrian 
volumes, this assumption may not be reasonable. 

The method is for steady state conditions (i.e., the demand and capacity conditions are constant during 
the analysis period); it is not designed to evaluate how fast or how often the facility transitions from one 
demand or capacity state to another. 

Operational Data 
ADJUSTMENT 

In addition to the inputs mentioned for the motorized procedure, the following inputs are available for the 
pedestrian mode procedure: Crosswalk Length, Median Refuge, Start-Up and End Clearance Time, 
Crosswalk Markings, Crossing Treatment, Motorist Yield Rate, Rectangular Rapid-Flashing Beacon, 
Pedestrian Platooning, and Crosswalk Width. These inputs along with the lane configuration, traffic 
volume, pedestrian flow, lane width, and walking speed, are used in determining the average pedestrian 
delay and level of service. There is also a checkbox provided to indicate whether or not to show 
pedestrian delay and LOS. Checking this will add pedestrian mode related results to both the formatted 
and text reports. 
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Results 

Level of Service (LOS) criteria for TWSC intersections: 

 

TWSC Pedestrian Report 
The report can be displayed in either Page or Full View. If displayed in Page View, the results will 
automatically update when the user switches to the Report page. From the Report page, the user can 
then switch between the formatted report and the text report using the button found at the bottom of the 
page. The formatted report shows the most important results in a presentable format, while the text report 
shows a detailed step-by-step analysis in plain text. 

If displayed in Full View, the report can be displayed along with the input screen. The user has the choice 
of displaying the report to the right of the input screen or below the input screen. The report is dynamic 
and reacts to changes in the input screen. Like the Report page in Page View, the user can switch 
between the formatted report and the text report using the button found at the bottom of the report. 

On the input screen, checking ‘Show Pedestrian Delay and LOS’ will add pedestrian mode related results 
to both the formatted and text reports. 

All or a portion of the reports can be copied to the Windows clipboard for insertion into other files by right-
clicking into the Report pane and selecting Copy. The user can also change the display of the report 
through File Menu or with the use of shortcuts. See General Controls. 
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Alternative Intersections 

HCM Chapter 23 
The procedure in this chapter can be used to estimate the capacity and level of service (LOS) of 
interchange ramp terminals and alternative intersections. Alternative intersection LOS is dictated by the 
experienced travel time (ETT) of origin-destination movements. 

Restricted Crossing U-Turn (RCUT) Intersections 

RCUTs can be controlled by traffic signals, STOP control on the minor-street approach, or merges and 
diverges. The core computational methodology in Section 3 of the chapter can evaluate all three types of 
control, at RCUTs and MUTs with three or four approaches. RCUTs and MUTs with signals are typically 
built in urban or suburban areas with higher traffic demands, while those with STOP signs or merges are 
typically built in rural areas on high-speed roadways with lower minor-street traffic demands. RCUTs with 
signals or stop signs typically have 450 to 800 feet (or 137.2 to 243.8 meters in metric) from the main 
junction to a U-turn crossover. RCUTs with merges typically have more than 800 feet (or 243.8 meters in 
metric) from the main junction to a U-turn crossover, to make the weaving maneuvers easier. 

Modeling Capability in HCS 
HCS has the capability of modeling five types of alternative intersections supported by HCM: 

 Restricted Crossing U-Turn Intersections (RCUT) with Signals 

 Restricted Crossing U-Turn Intersections (RCUT) with Stop Signs 

 Restricted Crossing U-Turn Intersections (RCUT) with Merges 

 Median U-Turn Intersections (MUT) with Stop Signs 

 Partial Displaced Left-Turn Intersections (DLT) 

The computations procedure for each type of alternative intersection can be used to estimate the control 
delay, extra distance travel time (EDTT), and experienced travel time (ETT) per origin-destination (O-D) 
demand movement. The level of service (LOS) for alternative intersections is dictated by the ETT value. 
RCUT with Stop Signs and RCUT with Merges are applicable to the TWSC module. MUT with Stop Signs 
requires both the use of the Streets module and the TWSC module. 
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Creating New Alternative Intersection Datasets 

Steps to Build an RCUT with Stop Signs 
To conduct an RCUT with stop signs analysis, the Two-Way Stop Control module is used. One TWSC 
(.xtw) file is necessary to serve as the main intersection file, and one or two separate TWSC (.xtw) files to 
serve as the upstream/downstream junctions. The upstream/downstream junctions will be attached in the 
main intersection file. HCS supports three-legged and four-legged RCUT intersections with stop signs. 
Note: TWSC does not redistribute conventional volumes. These values must be determined prior to input.   

1. Create a new TWSC (.xtw) file and check the RCUT Alternative Intersection checkbox found in 
Intersection Data. This file will serve as the main intersection.  

 

2. The Intersection Type dropdown will now become editable. The default selection is RCUT with 
Stop Signs. Note: Activating the RCUT Alternative Intersection checkbox adds three new input 
sections to TWSC titled Conventional Intersection, RCUT Main Intersection, and U-Turn 
Crossovers, as displayed below. 

 

a. In Page View, these fields may be found in the newly enabled RCUT tab. 

 

b. In Full View, these fields may be found by scrolling midway down the page.  
3. Code the inputs for Quick Lanes, Vehicle Volume and Adjustments, Critical Headway and Follow-

Up Headway, and Pedestrian Volumes and Adjustments as would typically be done.  
a. Quick Lanes will disable the restricted side-street left-turn and through movements.



16  Alternative Intersections Two-Way Stop Controlled Intersections Users Guide 

 

b. The volume entered in the Vehicle Volumes and Adjustments section should be the 
redistributed conventional volume. As previously mentioned, this must be determined 
manually. TWSC does not currently automate volume redistribution.  

4. Code the RCUT specific inputs in the sections Conventional Intersection, RCUT Main 
Intersection, and U-Turn Crossovers. Note: The conventional intersection volume is only used for 
final ETT calculations.  

5. If the crossover junctions have already been coded, skip ahead to Step 6. If not, the upstream 
and downstream TWSC files will be coded in this step. These files will then be attached in the U-
Turn Crossovers section of the main intersection file.  

a. Open a new TWSC module. There is no need to check the RCUT Alternative Intersection 
checkbox for the U-Turn crossover files. However, the MUT/RCUT Crossover 
Intersection checkbox must be checked to indicate the intersection is an MUT/RCUT 
crossover. Code the crossover junction as would be done for a typical TWSC file.  

 
Note: It is however necessary that the crossover junction only has major street through 
movements and one major street U-Turn movement. The main intersection attachment 
will not accept the file otherwise. A sample configuration of an East-West major street 
crossover file is presented in the image below. 
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b. Repeat Step 5a to create a second crossover file if a four-legged RCUT intersection is 
being constructed. 

6. Return to the main intersection file and navigate to the U-Turn Crossovers section. To attach the 
crossover files, click the buttons in blue.   

 
7. To view the RCUT report, press the F7 key. Alternatively, use the menu icon and navigate to 

Report > RCUT Report. Note: The RCUT report is only accessible after at least one crossover file 
has been attached. 

Steps to Build an RCUT with Merges 
To conduct an RCUT with merges analysis, the Two-Way Stop Control module is used. One TWSC (.xtw) 
file is necessary to serve as the main intersection file. The minor street movements will be treated as 
merges and therefore the only movements experiencing control delay are the major street left-turns. Note: 
TWSC does not redistribute conventional input volumes. These values must be determined prior to input. 
The RCUT with Merges engine will however calculate upstream and downstream junction demands, 
which are displayed in the Demand section of the RCUT Report.   
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1. Create a new TWSC (.xtw) file and check the RCUT Alternative Intersection checkbox found in 
Intersection Data.  

 

2. The Intersection Type dropdown will now become editable. Select RCUT with Merges.  

 

Note: Activating the RCUT Alternative Intersection checkbox adds three new input sections to 
TWSC titled Conventional Intersection, RCUT Main Intersection, and U-Turn Crossovers, as 
displayed below.  

 

a. In Page View, these fields may be found in the newly enabled RCUT tab. 

 

b. In Full View, these fields may be found by scrolling midway down the page.  
3. Code the inputs for Quick Lanes, Vehicle Volume and Adjustments, Critical Headway and Follow-

Up Headway, and Pedestrian Volumes and Adjustments as would typically be done.  
a. Quick Lanes will disable the restricted side-street left-turn and through movements.
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b. The volume entered in the Vehicle Volumes and Adjustments section should be the 
redistributed conventional volume. As previously mentioned, this must be determined 
manually. TWSC does not currently automate volume redistribution.  

4. Code the RCUT specific inputs in the sections Conventional Intersection, RCUT Main 
Intersection, and U-Turn Crossovers. Note: The conventional intersection volume is used to 
check the zero merging delay assumption, and to calculate ETT values.  

a. If the demand combinations do not fall within the ‘insignificant delay’ constraints, an input 
error message will appear.    

5. To view the RCUT report, press the F7 key. Alternatively, use the menu icon and navigate to 
Report > RCUT Report.  

a. If changing the conventional input volumes is necessary, first navigate away from the 
RCUT report. Since the zero delay assumption is checked after each volume input, failing 
to do so may result in an input error message appearing before editing is finished with the 
volume fields. 
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How To 

Create a New File 
1. From the Start screen, there are three options for creating a new file:  

 
Note: A new file can be created if an existing file is already open; you do not need to start from 
the Start screen. 
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a. Selecting File > New from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “New” 

 

b. Selecting “New File…” from the Start screen; this can be found below in the red box 

 

c. Using the keyboard shortcut “Ctrl+N” 

2. Once a new file is created, you will be brought to the General page if in Page View or the input 
screen split with the report either on the right or the bottom of the screen if in Full View 
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a. Page View  

 

b. Full View  
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Open an Existing File 
1. From the Start screen, there are six options for opening an existing file:  

 
Note: A file can be opened even if another file is currently open; you do not need to start from the 
Start screen. 

a. Selecting File > Open from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Open”  
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b. Selecting “Open File…” from the Start screen; this can be found below in the red box 

 

c. Using the keyboard shortcut “Ctrl+O” 

d. Selecting a file under the Recent files list from the Start screen; this can be found below 
in the red box  

 

e. Selecting File > Example Folder from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Example Folder”. 
Opening the example folder will open the path of the HCS example files in File Explorer. 
The desired example file can be double-clicked or right-clicked and selecting ‘Open’, 
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which will open the example file in the TWSC program.  

 

f. Selecting “Example Folder…” from the Start screen; this can be found below in the red 
box. Opening the example folder will open the path of the HCS example files in File 
Explorer. The desired example file can be double-clicked or right-clicked and selecting 
‘Open’, which will open the example file in the TWSC program.  

 

2. Once an existing file is opened, you will be brought to the General page if in Page View or the 
input screen split with the report either on the right or the bottom of the screen if in Full View
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a. Page View  

 

b. Full View  
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Save a File 
1. There are five options for saving an open file: 

a. Selecting File > Save from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Save”  

 

b. Selecting File > Save As… from the main menu; this can be found by selecting the three 
lines in the top left-hand corner of the screen and then selecting “Save As…”  

 

c. Using the keyboard shortcut “Ctrl+S” for Save 

d. Using the keyboard shortcut “F12” for Save As 
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e. Exiting the program or closing the file without saving changes beforehand; this will 
prompt you to save changes to the file before anything is closed  

 

i. Selecting “Yes” will save the file if it is an existing file. If the file has not been 
previously saved, the Save As dialog box will pop up allowing you to change the 
file name and save it. 

ii. Selecting “No” will exit the program or close the file without saving the file 

iii. Selecting “Cancel” will prevent the file from closing 

Note: Using Save with an existing file will save a file without prompting you to specify a file name. Using 
Save with a new file will bring up the Save As dialog box for you to specify a file name for saving. Using 
Save As will always bring up the Save As dialog box for you to specify a file name for saving. 

Close a File 
1. There are three options for closing an open file: 

a. Selecting File > Close from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Close”  

 

b. Using the keyboard shortcut “Ctrl+W” 

c. Exiting the program itself; please see How To: Exit the Program 
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Exit the Program 
1. From the Start screen, there are three options for exiting the program:  

 
Note: The program can be exited even if a file is still open; you do not need to start from the Start 
screen. 

a. Selecting File > Exit from the main menu; this can be found by selecting the three lines in 
the top left-hand corner of the screen and then selecting “Exit”  

 

b. Using the keyboard shortcut “Alt+F4” 
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c. Selecting “X” in the top right-hand corner of the screen; this can be found below in the red 
box 

 

Edit the Default Settings 
1. From the Start screen, there are two options for editing the Default Settings:  

 
Note: The Default Settings can be changed even if an existing file is already open; you do not 
need to start from the Start screen. 
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a. Selecting File > Default Settings from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Default Settings” 

 

b. Using the keyboard shortcut “Alt+F” 

2. Opening the Default Settings will cause a Default Settings window to pop up:  

 

3. You can specify Analyst, Agency, and Jurisdiction by clicking in the corresponding text boxes and 
typing the desired text. 

4. Under ‘Units’, you are given the option of running the analysis in either U.S. Customary (USC) or 
SI (Metric) units. 

5. Clicking “OK” will save the changes made and close the Default Settings window; clicking 
“Cancel” will close the Default Settings window without saving any changes. 

6. When a new file is created, the Analyst, Agency, and Jurisdiction fields will automatically be 
populated with the text specified in the Default Settings. 

7. When starting a new file, the input and results will display according to the units specified in the 
Default Settings. 
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Change the View 
1. When a file is open, there are three main options for the view of the program: 

a. Page View: the inputs and results reports are separated into pages as seen below. You 
can navigate between pages using the “Back” and “Next” buttons or by clicking the page 
names found at the top of the screen. 

 

b. Full View with the report on the right of the screen: the screen is split with all inputs on 
the left side and the results reports on the right side. You can access all inputs and view 
all of the current report by using the corresponding scroll bars. There is also a screen 
splitter that can be moved to adjust the views of the input screen and results report. 

 

c. Full View with the report on the bottom of the screen: the screen is split with all inputs on 
the top of the screen and the results reports on the bottom of the screen. You can access 
all inputs and view all of the current report by using the corresponding scroll bars. There 
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is also a screen splitter that can be moved to adjust the view of the input screen and 
results report.  

 

2. Views can be changed by using the main menu items or the keyboard shortcuts. 

a. Main Menu Items 

i. To switch to Page View, select File > View > Page View from the main menu; this 
can be found by selecting the three lines in the top left-hand corner of the screen, 
hovering over “View”, and then selecting “Page View”.  

 

ii. To switch to Full View with the report on the right of the screen, select File > View 
> Full View > Report -> Right from the main menu; this can be found by selecting 
the three lines in the top left-hand corner of the screen, hovering over “View”, 
hovering over “Full View”, and then selecting “Report -> Right”.  
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iii. To switch to Full View with the report on the bottom of the screen, select File > 
View > Full View > Report -> Bottom from the main menu; this can be found by 
selecting the three lines in the top left-hand corner of the screen, hovering over 
“View”, hovering over “Full View”, and then selecting “Report -> Bottom”.  

 

b. Keyboard Shortcuts 

i. Page View: keyboard shortcut is “F9” 

ii. Full View with report on the right of the screen: keyboard shortcut is “F10” 

iii. Full View with report on the bottom of the screen: keyboard shortcut is “F11” 

Change the Lane Configuration 
1. When a new file is created or an existing file is opened, the lane configuration can be changed 

under the Lanes section. This can be found on the Lanes page if using Page View or the input 
portion of the split screen if using Full View. 
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a. Page View  

 

b. Full View  

 

2. To add lanes, click on the lane buttons (black arrows) on the edges of the lanes graphic. If the 
background of a lane button is white, the lane is available to add to the corresponding approach. 
If the background of a lane button is gray, it is disabled and cannot be added to the 
corresponding approach based on the current lane configuration. 

a. The ‘Major Street Direction’ must be specified to determine which lanes can be added for 
each of the approaches. This can be found under the ‘Intersection Data’ section on the 
General page if using Page View or the input portion of the split screen if using Full View. 
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i. The default is ‘East-West’. 

ii. Choices include: East-West, North-South 

1. East-West indicates the major street approaches are eastbound (EB) 
and westbound (WB); the minor street approaches are northbound (NB) 
and southbound (SB) 

2. North-South indicates the major street approaches are northbound (NB) 
and southbound (SB); the minor street approaches are westbound (WB) 
and eastbound (EB) 

b. Major Street Approaches 

i. Major Street approaches do not allow shared left-right (LR) lanes; this lane is 
always disabled  
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ii. Each approach allows up to three thru (either exclusive or shared) lanes to be 
added 

 

iii. Adding a U-turn (U) lane will disable the U-turn (U), exclusive left-turn (L), shared 
left-thru (LT), and shared left-thru-right (LTR) lanes; the shared left-right (LR) 
lane should already be disabled  

 

iv. Adding a shared left-thru-right (LTR) lane will disable all lanes  
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v. Adding an exclusive thru (T) lane will disable the shared left-thru-right (LTR) lane; 
the shared left-right (LR) lane should already be disabled  

 

vi. Adding an exclusive left-turn (L) lane will disable the U-turn (U), exclusive left-
turn (L), shared left-thru (LT), and shared left-thru-right (LTR) lanes; the shared 
left-right (LR) lane should already be disabled  

 

vii. Adding a shared left-thru (LT) lane will disable the U-turn (U), exclusive left-turn 
(L), shared left-thru (LT), and shared left-thru-right (LTR) lanes; the shared left-
right (LR) lane should already be disabled  
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viii. Adding a shared thru-right (TR) lane will disable the shared left-thru-right (LTR), 
shared thru-right (TR), and exclusive right-turn (R) lanes; the shared left-right 
(LR) lane should already be disabled  

 

ix. Adding an exclusive right-turn (R) lane will disable the shared left-thru-right 
(LTR), shared thru-right (TR), and exclusive right-turn (R) lanes; the shared left-
right (LR) lane should already be disabled  

 

c. Minor Street Approaches 

i. Minor Street approaches do not allow U-turn (U) lanes; there is no U-turn button 
available 
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ii. Each approach allows up to three lanes (with no more than one exclusive lane 
for each movement on the minor-street approach)  

 

iii. Adding a shared left-right (LR) lane will disable all lanes  

 

iv. Adding a shared left-thru-right (LTR) lane will disable all lanes  
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v. Adding an exclusive thru (T) lane will disable the shared left-thru-right (LTR), 
shared left-right (LR), and exclusive thru (T) lanes  

 

vi. Adding an exclusive left-turn (L) lane will disable the exclusive left-turn (L), 
shared left-thru (LT), shared left-thru-right (LTR), and shared left-right (LR) lanes 

 

vii. Adding a shared left-thru (LT) lane will disable the exclusive left-turn (L), shared 
left-thru (LT), shared left-thru-right (LTR), and shared left-right (LR) lanes 
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viii. Adding a shared thru-right (TR) lane will disable the shared left-thru-right (LTR), 
shared left-right (LR), shared thru-right (TR), and exclusive right-turn (R) lanes 

 

ix. Adding an exclusive right-turn (R) lane will disable the shared left-thru-right 
(LTR), shared left-right (LR), shared thru-right (TR), and exclusive right-turn (R) 
lanes 

 

3. To remove lanes, click on the lanes within the center of the lanes graphic (white arrows). Clicking 
on an arrow will immediately remove the lane and change which lane buttons are 
enabled/disabled for the corresponding approach. 

4. Changes to the lane configuration on the lanes graphic in the input screen will be reflected on the 
lanes graphic in the formatted report and the lane information in both the formatted and text 
reports. 
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Enable and Edit the Headway Fields 
1. Enabling and editing of the different headway fields are dependent on the lane configuration and 

‘Major Street Median Type’.  

 

2. To enable headways for specific movements of an approach, the movement must exist by adding 
an appropriate lane to the lane configuration.  

a. Thru and Right-turn fields for the major street approaches are always disabled  
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b. Left-turn fields for a major street approach are enabled if either a shared or exclusive left-
turn lane is coded  
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c. U-turn fields for a major street approach will enable if one of the following is true: 

 

i. The corresponding U-turn lane is coded and at least two opposing thru lanes are 
coded 

ii. An exclusive left-turn lane is coded in the subject approach, at least two thru 
lanes are coded in the opposing approach, and the volume for the corresponding 
U-turn is greater than 0 
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d. U-turn fields for the minor street approaches are always disabled  
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e. Left-turn fields for a minor street approach are enabled if either a shared or exclusive left-
turn lane is coded  

 

f. Right-turn fields for a minor street approach are enabled if either a shared or exclusive 
right-turn lane is coded  
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g. Thru fields for a minor street approach are enabled if either a shared or exclusive thru 
lane is coded  

 

3. To enable Stage One and Stage Two headways, the Major Street Median Type must be 
specified. Choices include: Undivided, Left + Thru, and Left Only. The default selection is 
‘Undivided’. Note: Stage One and Stage Two headways will only apply to left and thru fields from 
the minor street approaches.  
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a. If the left and thru movements exist and the ‘Major Street Median Type’ selected is 
‘Undivided’, then none of the Stage One or Stage Two headways will be enabled. 

 

b. If the left and thru movements exist and the ‘Major Street Median Type’ selected is ‘Left + 
Thru’, then both the Left and Thru fields for Stage One and Stage Two of the minor street 
approaches will be enabled.  
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c. If the left and thru movements exist and the ‘Major Street Median Type’ selected is ‘Left 
Only’, then only the Left fields for Stage One and Stage Two of the minor street 
approaches will be enabled.  

 

d. If a left movement does not exist, then the corresponding Stage One and Stage Two 
fields will be disabled regardless of the Major Street Median Type selected. 

e. If a thru movement does not exist, then the corresponding Stage One and Stage Two 
fields will be disabled regardless of the Major Street Median Type selected. 

View Results of the Analysis 
1. After editing all the necessary inputs, results of the analysis can be found in the form of reports. 

Reports can be found on the Report page if using Page View or on the results portion of the split 
screen if using Full View. 
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a. Page View with Report page displayed  

 

b. Full View with the report on the right of the screen  
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c. Full View with the report on the bottom of the screen  

 

2. There are two options for reports: Formatted and Text 

a. Formatted reports show the most important results in a presentable format  
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b. Text reports show a more detailed analysis in plain text  

 

3. The type of report displayed can be changed by using the main menu items, keyboard shortcuts, 
or toggle buttons found under the report 

a. Main Menu Items 

i. To switch to the Formatted Report, select File > Report > Formatted Report from 
the main menu; this can be found by selecting the three lines in the top left-hand 
corner of the screen, hovering over “Report”, and then selecting “Formatted 
Report”. 
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ii. To switch to the Text Report, select File > Report > Text Report from the main 
menu; this can be found by selecting the three lines in the top left-hand corner of 
the screen, hovering over “Report”, and then selecting “Text Report”.  

 

b. Keyboard Shortcuts 

i. Formatted Report: keyboard shortcut is “F4” 

ii. Text Report: keyboard shortcut is “F6” 

c. Report Toggle Buttons 

i. Whether viewing the report in Page View or Full View, a toggle button will be 
available at the bottom of the screen underneath the report. 
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ii. If the formatted report is currently being displayed, the toggle button will say 
“Switch to Text Report” which will allow you to display the text report if clicked. 

 

iii. If the text report is currently being displayed, the toggle button will say “Switch to 
Formatted Report” which will allow you to display the formatted report if clicked. 
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4. The magnification of the report currently being displayed can be changed using the zoom slider 
found at the bottom right-hand corner of the screen.  

 

a. To zoom in, drag the slider to the right; to zoom out, drag the slider to the left 

b. Clicking the plus (+) button will zoom in; clicking the minus (-) button will zoom out 

c. Holding down “ctrl” on the keyboard and scrolling up on the mouse wheel will zoom in; 
holding down “ctrl” on the keyboard and scrolling down on the mouse wheel will zoom out 

Print a Report 
1. There are four options for printing a report: 

a. Selecting File > Print from the main menu; this can be found by selecting the three lines 
in the top left-hand corner of the screen and then selecting “Print”  
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b. Selecting File > Print Preview from the main menu; this can be found by selecting the 
three lines in the top left-hand corner of the screen and then selecting “Print Preview” 

 

c. Using keyboard shortcut “Ctrl+P” for Print 

d. Using keyboard shortcut “Ctrl+F2” for Print Preview 

2. Print 

a. Using Print will bring up a Print dialog box where you can select which printer to print to 
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3. Print Preview 

a. Using Print Preview will bring up a window where you can view how the report will look 
on paper before sending it to the printer  

 

b. The print icon in the toolbar found in the top left-hand corner can then be selected 

 

c. A Print dialog box will pop up where you can select which printer to print to  
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Glossary of Terms 

Agency 
This field is provided to document the agency or company associated with this analysis or project. 

Analysis Time Period 
The length of time (T) the peak flow remains constant (usually 0.25 hr) and is used in the delay equations. 
If v/c exceeds 0.90, control delay may be significantly affected by the value of T. 

Analysis Year 
This field is provided to document the year for which the analysis is being performed. 

Analyst 
The field is provided to document the individual performing the analysis. 

Base Critical Headway 
This value is obtained for each movement for two-lane, four-lane or six-lane major streets and is used to 
calculate the critical headway. See exhibit below. 
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Base Follow-Up Headway 
This value is obtained for each movement for two-lane, four-lane or six-lane major roads and is used to 
calculate the follow-up headway. 

 

Capacity 
Capacity is the maximum hourly rate at which persons or vehicles can be reasonably expected to 
traverse a point or uniform segment of a lane or roadway during a given time period under prevailing 
roadway, traffic, and roadway conditions. 

Control Delay 
Control Delay is the portion of total delay attributed to traffic control measures, either traffic signals or stop 
signs. 

Critical Headway 
Vehicles 

The minimum time interval in the major-street that allows intersection entry to one minor-street vehicle. 
Factors that influence the calculation of critical headway include the number of lanes in each direction on 
the major street, the proportion of heavy vehicles, percent grade, intersection geometry, and base critical 
headway values. See Base Critical Headway for the HCM default values. Please note that values for U-
turns from a four-lane major road depend on whether the median nose is narrow (less than 21 ft, or 6.4 m 
in metric) or wide (21 ft, or 6.4 m in metric, or wider). 

The following equation is used to calculate critical headway: 

tc,x = tc,base + tc,HVPHV + tc,GG – t3,LT 

where 

tc,x = critical headway for movement x (s); 

tc,base = base critical headway (s); 

tc,HV  = adjustment factor for heavy vehicles (1.0 for major streets with one lane in each direction;  
2.0 for major streets with two or three lanes in each direction) (s); 

PHV = proportion of heavy vehicles for movement x (expressed as a decimal; e.g., PHV = 0.02 for 
2% heavy vehicles); 

tc,G = adjustment factor for grade for given movement (0.1 for Movements 9 and 12; 0.2 for 
Movements 7, 8, 10, and 11) (s); 
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G = percent grade (expressed as an integer; e.g., G = -2 for a 2% downhill grade); and 

t3,LT = adjustment factor for intersection geometry (0.7 for minor-street left-turn movement at 
three-leg intersections; 0.0 otherwise) (s). 

 

Pedestrians 

The minimum headway in the traffic stream that will allow a pedestrian, or group of pedestrians, to cross 
without the need for vehicles to yield. 

Crossing Treatment 
The exhibit below provides information on average motorist responses to typical pedestrian crossing 
treatments summarized from a number of research efforts.  

 

Crosswalk Length 
The length in feet (or meters in metric) of a pedestrian crosswalk. A pedestrian crosswalk is a connection 
between pedestrian facilities across sections of roadway used by automobiles, bicycles, and transit 
vehicles. Crosswalk lengths can be broken up into two stages if there is a median refuge. Crosswalks can 
be marked or unmarked. 

Crosswalk Markings 
A checkbox is provided to indicate if the pedestrian crosswalk has any markings or not. Please also see 
Marked Crosswalk and Unmarked Crosswalk. 
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Crosswalk Width 
The width in feet (or meters in metric) of a pedestrian crosswalk. A pedestrian crosswalk is a connection 
between pedestrian facilities across sections of roadway used by automobiles, bicycles, and transit 
vehicles. Crosswalks can be marked or unmarked. 

Date 
The date will default to the computer's date, but may be edited. The format of the date is determined by 
the user's 'Short date style' preferences (regional setting icon on the Control Panel). 

Delay 
The difference between the travel time actually experienced and the reference travel time that would 
result during conditions with ideal geometric characteristics and in the absence of incidents, control, and 
traffic. 

Distance from Main Intersection to Crossover 
The distance in feet (or meters in metric) from the main intersection to the U-Turn crossover. It is used in 
determining the Extra Distance Travel Time (EDTT). 

East/West Street Name 
The name of the east/west intersecting street is coded to document the intersection being analyzed. 

Flared Minor-Street Approach 
A shared right-turn lane that allows right-turning vehicles to complete their movement while other vehicles 
are occupying the lane.  

This box is checked when two vehicles may occupy or depart from the stop line simultaneously as a result 
of a large curb radius, a tapered curb, or a parking prohibition. This geometry may result in a greater 
capacity than if turning and through movement share only one lane. The magnitude of this effect depends 
in part on the turning-movement flow rates and the resultant probability of there being two vehicles 
simultaneously at the stop line, and in part on the storage length available to feed the second position at 
the stop line. 

Flared Minor-Street Storage 
The number of spaces for right-turning passenger cars that can queue at the stop line without obstructing 
the access to the stop line for other movements. 

Follow-Up Headway 
The time between the departure of one vehicle from the minor street and the departure of the next vehicle 
using the same major-street headway under a condition of continuous queuing on the minor street. 
Factors that influence the calculation of follow-up headway include the number of lanes in each direction 
on the major street, the proportion of heavy vehicles, and base follow-up headway values. See Base 
Follow-Up Headway for the HCM default values. Please note that values for U-turns from a four-lane 
major road depend on whether the median nose is narrow (less than 21 ft, or 6.4 m in metric) or wide (21 
ft, or 6.4 m in metric, or wider). 
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The following equation is used to calculate follow-up headway: 

tf,x = tf,base + tf,HVPHV 

where 

tf,x = follow-up headway for movement x (s); 

tf,base = base follow-up headway (s); 

tf,HV  = adjustment factor for heavy vehicles (0.9 for major streets with one lane in each direction; 
1.0 for major streets with two or three lanes in each direction) (s), and 

PHV = proportion of heavy vehicles for movement x (expressed as a decimal; e.g., PHV = 0.02 for 
2% heavy vehicles). 

Intersection 
The name of the intersection, usually defined by the two intersecting streets, is coded to document the 
intersection being analyzed and will be printed on the report. 

Intersection Type 
When the RCUT Alternative Intersection checkbox is checked, the Intersection Type drop down menu will 
enable. The two RCUT intersection types include: RCUT with Stop Signs and RCUT with Merges. 

Jurisdiction 
This field is provided to document any jurisdiction convention or project related information. 

Lane Width 
The average width for all lanes in the approach is coded. This is measured in feet (or meters in metric). 

Lanes 
Lanes is a graphic data entry screen for coding lane configuration data. Lane combinations can be 
selected by clicking on the appropriate arrows to place them on the central diagram for each approach. 
Clicking on an arrow on the central diagram will remove it. As arrows are selected, others may become 
disabled. 

Note:  As stipulated in the HCM methodology, each major-street approach can have up to three through 
lanes and one exclusive right- and/or left-turn lane (five lanes maximum). Each minor-street approach can 
have up to three lanes, a maximum of one exclusive lane for each movement. 

Left-Turn Storage 
If a major-street left-turn lane exists, the storage length must be provided (in vehicles) to determine 
whether or not the computed queue will exceed the storage, and generate delay to the Rank 1 
movements. 

Level of Service (LOS) 
A level of service is a letter designation that describes a range of operating conditions on a particular type 
of facility. Six levels of service are defined, using the letters A through F. Level of service A represents the 
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best level of service, and generally describes operation of free flow and very low delay. Level of service F 
represents the worst operating conditions.  

LOS criteria for the motorized vehicle mode for TWSC intersections are given in the exhibit below. 

 

LOS criteria for the pedestrian mode for TWSC intersections are given in the exhibit below. 

 

Major Street Direction / Intersection Orientation 
Defines the street with the two approaches that are uncontrolled. The minor street is the other street that 
is controlled by STOP signs. Select the Major Street Direction between East-West and North-South from 
the drop-down menu. 

Major Street Free-Flow Speed 
Free-Flow Speed (FFS) on the major street. FFS is: 

1. The theoretical speed when the density and flow rate on a study segment are both zero. 

2. The prevailing speed on freeways at flow rates between 0 and 1,000 passenger cars per hour per 
lane (pc/h/ln). 

Major Street Median Storage 
The number of vehicles able to be stored in the median to be used in the two-stage gap acceptance 
calculations. 

Major Street Median Type 
The Median Type is coded for the major street, either Undivided, Thru & Left, or Left Only.  
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A raised, striped or two-way left-turn lane (TWLTL), often causes a special gap acceptance phenomenon 
known as two-stage gap acceptance where a significant proportion of the minor-street drivers cross part 
of the major-street then pause in the median to wait for a gap on the other approach.  

Undivided is selected when there is no median storage, disabling that field. Thru & Left is selected if the 
geometry permits both thrus and lefts from the minor street to store in the median for two-stage 
movements. Left Only is selected if only left turns (not thrus) can be stored, in a TWLTL for example.  

If a median type other than Undivided is selected, the Median Storage field will enable coding of the 
number of vehicles able to be stored. 

Marked Crosswalk 
Any portion of a roadway at an intersection or elsewhere distinctly indicated as a pedestrian crossing by 
pavement marking lines on the surface, which might by supplemented by contrasting pavement texture, 
style, or color. 

Median Refuge 
When a raised median refuge island is available, pedestrians typically cross in two stages. Determination 
of whether a median refuge exists may require engineering judgment. The main issue to determine is 
whether pedestrians cross the traffic streams in one or two stages. When pedestrians cross in two stages, 
pedestrian delay should be estimated separately for each stage of the crossing. 

Motorist Yield Rate 
Rate at which motor vehicles yield and allow a pedestrian to cross the street. Motorist yield rates are 
influenced by a range of factors, including roadway geometry, travel speeds, pedestrian crossing 
treatments, local culture, and law enforcement practices. 

MUT/RCUT Crossover Intersection 
A checkbox is provided for the user to indicate whether the dataset is an MUT/RCUT Crossover 
Intersection. If converting an existing file, a confirmation popup will appear to verify conversion of file to a 
crossover intersection and invalid side-street movements will be removed from the lanes graphic. 

North/South Street Name 
The name of the north/south intersecting street is coded to document the intersection being analyzed. 

Peak Hour Factor 
The hourly volume during the analysis hour divided by the peak 15-min flow rate within the analysis hour; 
a measure of traffic demand fluctuation within the analysis hour. The peak-hour factor (PHF) is entered 
for the intersection to compute peak flow rates. 

Pedestrian Critical Headway 
The minimum time interval in seconds below which a pedestrian will not attempt to begin crossing the 
street. For a single pedestrian, critical headway is computed with the following equation: 

tc = L / Sp + ts 
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where 

tc = critical headway for a single pedestrian (s), 

Sp = average pedestrian walking speed (ft/s) (or m/s in metric), 

L = crosswalk length (ft) (or m in metric), and 

ts = pedestrian start-up time and end clearance time (s). 

Pedestrian Flow 
The pedestrian volume is the sum of pedestrians crossing each subject approach (i.e., "Eastbound" 
pedestrians are those crossing the Eastbound vehicular approach) individually, and groups of pedestrians 
crossing together, during the time period of study in pedestrians per hour. 

Pedestrian Platooning 
This is checked when a there is a group of pedestrians traveling together as a group, either voluntarily or 
involuntarily because of geometrics or other factors. 

Pedestrian Start-Up Time and End Clearance Time 
The time for a platoon of pedestrians to get under way following the beginning of the walk interval and the 
time at the end of the walk interval not used by any pedestrians. The default value is 3 seconds. 

Percent Grade 
The percent grade is entered for each approach to compute the adjustment factor used in the 
computation of critical headway and follow-up headway. 

Percent Heavy Vehicles 
The percentage of heavy vehicles is entered for each movement. This value is used in the calculation of 
critical headway and follow-up headway. 

Percent Thrus Using Shared Lane 
When there is more than one thru lane coded (shared or exclusive), the fields are activated to provide for 
the turn proportions. 

Project Description 
This field is provided for the user to document the analysis with any information for identification 
purposes. 

Proportion Time Blocked 
To evaluate the impact of coordinated upstream signals, the urban streets segments methodology is used 
to estimate the proportion of time that each Rank 2 or lower movement will be effectively blocked by a 
platoon. The proportion of time blocked is denoted by pb,x where x is the movement using the movement 
conventions provided in the following exhibit: 
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Coding the values directly into the corresponding fields within TWSC will modify the appropriate 
conflicting flows to account for the effects of the upstream signals. Because of the effects on the 
movements, the minor-street left and thru values will always be the same, and the minor-street left and 
major-street left values will always be the same for each direction. 

Queue Length 
Queue Length is the number of vehicles in queue. 

RCUT Alternative Intersection 
RCUT stands for Restricted Crossing U-Turn and is a type of alternative intersection. RCUTs are at-grade 
intersections at which minor-street left-turn and through movements are rerouted. Major-street left turns 
are not rerouted.  

When there are invalid lanes coded and RCUT Alternative Intersection is checked, a dialog box will pop 
up asking for confirmation to convert the current file to an RCUT Alternative Intersection. If Yes, Lanes will 
remove the invalid side street movements.  

Checking RCUT Alternative Intersection will also create three sections with additional inputs for the 
conventional intersection, RCUT main intersection, and the U-Turn crossovers. 

RCUT Main Intersection Storage Length 
The storage length is specified for left turn lanes on the major street of the main intersection and for right 
turn lanes on the minor street of the main intersection. Storage length is the length of turn lane available 
for storing queued vehicles. 

Right Turn Channelized 
This box is checked when the right-turning traffic from the major road is separated by a triangular island 
and has to comply with a stop or yield sign. This is a special case of an exclusive right-turn lane, which is 
coded in Lanes. 

Saturation Flow Rate 
The equivalent hourly rate at which previously queued vehicles can traverse an intersection approach 
under prevailing conditions, assuming that green signal is available at all times and no lost times are 
experienced. 
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Where there is no separate left-turn lane, the saturation flow rate for major street right-turning and thru 
traffic is used to compute the probability that there will be no queue in the respective major-street shared 
lanes. 

Short Left-Turn Pocket 
This box is checked if present. If no exclusive left-turn lane is provided on the major street, it is possible 
for major-street thru (and possibly right-turning) traffic to be delayed by left-turning vehicles waiting for an 
acceptable gap. 

Show Pedestrian Delay and LOS 
When this checkbox is checked, results relevant to the HCM Pedestrian LOS procedure will be shown on 
both the formatted and text reports. 

The HCM procedure for pedestrian mode analysis does not apply to undivided streets with more than four 
lanes, but it can accommodate up to four lanes in each direction separated by a median. 

Time Analyzed 
This field exists for documenting the time frame of the analysis as morning peak, afternoon peak, existing 
conditions, future projections, etc. 

Upstream Signal 
This box is checked for the existence of a nearby upstream signalized intersection usually causing 
vehicles to arrive at the subject intersection in platoons, which may cause an increase in the minor-street 
capacity compared with the case of random arrivals. The greater the number of vehicles traveling in 
platoons, the higher the minor-street capacity for a given opposing flow because there is a greater 
proportion of large gap sizes that can be used by more than one minor-street vehicle.  

To evaluate the impact of coordinated upstream signals, the urban street segments methodology is used 
to estimate the proportion of time that each Rank 2 or lower movement will be effectively blocked by a 
platoon. With these values, the proportion of the analysis period that is blocked for each minor movement 
can be computed. 

U-Turn Crossover 
The intersection in an alternative intersection that a driver uses to make a U-Turn to complete a 
movement through the main intersection of an alternative intersection. For RCUTs, cross street left turn 
and through traffic from the main intersection makes a U-turn at the crossover. For example, if the major 
street is East-West and a driver needs to turn left from the south leg of the main intersection, they must 
first turn right and then make a U-turn at the east crossover and continue driving westbound to complete 
their movement. 

U-Turn Crossover Storage Length 
The length of U-Turn crossover lane available for storing queued vehicles. 

Unmarked Crosswalk 
Absent any pavement markings, the part of the roadway within an intersection formed by the extension of 
the lateral lines of a sidewalk across the roadway. 
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v/c Ratio 
The v/c ratio is the volume capacity ratio, which is the volume of one movement (or shared-lane 
movements) divided by the movement capacity of the movement (or shared-lane movements). 

Volume 
The total number of vehicles or other roadway users that pass over a given point or section of a lane or 
roadway during a given time interval. The volumes (V) for each movement are coded in vehicles per hour 
(veh/h). An hourly volume is required for any movement to be included in the analysis. Note that U-turns 
off the major street are now analyzed. 

Walking Speed 
The average pedestrian walking speed, measured in ft/s (or m/s in metric), is entered to calculate the 
pedestrian blockage factor.  
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