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Introduction 

License Agreement 
TRAFFIC SOFTWARE INTEGRATED SYSTEM™ and TRANSYT-7F™ 
 
TSIS-CORSIM2022™ END USER LICENSE AGREEMENT 
 
Copyright © 2021 University of Florida. All rights reserved. 
 
This is an agreement between you and the University of Florida Board of Trustees for the benefit of the McTrans 
Center. 
 
BY USING THE PROGRAMS WITHIN THE ELECTRONIC TRANSMITTED PACKAGE OR DIRECT DOWNLOAD 
(“SOFTWARE”), YOU AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT. DO NOT USE 
THE SOFTWARE WITHOUT FIRST READING AND UNDERSTANDING THE TERMS OF THIS LICENSE 
AGREEMENT. 
 
If you do not agree with the terms of this license, discontinue use, delete and/or return the unused Software 
immediately to the distributor from which it was obtained. 
 
1. LICENSE: In consideration of the required license fee, the University of Florida McTrans Center (hereinafter 
called “McTrans”) hereby grants you (hereinafter called “End User”) a nonexclusive license to use the enclosed 
TRAFFIC SOFTWARE INTEGRATED SYSTEM and TRANSYT-7F in TSIS-CORSIM2022 (hereinafter called 
“Software”) as described in the applicable portion of section 3 for a period in which the End User pays the 
subscription fee established by McTrans. 
 
2. OWNERSHIP: This license is not a sale of the Software; it is a license to use the Software under the terms of 
this License Agreement.  
 
3. USE: The Software is licensed to End Users for a particular use, depending on the particular license that is 
designated on order and described in this Section 3. 
 
a. Single Office License. The End User may use the Software on any number of computers within End User’s 
immediate office, which is defined as a single organizational unit, having a unique function, comprising one or more 
contiguous rooms in a single location. All persons using the Software are also End Users. End Users may also use 
the Software on portable computers while on official travel and on home computers, as long as ALL such use is on 
behalf of the office for which this Software License was purchased. This Software License does not authorize the 
use of the Software at any offices that are related to that single organizational unit but are not located at the same 
geographic location, even if the Software is stored on a portable computer. If you have any questions as to the 
validity of your End User License, contact McTrans. 
 
b. Academic License. The End User may use the Software only within a laboratory within End User’s immediate 
school, which is defined as a single school unit, having a unique function, comprising one or more contiguous rooms 
in a single location, up to the permitted (purchased) number of copies, provided the use is supervised in a classroom 
setting for teaching or research purposes, and appropriate protection is in place against students copying the 
Software and taking it out of the lab. The responsibility for ensuring this protection of the Software rests with the 
End User. Multiple laboratories require multiple licenses. The Software may not be installed or used on any 
computer outside of the licensed laboratory under the Academic License, including (but not limited to) any office, 
home, networked or portable computer. If you have any questions as to the type or validity of your End User License, 
contact McTrans. 
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WARNING! If this license is a Single Office License for use in traffic and transportation applications, the Software 
may not be used for classroom or workshop instruction, demonstrations, conferences or other similar purposes 
without the express, written consent of McTrans. (Contact McTrans for an Academic License.) If this license is an 
Academic License for use in training or educational applications, the Software may not be used for traffic and 
transportation applications or other similar purposes without the express, written consent of McTrans. (Contact 
McTrans for an Applications License.) 
 
4. NETWORK INCOMPATIBILITIES: McTrans is not able to provide technical support for issues resulting from 
network incompatibilities. 
 
5. GENERAL: The Software is not designed for network use, and such use is not supported. No network use is 
permitted, including but not limited to, using the Software either directly or through commands, data or instructions 
from or to a computer not already licensed and part of the internal network, for Internet or web hosting services or 
by any user not licensed to use this copy of the Software through a valid license from McTrans. 
 
6. COPY RESTRICTIONS: Unauthorized copying, distribution, or dissemination of the Software is expressly 
prohibited. End User may be held legally responsible for any copyright infringement that is caused, encouraged, or 
enabled by failure to abide by the terms of this license. Subject to these restrictions, End User may make copies of 
the Software for backup purposes and for use of the Software on any computers located within its office complex, 
as described in paragraph 3. Under no circumstances may the Software or associated printed documentation be 
copied for sale, distribution, or dissemination, except as provided in paragraph 3, without the express, written 
consent of McTrans. End User may reproduce the associated documentation as necessary to use within the 
geographic location for which the license is granted. End User may not modify, adapt, translate, reverse engineer, 
decompile, disassemble, or create derivative work from the Software or any associated written materials without 
the prior written consent of McTrans. ANY SUCH ACTIVITY OR PRODUCT BECOMES THE PROPERTY OF 
McTRANS. 
 
7. TRANSFER RESTRICTIONS: The Software is licensed only to the End User, and this License Agreement may 
not be assigned or transferred to anyone without the prior written consent of McTrans. Any authorized transferee 
of this License Agreement shall be bound by the terms of this License Agreement. End User may not transfer, 
assign, rent, lease, sell, or otherwise dispose of the Software except as expressly provided in this License 
Agreement.  
 
8. REGISTRATION AND SUPPORT: This license is automatically registered to the person or entity that purchased 
it. If the End User wishes to change the registration, he or she must fill out and return the registration card contained 
in this package. McTrans may, from time to time, revise or update the Software to correct bugs or add minor 
improvements. McTrans will supply, at its discretion, minor updates to the End User without additional charge and 
will provide reasonable telephone or email support to the End User during the normal business hours of McTrans 
for the period for which End User pays the subscription fee established by McTrans. McTrans reserves the right to 
determine the extent of the support. McTrans reserves the right to make substantial revisions and enhancements 
to the Software and to market such substantially revised versions as separate products. End User shall not be 
entitled to receive such separate products without additional charge. Upon release of any such revised version of 
the Software, the obligation to provide the above described technical support services to End User shall cease, 
unless End User chooses to pay to license the enhanced version of the Software, whether or not the End User has 
previously requested or received support on the prior version. 
 
9. LIMITED WARRANTY AND LIMITATIONS OF REMEDIES: McTrans warrants the magnetic or optical medium 
on which the Software is furnished to be free from defects in material and workmanship under normal use for a 
period of thirty (30) days from the date of delivery to the End User as evidenced by a copy of invoice. The entire 
liability and End User’s exclusive remedy shall be the replacement of any diskette found to be defective. Defective 
diskettes should be returned with a copy of the End User’s invoice to the distributor from which the Software was 
obtained. End User agrees that it is the responsibility of End User to understand fully the limitations of and 
assumptions underlying the Software and not to make use of the Software without the assistance of personnel with 
appropriate expertise. End User accepts all responsibility for review, application, and use of the program output and 
accepts all responsibility for assurance that the output meets provisions of any applicable design code, standard, 
or any project specification. 
 
EXCEPT AS PROVIDED ABOVE, THE PRODUCT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF 
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MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. McTRANS DOES NOT WARRANT THAT 
THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET END USER’S REQUIREMENTS OR THAT THE 
OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE. THE ENTIRE RISK AS TO 
THE QUALITY AND PERFORMANCE OF THE PRODUCT IS WITH THE END USER. IN NO EVENT WILL 
McTRANS BE LIABLE TO END USER FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, 
OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR INABILITY TO 
USE THE SOFTWARE EVEN IF McTRANS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, 
OR FOR ANY CLAIM BY ANY OTHER PARTY. THE ABOVE WARRANTY GIVES END USER SPECIFIC LEGAL 
RIGHTS AND END USER MAY ALSO HAVE OTHER RIGHTS IN THE UNITED STATES WHICH VARY FROM 
STATE TO STATE. USE OF THE SOFTWARE WHERE THE END USER BELIEVES OR HAS REASON TO 
BELIEVE THAT DAMAGE MAY OCCUR IS A VIOLATION OF ANY AND ALL WARRANTIES. McTRANS HAS NO 
KNOWLEDGE OF THE HARDWARE OR SOFTWARE CONFIGURATIONS OF THE END USER AND ASSUMES 
NO LIABILITY FOR THEIR DAMAGE. 
 
10. TERMINATION: This license is effective from the date End User receives the Software until this License 
Agreement is terminated. End User may terminate it by returning or destroying all copies of the Software and 
associated documentation in End User’s possession or control. If any terms of this license are breached by End 
User, the license shall terminate immediately. 
 
11. GOVERNING LAW: This License Agreement shall be governed by the laws of the State of Florida, U.S.A. Venue 
for all disputes related to this License Agreement shall be in the United States District Court of the Northern District 
of Florida, Gainesville Division, or in the Circuit Court of the Eighth Judicial Circuit for Alachua County Florida. 
 
12. U.S. GOVERNMENT RESTRICTED RIGHTS: The Software and associated documentation are provided with 
RESTRICTED RIGHTS. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set 
forth in subdivision (c)(1)(ii) of The Rights in Technical Data and Computer Software clause at 52.227-7013 or 
subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted Rights at 48CFR52.227-19. The 
contractor is McTrans, University of Florida, PO Box 116585, Gainesville, FL 32611-6585. 
 
13. EXPORT REGULATION: The Software may be subject to U.S. export control laws, including the U.S. Export 
Control Reform Act and its associated regulations. End User will not directly or indirectly, export, re-export, or 
release the Software to, or make the Software accessible from, any country, jurisdiction or person to which export, 
re-export, or release is prohibited by applicable law. End User will comply with all applicable laws and complete all 
required undertakings (including obtaining any necessary export license or other governmental approval) prior to 
exporting, re-exporting, releasing, or otherwise making the Software available outside the U.S.  
 
14. INTEGRATION: This License Agreement is the complete and exclusive statement of the agreement between 
End User and McTrans and supersedes any proposal or prior agreement, oral or written, and any other 
communications between End User and McTrans relating to the subject matter of this License Agreement. This 
License Agreement may only be modified by a written agreement made subsequent to the date hereof and signed 
by both parties. 
 
15. SEVERABILITY: If any portion of this License Agreement shall be declared void or a nullity by a court of 
competent jurisdiction then the remainder shall survive and remain in full force. Should you have any questions 
concerning this license, you may contact the McTrans Center, University of Florida, PO Box 116585, Gainesville, 
FL 32611-6585, U.S.A., [1] (352) 392-0378. 
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According to the Federal Highway Administration (FHWA), TSIS-CORSIM has been used by FHWA for conducting 
research and applied by thousands of practitioners and researchers worldwide over the past 30 years, embodying 
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a wealth of experience and maturity. Volume 4 of the Traffic Analysis Toolbox (CORSIM Application Guidelines) is 
available on the FHWA traffic analysis tools home page: https://ops.fhwa.dot.gov/trafficanalysistools/corsim.htm. 
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 McTrans(TM), HCS(TM) and TRANSYT-7F(TM) are registered trademarks of the University of Florida. 
 HCS, HCS2022, HCS7, HCS 2010, HCS+, HSS, TRANSYT-7F, and T7F are copyright University of Florida. 
 TSIS-CORSIM2022, TSIS, CORSIM, NETSIM, FRESIM, TRAFED, TRAFVU, and TShell are copyright 

University of Florida, with portions copyright ITT Industries, Inc., Systems Division. 
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Getting Started 

System Requirements 
This section lists the minimum and recommended hardware requirements for installing and executing TSIS on a 
personal computer. Microscopic simulation is, by its nature, extremely processor intensive. Furthermore, a large 
network or lengthy simulation may generate hundreds of megabytes of vehicle and signal animation data. Thus, 
faster processors and larger disk drives are desirable when simulating large traffic networks. 

Hardware 

TSIS is a 32-bit application. Most computer systems that are available today are sufficient for hosting TSIS. 
However, some legacy systems may not be suitable for TSIS. Thus, we recommend the following: 

 Processor operating at 1.1 GHz or faster 

 A minimum of 1 GB RAM or more recommended 

Keep in mind that increased traffic network size and simulation time requires increased memory usage and disk 
space. Thus, to simulate a large network, a large amount of memory and disk space may be required for efficient 
operation and shorter run times. 

The following are required to install TSIS: 

 Installer file for TSIS, downloaded from McTrans 

 A minimum of 1GB of disk space for the fully installed TSIS package (not including the space required for 
the installation of operating system requirements) 

Operating Systems 

TSIS was designed to operate with the following Microsoft Windows operating systems: 

 Windows 8.1 or newer 

Installing TSIS-CORSIM 2022 
This section describes the procedure for installing the TSIS package and system support files. 

Installing TSIS 

When you run the installer file provided by McTrans it should launch the setup program. Upon acceptance of the 
agreement terms. the setup program will ask for a registration number that should have been delivered along with 
the software. The setup program will create the folder “C:\Program Files (x86)\FHWA\TSIS-CORSIM”, where all 
TSIS files, including examples, will be installed. 

Upgrading a Previous Version of TSIS 

You do not need to uninstall previous versions of TSIS before installing TSIS 2022. The installer will create a folder 
for TSIS 2022 (TSIS-CORSIM), which can coexist with previous installations of TSIS. For example: TSIS6.3 folder 
and TSIS-CORSIM (for TSIS-CORSIM2022) may be kept under “C:\Program Files (x86)\FHWA\. You may continue 
to use the older version as well as TSIS-CORSIM 2022.
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Adding or Restoring TSIS Components 

If you did not initially install the entire TSIS package, or if some of the original files have been changed, then you 
might want to run the installation again (to install the missing components or restore altered files). You may also do 
a “clean install”, by first uninstalling TSIS-CORSIM2022 (see “Removing TSIS-CORSIM2022” below) and then 
reinstalling the software again. 

Installation Notes 

You must have administrator privileges to install TSIS-CORSIM2022. After installation, any user can run it.  

Removing TSIS-CORSIM 

TSIS-CORSIM can be removed from your system using the Add/Remove Programs interface from the Windows 
Control Panel. Note that the uninstall process will not remove any files that have changed since installation, or any 
files that you have added. Thus, not all of the folders that the TSIS setup program added may be removed 
automatically. After uninstalling TSIS-CORSIM, you can manually delete the folders using the file explorer. 

TSIS-CORSIM may be also removed by using the Uninstall TSIS-CORSIM2022 executable, included in the 
installation package. 

Starting TSIS-CORSIM 
The setup program will add the TSIS-CORSIM2022 and TRANSYT-7F apps in your Start Menu programs section 
and desktop icon. To start TSIS-CORSIM, click on the Start button. Under TSIS-CORSIM2022, select “TSIS-
CORSIM2022”. You can uninstall the program by clicking on “Uninstall TSIS-CORSIM2022” under the same menu. 
You may also find TSIS-CORSIM2022 or TRANSYT-7F on Windows Search Tool, under the Apps category. 

TSIS-CORSIM stores user-specified preferences by user. As part of the startup process, TSIS-CORSIM restores 
those preferences to the state they had when you last used TSIS-CORSIM. It restores window size and position, 
tool definitions, and tool bar states and positions. 

When successfully launched, TSIS-CORSIM2022 will display the Welcome screen as shown below. Click on the x 
symbol to close it and start your project.
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About TSIS-CORSIM 

Introduction 
This guide describes how to install and begin using the Traffic Software Integrated System (TSIS). This guide is 
intended to support traffic engineers using TSIS to conduct traffic operations analysis. 

In preparing this manual, the authors assumed that you are familiar with the general operation of the Microsoft 
Windows platforms on which TSIS runs. For general help on using Windows, such as managing the operating 
system environment and using the file system, please refer to the Microsoft Windows user documentation provided 
with your computer or available online from Microsoft. 

Overview 
TSIS is an integrated modeling environment that enables users to conduct traffic operations analysis. Built using a 
component architecture, TSIS is a toolbox that allows the user to define and manage traffic analysis projects, model 
traffic networks, create inputs for traffic simulation analysis, run traffic simulation, and interpret the results of those 
models. 

CORSIM is a microscopic traffic simulation capable of modeling surface streets, freeways, highways, and integrated 
networks, including segments, weaves, merge/diverges, and intersections with stop/yield signs or traffic signals. It 
simulates traffic and traffic control systems using research-backed and established vehicle and driver behavior 
models. 

What’s New 
Updates added in TSIS-CORSIM 2022 

 Bing Maps can be added as a background to your network:  
o Links created on the map are the same length in real life / the Bing Map as shown in TSIS  
o Easy navigation to a specific street simply by typing keywords  
o Map location can be changed at any time, making it easy to make small adjustments to the location 

of your network  
o You can change between a typical map type or an aerial photo view, as well as enabling or disabling 

aerial labels  
 A modernized user interface for Windows 10 and 11 usability 
 Network data is now edited through the CORSIM (*.trf) file, which means no need to keep a separate 

TRAFED (*.tno) file 
 Output quick jump to quickly search through the extensive CORSIM text report  
 The ability to modify all entry node volumes and/or turn movement volumes with a growth factor  
 Graphical curvature can be added to links to show a more accurate representation of a network for modeling 
 Automatic link length scaling allows freedom from manually changing link lengths when moving nodes 

around  
 CORSIM feature support for two-lane rural highways, HOT lanes, toll plazas, and adaptive cruise control 
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Purchasing TSIS-CORSIM 
TSIS-CORSIM software is distributed by McTrans through the online store: https://store.mctrans.ce.ufl.edu/software 

McTrans Center Physical Address 

PO Box 116585 
Gainesville, FL 32611-6585 
tel: 1-800-226-1013 
fax: (352) 392-6629 
mctrans@ce.ufl.edu 
https://mctrans.ce.ufl.edu 

Reporting Problems and Technical Support 
We pride ourselves on providing support to our customers in an individualized way. Our customers only need to let 
us know their questions or where they stopped in their analyses, and the McTrans experts will get back to them to 
connect and offer suggestions and answers to questions. McTrans currently has an engineering team of half a 
dozen engineering experts. Some serve at the TRB Committee on Highway Capacity and Quality of Service and 
are highly involved with TRB simulation committees and ITE SimCap. Some have devoted more than a decade 
modeling demand and traffic for engineering consultancy and national-level research projects. 

Contact us via email at mctrans@ce.ufl.edu or call us at 800-226-1013.
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TSIS-CORSIM Package 

Components 
CORSIM 

The CORSIM simulation consists of an integrated set of two microscopic simulation models (NETSIM and FRESIM) 
that represent the entire traffic environment as a function of time. NETSIM represents surface-street traffic and 
FRESIM represents freeway traffic. Microscopic simulations model the movements of individual vehicles, which 
include the influences of driver behavior. Thus, the effects of very detailed strategies, such as relocating bus stations 
or changing parking restrictions, can be studied with such models. CORSIM provides its own interface in TSIS 6 
that enables you to control the simulation and the accumulation of traffic measures of effectiveness. See the 
CORSIM User's Guide for additional details. 

TRAFVU 

TRAFVU (TRAF Visualization Utility) is a legacy graphics post-processor for FHWA’s CORSIM microscopic traffic 
simulation system. TRAFVU provides an option for displaying traffic networks, traffic flow simulation animations 
compatible with multiple previous versions of TSIS. TRAFVU can display simulation output measures of 
effectiveness, and user-specified input parameters for simulated network objects. See the TRAFVU User's Guide 
for additional details. 

TRANSYT-7F 

TRANSYT-7F (TRAffic Network StudY Tool) is a traffic simulation and signal timing optimization program. 
TRANSYT-7F enhances the traffic signal analysis functionality of CORSIM in the following ways: 1) import CORSIM 
files and optimize their signal timing, 2) automatically generate input files for NETSIM 
http://mctrans.ce.ufl.edu/featured/TSIS/Version6/Optimization.htm, 3) compute level of service for NETSIM 
intersections, 4) generate time-space diagrams for NETSIM, and 5) generate summary text reports for CORSIM 
(network-wide outputs also reflect FRESIM results when applicable). 

Examples 
Installed automatically by the TSIS package are several example projects that demonstrate different features of the 
CORSIM model. These examples also help in understanding and using the Bing Maps interface. Additional sample 
networks may be available for download on the McTrans website or through the support channel. 

CORSIM City Demo 

This combined surface-street and freeway project demonstrates many the capabilities of the TSIS package in 
creating and simulating a wide variety of different roadway configurations and interchanges. 

Actuated Corridor 

This project models an actuated congested arterial corridor with three intersections. .trf TSIS-CORSIM and a .tin 
TRANSYT-7F compatible files are included 

Weaving Facility with OD 

This project demonstrates the operation of a weaving facility as part of an interchange. A seed OD matrix is set for 
the paths within the weaving. 

Two-Lane Highway Demo 

This project demonstrates two-lane rural highway passing and no-passing zones, producing performance measures 
compatible with the Highway Capacity Manual versions HCM6 (2016) and HCM7 (2022).
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TWSCStoragePockets 

This project models a two-way stop-controlled intersection within a corridor with short storage pockets for minor 
approaches, which may also represent a flared approach design. 

Toll Plaza 

This project models a toll plaza with one free lane and restriction for trucks o the rightmost lane. 

Documentation 
In addition to this guide, there are other supplemental guides provided with this package, allowing the user to go 
deeper in each TSIS component. These user guides are provided both as part of the TSIS help system and as PDF 
files on the installer. 

 CORSIM Reference Manual (Record Type manual) 

 TRAFVU User Guide 

 TRANSYT-7F Manual 

For additional information regarding the TSIS package and the CORSIM model, please visit the TSIS web site at: 
https://mctrans.ce.ufl.edu/tsis-corsim/. This site contains the latest information about new tools, product updates, 
known problems, example projects, training and other resources.
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General Controls 

Menu Items 

 

File 

New – Creates a new CORSIM input file (*.trf) and starts a new analysis project; shortcut is Ctrl+N 

Open – Opens an existing CORSIM input file (*trf); shortcut is Ctrl+O 

Close – Closes an open CORSIM input file (*.trf); shortcut us Ctrl+W 

Example Folder – Opens folder with TSIS-CORSIM examples in File Explorer 

Save – Saves an open CORSIM input file (*.trf) using the current file name; shortcut is Ctrl+S 

Save As – Saves an open CORSIM input file (*.trf) using a specified file name; shortcut is Ctrl+A 

Data Path – Opens a dialog to set the default path for opening and saving project files 

Recent Files – Files last accessed in the program appear in a list 

Exit – Exits the TSIS-CORSIM program; shortcut is F12 

Edit 

Find Node – Opens Find Node dialog to input node number and zoom in on specified node on map when 
Map View is open; shortcut is Ctrl+F 

Find Text – Opens Find dialog to search for text when Record Type Editor is open; shortcut is Ctrl+F 

Options 

Preferences – Opens Preferences dialog to allow editing of fields related to User Information, Surface Link, 
Freeway Link, Signal Control, and Output Files  

Run Properties – Opens Run Properties dialog to allow editing of fields related to Output Processing, 
Format and Options, and Multiple Run Properties 

Tools 

 Editors 

Map View – Opens CORSIM Map View; shortcut is F3 

Text Editor – Opens the Record Type Editor; shortcut is F2 

 Simulation 

CORSIM – Runs CORSIM, which processes the network file to generate output; shortcut is Ctrl+R 

CORSIM Multi-Run – Runs multiple CORSIM simulations at one time 

TRANSYT-7F – Exports and runs file in TRANSYT-7F 

 Viewers 

TRAFVU – Opens file in TRAFVU to allow simulation viewing
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CORSIM and TRAFVU – Runs both CORSIM and TRAFVU to generate output and view simulation 

Network 

Properties – Opens Network Properties dialog to allow editing of fields related to Time Periods, Description, 
Run Control, Random Seeds, Reports, Controllers, Vehicle Entry Headway, and Vehicle Types  

NETSIM 

Calibration – Opens NETSIM Setup dialog to allow editing of fields related to Amber Response, 
Bus Station Dwell Time, Cross Traffic, Discharge Headways, Pedestrians, Short-Term Events, 
Spillback, Start-Up Lost Time, Lane Changes, Lane Changes (Driver Behavior), Left/Right Turns, 
Driver Familiarity, Free-Flow Speed, and Jumped/Lagged Left-Turns 

Interchanges – Opens Interchanges (NETSIM) dialog to allow adding and deleting of interchanges 
by specifying node numbers and origin-destination inputs 

Link Aggregation – Opens Link Aggregation (NETSIM) dialog to allow adding and deleting of 
upstream and downstream nodes 

FRESIM 

Calibration – Opens FRESIM Setup dialog to allow editing of fields related to Driver Behavior, 
Free-Flow Speed, Friction Coefficient, Lane Change Parameters, Miscellaneous, and Value of 
Time 

Origin-Destination – Opens Origin-Destination (FRESIM) dialog to allow entering of origin and 
destination nodes, along with percent flow 

Vehicle Type O-D – Opens Origin-Destination (FRESIM) dialog to allow entering of origin and 
destination nodes, along with percent flow and vehicle type 

Two-Lane Highways – Opens Two-Lane Highways dialog to allow editing of various two-lane 
highway fields 

Two-Lane MOE Aggregation – Opens Two-Lane Highway MOE Aggregation dialog to allow 
adding, editing, and deleting of routes 

Bus Routes – Opens Bus Routes dialog to allow adding, editing, and deleting of bus routes between nodes 

Growth Factor – Opens Growth Factor dialog to allow editing of ‘Entry Volume Change’ and ‘Turn Volume 
Change’ fields 

Window 

Tile – Files appear in row form for side-by-side analysis 

Cascade – Places the current files into smaller windows to allow a better view of multiple files 

Help 

TSIS-CORSIM User Guide – Opens TSIS-CORSIM user guide 

CORSIM Reference Manual – Opens CORSIM reference manual 

TRAFVU User Guide – Opens TRAFVU user guide 

Support 

FAQ – Opens the McTrans FAQ page for TSIS in the default web browser 

E-mail – Composes a new e-mail addressed to McTrans in the default e-mail client 

Phone – Opens window displaying McTrans customer support phone numbers 

Training – Opens the McTrans store in the default web browser to view the latest training 
opportunities



____________________________________________________________________________________________________ 
 14 · General Controls   TSIS-CORSIM User Guide 

Check for Updates – Sends the TSIS version number anonymously without any personally identifiable 
information to McTrans to check for a newer version 

About TSIS – Opens an about window with software version information, EULA, general 
acknowledgements, contact information, and other relevant links 

Toolbar Icons 
 New – Creates a new CORSIM input file (*.trf) and starts a new analysis project 

 Open – Opens an existing CORSIM input file (*trf) 

 Save – Saves an open CORSIM input file (*.trf) using the current file name 

 Run CORSIM – Runs CORSIM, which processes the network file to generate output 

 Run TRAFVU – Opens file in TRAFVU to allow simulation viewing 

 Run Multiple – Runs multiple CORSIM simulations at one time 

 Run Properties – Opens the Run Properties dialog to allow editing of fields related to Output Processing, 
Format and Options, and Multiple Run Properties 

 Map View – Opens CORSIM Map View 

 Run CORSIM and TRAFVU – Runs both CORSIM and TRAFVU to generate output and view simulation 

 Abort the current run – Stop the current run 

 TRANSYT-7F – Opens and runs file in TRANSYT-7F 
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How To 

Create a New File 
1. There are three options for creating a new file:  

Note: A new file can be created if an existing file is already open. 

a. Selecting File > New from the main menu 

 

b. Selecting the New icon from the toolbar 

  

c. Using the keyboard shortcut “Ctrl+N” 

2. Once a new file is created, the Network Properties dialog will open
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Open an Existing File 
1. There are five options for opening an existing file:  

Note: A file can be opened even if another file is currently open. 

a. Selecting File > Open from the main menu 

 

b. Selecting the Open icon from the toolbar 
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c. Using the keyboard shortcut “Ctrl+O” 

d. Selecting a file under the Recent files list under File 

 

e. Selecting File > Example Folder from the main menu. Opening the example folder will open the 
path of the TSIS-CORSIM example files in File Explorer. The desired example file can be double-
clicked or right-clicked and selecting ‘Open’, which will open the example file in the TSIS-CORSIM 
program. 

 

2. Once an existing file is opened, the Network Properties dialog will open 
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Save a File 
1. There are six options for saving an open file: 

a. Selecting File > Save from the main menu 

  

b. Selecting File > Save As from the main menu 

 

c. Using the keyboard shortcut “Ctrl+S” for Save 

d. Using the keyboard shortcut “Ctrl+A” for Save As 

e. Selecting the Save icon from the toolbar 
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f. Exiting the program or closing the file without saving changes beforehand; this will prompt you to 
save changes to the file before anything is closed  

 

i. Selecting “Yes” will save the file if it is an existing file. If the file has not been previously 
saved, the Save As dialog box will pop up allowing you to change the file name and save 
it. 

ii. Selecting “No” will exit the program or close the file without saving the file 

iii. Selecting “Cancel” will prevent the file from closing 

Notes:  

Using Save with an existing file will save a file without prompting you to specify a file name. Using Save with a new 
file will bring up the Save As dialog box for you to specify a file name for saving. Using Save As will always bring 
up the Save As dialog box for you to specify a file name for saving. 

Once a file is saved, the option Save is disabled until any change is made to the model. 

Close a File 
1. There are three options for closing an open file: 

a. Selecting File > Close from the main menu 

  

b. Using the keyboard shortcut “Ctrl+W” for Close 

c. Exiting the program itself; please see How To: Exit the Program



____________________________________________________________________________________________________ 
 20 · How To    TSIS-CORSIM User Guide 

Exit the Program 
1. There are three options for exiting the program:  

Note: The program can be exited even if a file is still open.  

a. Selecting File > Exit from the main menu  

 

b. Using the keyboard shortcut “Alt+F4” 

c. Selecting “X” in the top right-hand corner of the screen 
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Map View 

TSIS-CORSIM features a map view user interface, allowing for editing the model and visualizing the animation 
output. 

Bing Maps Configuration Toolbar 
Map View with Bing Maps is opened through the Tools > Editors > Map View menu item (F3 shortcut), or by clicking 

on the button  . The Map View contains its own set of toolbar icons, listed below: 

 Shortcut Information – Shows a list of applicable keyboard shortcuts 

 

 

 Map Properties – Allows editing background map properties. This command opens the Window shown 
below, with the options listed below. All changes are applied upon clicking the ‘Apply’ or ‘OK’ buttons on the bottom 
of the window. 

Global 

Background Color – Allows changing background colors (areas with no maps) 

Post-process animation options – Selects which features are to be included in the animation produced 
by the simulation; options include indices, vehicles, and signals 

Scale node radius with zoom level – Nodes are enlarged as the user zooms in
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Node radius – Defines the size nodes are shown over the maps background 

Background 

Bing Maps (Edit Location) – Allows choosing real locations with Bing Maps 

Image from File – Allows selecting of an image file to serve as a background. Upon selecting this option, 
the user is prompted to choose a local *.jpg, *.jpeg, *.png, *.bmp, or *.gif file. 

No Background – No maps or images are used as a background. This option keeps the color chosen 
under the Global box as a solid background. 

Origin (X) and Origin (Y) – Refer to the number of pixels from the reference point to be defined as the 
origin of the background. 

Reference Point – Defines the map location used as the origin of the image 

Ratio of Image Pixels to TSIS Twips – Allows configuring how much each pixel represents in terms of the 
actual distance modeled on TSIS-CORSIM. The higher the number, the larger the map will be displayed 
on the screen. 

 

 

 Edit Bing Maps Location – Allows editing background map properties; the location on Bing Maps can be 
edited by dragging the map with the mouse. 

Map Photo Type – Allows selection of type of map shown; options include Roads, Aerial (Without Labels), 
and Aerial (With Labels) 

Zoom to Location – Finds a location by typing an address or road names 

Enable Scale Bar – Shows a scale bar, in feet, on the map 

Enable Automatic Map Scaling – When automatic map scaling is enabled, the map background image 
will be scaled so that the scale bar fits to scale with TSIS. For example, when the map scale is 100 ft, the 
scale bar will fit exactly within two TSIS axis lines.
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Editing Toolbar 

 Add Entry/Exit Node – Adds origin-destination nodes 

 Add Interface Node – Adds interface nodes between urban and freeway links 

 Add Node – Adds all other node types 

 Add Two-Way Surface Link – Adds two-way surface street links 

 Add One-Way Surface Link – Adds one-way surface street links 

 Add Freeway Link – Adds one-way freeway links 

 Pointer – Used to select model elements 

 Center To Cursor – Centers screen on the cursor 

 Zoom In – Zooms in one level or to a selected area 

 Zoom Out – Zooms out one level
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 Show All – Adjust zoom level to show the entire model 

 Background Scaling – Allows configuring how much each pixel represents in terms of the actual distance 
modeled on TSIS-CORSIM (Ratio of Image Pixels to TSIS Twips) 

 Show Link Lengths – Shows link length labels in feet 

 Show Link Free-Flow Speed – Shows link free-flow speed labels in mph 

 Show Link Names – Shows link name labels 

 Show Node Numbers – Shows node number labels 

 Show Grid Lines – Shows grid lines 

 Show Background – Shows any background map image 

 Show Lane Graphics – Shows detailed lane graphics 

 Show Vehicles – Shows vehicles when animation is running 

 Animation Controls – Allows playing, pausing, and reversing the 
animation with three speed options (i.e., Fast, Normal, Slow); also shows number of vehicles that have traveled 
through the facility; animation controls are enabled when vehicles are shown
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Glossary of Terms 

ACC  
Adaptive Cruise Control 

ATMS 
Advanced Traffic Management System 

Case 
A single simulation for a specified traffic network as defined by its simulation input file. A case includes the simulation 
input file and all data files generated by the simulation during a run. Multiple runs of the simulation for gathering 
statistics are still considered part of a single case provided the input has not changed. 

CORSIM 
CORridor SIMulation. A microscopic traffic simulation tool supported by the TSIS environment. 

DOT 
Department of Transportation 

FHWA 
Federal Highway Administration. Sponsor for the development of the TSIS suite of traffic analysis tools. 

FRESIM 
FREeway SIMulation. The part of the CORSIM simulation that models freeway operations. 

GUI 
Graphical User Interface. An interface between a user and a software tool, consisting of graphical elements and 
controls (e.g., windows, dialogs, buttons). 

HOV 
High Occupancy Vehicle. A term generally used to describe roadway lanes (facilities) that are reserved for vehicles 
that contain more than one occupant. 

HTML 
Hypertext Markup Language. A system of marking up or tagging a document so that it can be published on the 
World Wide Web. It is used to display TSIS on-line help.
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MOE 
Measure of Effectiveness. One of several statistics, generated by the simulation, that indicates the state of traffic 
flow within the network. 

NETSIM 
NETwork SIMulation. The part of the CORSIM simulation that models surface-street operations. 

Text Editor 
This editor is a standard text editor that has the additional capability of "understanding" the CORSIM TRF file format. 
When editing a TRF file with this editor, the TShell output window displays text describing the entry field and record 
type at the current cursor position. Clicking a specific field description in the output window highlights the 
corresponding entry field in the displayed TRF file. 

TRAFVU 
TRAFVU (TRAF Visualization Utility) is a user-friendly graphics post-processor that displays traffic networks, 
animates simulated traffic flow operations, animates and displays simulation output measures of effectiveness, and 
displays user-specified input parameters for simulated network objects. 

TRANSYT-7F 
TRAffic Network StudY Tool. TRANSYT-7F is a traffic simulation and signal timing optimization program. 
TRANSYT-7F enhances the traffic signal analysis functionality of CORSIM in the following ways:  

1) import CORSIM files and optimize their signal timing, 

2) automatically generate input files for NETSIM, 

3) compute level of service for NETSIM intersections, 

4) generate time-space diagrams for NETSIM, and 

5) generate summary text reports for CORSIM (network-wide outputs also reflect FRESIM results when 
applicable). 

TRF 
A file that contains the input data used to define a CORSIM network and to drive the CORSIM simulation for a single 
simulation case. 

TSIS 
Traffic Software Integrated System. TSIS is the integrated development environment that hosts the CORSIM 
simulation and its support tools. 
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